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Notational conventions
This section describes notational conventions used in this book.

bold monospace In  command examples,  bold 
monospace identi f ies input that must 
be typed exact ly as shown.

monospace In  paragraph text,  monospace 
identi f ies command names,  system 
ca lls ,  and data structures and types.  
In command examples,  monospace 
identi f ies command output, 
including error  messages.

italic In  paragraph text,  italic identi f ies  
t i t les of  documents.
In command syntax diagrams, italic 
identi f ies var iables that you must 
provide.
The fol lowing command example 
uses brackets to indicate that the 
variable  output_file is  optional :
command input_file [output_file]  

Brackets (  [  ]  ) In  command examples,  square 
brackets designate optional  entries .

Curly brackets ({} ),
P ipe (|)

In command syntax diagrams, text 
surrounded by curly  brackets 
indicates a choice.  The choices 
avai lable  are shown inside the curly 
brackets and separated by  the pipe 
sign (|) .
The fol lowing command example 
indicates that you can enter ei ther a 
or b:
command {a | b}

Horizontal e l l ipses 
( . . .)

In  command examples,  horizonta l 
e l lipses show repetit ion of  the 
preceding i tems.  

Vert ical  e l l ipses
.
.
.

Vert ica l e l l ipses show that l ines of 
code have been left  out of an 
example.

Keycap Keycap indicates the keyboard keys 
you must press to  execute the 
command example.
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1 Introduction

WebConnect enables enterprise organizations to provide suppliers, 
partners and employees with secure access to vital mainframe and 
midrange applications and information. Enterprises increase 
productivity and profits while retaining all the advantages of secure 
host connectivity to new and existing applications in “real-time.” 
WebConnect provides this access without requiring any 
modifications to the original application, providing reliable, secure, 
and scalable host access using a Java™ or JavaScript enabled Web 
browser. To deliver traditional host-access emulation features over 
an intranet or the Internet, WebConnect combines the strengths of 
traditional client/server technology with the network access and 
ease of use of popular browsers and client technologies. The 
WebConnect servers on UNIX and Windows are all secured by Secure 
Sockets Layer (SSL) authentication and encryption or RSA Data 
Security™ encryption.

This chapter contains information about the following subjects:

• ”WebConnect Features” on page 18.

• ”Full-Featured Emulation” on page 18.

• "User Manual layout," page 18.

• ”Client Technologies” on page 18.

• ”Browser Environment and Java Support” on page 19.

• ”Identifying the Client Type” on page 19.

• ”Identifying client type by visual clues within the interface” on 
page 20.

• ”Network Environment” on page 22.

• ”Browser Support” on page 23.

• ”SFile Access Authority” on page 23.



18 

WebConnect Features  

WebConnect User Guide

WebConnect Features
WebConnect provides all the features of traditional emulation clients 
with centralized server management. Java applets, clients, and HTML 
clients for 3270, 3287 print, 3812 print, 5250, VT, including VT/SSH 
emulations.

Full-Featured Emulation
In addition to traditional client emulation features, WebConnect also 
includes TN3270E protocol support, screen print, enhanced copy 
and paste, hot spots, record and play macros, Visual Basic macros, 
and IND$FILE file transfer. Administrators or end users can modify 
user interface options such as keyboard and color mappings.

User Manual layout
This user manual describes features and configuration options for all 
supported client types and underlying technologies. The table of 
contents of this manual clearly shows which chapters apply to which 
client types by embedding the client type name (Classic, Swing, or 
HTML) into the chapter title. Small differences may exist between 
client types and as such are documented within their respective 
chapters. However, most features are supported in a similar fashion 
across Swing (Java 1.5+) clients and significant training differences 
would not be expected. In general, features and configuration 
options are discussed within the context of their position within the 
client user interface menu system.

Client Technologies
WebConnect can be configured to provide secure communication to 
your host environment across a variety of underlying client 
technologies including:

• Classic applet (Java 1.1+)

• Swing applet (Java 1.5+)

• HTML client (HTML 1.0).

Additionally, the Classic applet allows a basic 1-for-1 screen refacing 
called AutoVista. AV clients have limited user menu preferences.
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The WebConnect Administrator determines which client is available 
to the end user. Even though a given WebConnect server can 
support a mix of different client technologies, only one type of client 
should be deployed to any one desktop. So, the end user runs a Java, 
or HTML client, but not more than one type on a given desktop at 
the same time. However, users may be able to switch between client 
types based on their WebConnect login user identification if so 
configured by the WebConnect Administrator. In general, most client 
populations run the same underlying client technology.

Another consideration in the choice of client technology is whether 
a persistent or non-persistent communications channel (socket 
connection) is required. Since the client is an application program 
executed within a browser interface which provides most of the 
application user interface, Java clients are fairly small in size, 
cross-platform compatible, and highly secure. Their persistent applet 
TCP/IP connection offers the full range of mainframe updates, such 
as unsolicited data writing.

The HTML client is a program written in Java Script and executed 
within a Java Script capable browser interface. The underlying HTML 
protocol provides a non-persistent access method that is more 
suited to request/response oriented applications. Your WebConnect 
Administrator has determined which WebConnect client to use 
based on the network environment, the browser used, and the 
required features.

Browser Environment and Java Support
Java applets are being deprecated at the time of this writing and the 
only environment available for Java applets is Internet Explorer with 
a current JRE version from Oracle. 

Identifying the Client Type
If you are not sure what client type you are running, it is best to 
contact your WebConnect Administrator or help desk. However, the 
following may help you determine which client type has been 
configured for you and allow you to determine which chapters 
within this user manual apply to your specific client type.
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Identifying client type by visual clues within the interface

Figure 1-1: Classic Client

Figure 1-2: Swing Client



Browser Environment and Java Support

Chapter 1—Introduction 21

Figure 1-3: HTML Client
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Figure 1-4: HTML5 Client

Network Environment
The network environment in which WebConnect is accessed and 
operates affects the decision to choose one applet over another, as 
well as whether to use WebConnect security features. WebConnect 
Java applets are downloaded to the browser platform the first time 
the client is started during a browser session. When you exit the 
browser, the applet no longer resides on the browser platform. This 
allows the administrator to maintain software and software 
configurations on the server while the client platform is updated. 
The amount of time needed to download a client emulation applet 
depends on the network connection. WebConnect security features 
can be a necessity, depending on the sensitivity of data accessed 
and the security of the network used.

Security features require encryption key generation and data 
encryption and decryption. The security feature decision is based on 
speed versus security. If an end user is using the corporate intranet 
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and not accessing sensitive data, RSA or SSL might not be required. If 
an end user is using the Internet and accessing sensitive corporate 
data, security must be a high priority.

Browser Support
WebConnect operates on the following browsers:

• HTML Client requires a browser that includes “cascading style 
sheets or layers” (IE 5.0+ or Safari 1.0.2 or 1.2).

• Classic Applets require a browser that supports Sun's Java Dev. 
Kit 1.1

• MSIE - Microsoft Internet Explorer Version 5.0.1+ with JVM Build 
3802 or greater.

• SAFARI - Safari 1.02 & 1.2 w/JDK 1.4.2

SFile Access Authority
Some WebConnect features require additional security measures 
because the applet must access local system resources. Security is 
provided by certificates that are included with the applets and 
verified by the browser. When the browser attempts to execute the 
applet, it encounters a certificate delivered with the applet that 
details the developer of the applet and the local file system access 
required. The browser then displays a window prompting the user to 
choose whether to grant the local file system access. If the user 
chooses to trust the applet by granting the access, the applet begins 
and all functionality becomes available for use. The user can grant 
the privileges on a temporary or permanent basis. If privileges are 
granted temporarily, future applet sessions require the user to grant 
privileges again. If privileges are granted permanently, subsequent 
downloads and use of the applet automatically grants privileges. The 
certificate and privileges can be removed from the browser under 
the Security or Certificates section of the browser. The following 
WebConnect features require access to the local resources:

The ability to write to the disk and store user configuration files for 
key maps, color maps, etc.

• The ability to use the local print spooler for “print screens” and 
3287 print.
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• The ability to access the local clipboard for copy and paste 
functionality.

• The ability to access the local file system to retrieve and store files 
for file transfer operations.
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2 Using 
WebConnect

This chapter contains information about the following subjects:

• ”Session Folders” on page 26.

• ”Navigation” on page 27.

• ”User Menu” on page 28.

• ”LOGOUT” on page 28.

• ”PREFERENCES” on page 28.

• ”IDENTITY” on page 28.

• ”DOWNLOADS” on page 28.

• ”Preferences” on page 29.

• ”View” on page 30.

• ”Printing” on page 30.

• ”Trace Each Session” on page 31.

• ”Store User Files On:” on page 32.

• ”Store User Files On:” on page 32.

• "Single Sign-On," page 32

• ”Password Management” on page 32.

• "Password Length and Strength," page 33
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Sessions Panel
The SESSIONS panel, shown in Figure 2-5, is the initial user panel 
displayed by WebConnect and provides access to pre-configured 
sessions, user-configurable preferences, settings, and other 
components implemented by your System Administrator. 

Figure 2-5: SESSION Panel Default View

Configuration settings made by the WebConnect Administrator 
affect the appearance of the end user interface. If your Administrator 
has enabled support for Session Folders for example, the SESSIONS 
panel could look similar to Figure 2-7. Refer to following section, 
”Session Folders” on page 26, for more information about session 
folders.

Session Folders
The Session Folders feature allows the WebConnect Administrator to 
organize session icons into logical groups. Session folders are stored 
at the server level and can be shared by all users. The Administrator 
also specifies the default starting folder. 

Session Folders can be viewed in Icon or List mode. Refer to 
”Preferences” on page 29 for details about these settings.
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Figure 2-6: SESSION Panel Folders Enabled View

Navigation
Session folders are navigated in much the same manner as folders 
are in Windows. Clicking on a folder icon opens a view of the 
sessions contained in that folder similar to Figure 2-7, on page 28. 
The folder name is displayed at the top panel, followed by the folder 
description, if any. 

The first icon on the left which is marked with the diagonal arrow, as 
shown in Figure 2-7, on page 28 allows the user to return to the main 
folder list when clicked. Clicking on any session icon within a folder 
starts that session in the normal manner. 

Note: To view all of the session icons that are contained in all of the folders 
simultaneously, simply click on the All Sessions folder. 
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Figure 2-7: SESSION Folder

User Menu
The user menu is located on the left side of the user window as 
shown in Figure 2-5. The menu contains the following options:

LOGOUT

Logs the current user out and displays Login screen. 

PREFERENCES

Select from the user preferences made available by the WebConnect 
administrator.

IDENTITY

If your administrator has enabled authentication, IDENTITY displays 
in the menu list as shown in Figure 2-5, page 26. You can select it and 
change your WebConnect password. It also displays information 
about your last login and a count of failed login attempts. For more 
information about passwords see ”Password Management” on 
page 32.

DOWNLOADS

Select additional WebConnect components to download and install. 
See Chapter 3 for more information about downloads.
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SESSIONS

Select from various WebConnect administrator configured 
emulation sessions. For more information about the Session Panel 
and emulation clients, see Chapter 4, "Classic Client Sessions," 
Chapter 15, "HTML5 Componentless Sessions,"  Chapter 14, "HTML 
Client Emulation." 

Display Language

To change the display language, click the desired language on the 
user menu on the left, as shown in Figure 2-8. The choices are 
English, French, Dutch, and Spanish. The display language 
automatically changes to the selected language.

HELP

Displays the WebConnect User’s Guide in PDF format.

Preferences
Click PREFERENCES on the menu and the window shown in 
Figure 2-8 appears. Individual user configurable options can be set 
from this window.

Note: Features available from the PREFERENCES window have been defined by 
the system administrator and may not include all of the options 
discussed and shown here.
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Figure 2-8: Swing Client PREFERENCES Window

View
Select PREFERENCES from the user menu, shown in Figure 2-5, to 
set one of the following view options:

Icon View 

Display session type and session name in the SESSION panel with 
large icons.

List View

Display session type and session name in the SESSION panel in a list 
format with small icons.

Printing
Click the Printing checkbox and choose a print method from the 
following options:

WebPrint

For complete information see Chapter 5, "Classic Client Printing." 

JDK Print solution

Uses the built-in Java solution. No additional installation is required.
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JavaScript print option

Print to a browser window where the browser print facilities are 
invoked to send the output to the printer. JavaScript printing does 
not support formatting controls, such as font size or character 
spacing view.

Print to File

Print to a file on the local machine. Select print and a dialog box 
displays the file you are printing to and the following options:

Figure 2-9: Print to File Dialog

• Browse to select another file

• Append to append the current print job to a selected file

• Overwrite prints only the current job to the file (erasing the 
contents of the previous file)

• Cancel to abort the print job

The data in the file is “text only” with no attributes. Character 
encodings are converted to the platform default, see Figure 5-27, on 
page 67.

Trace Each Session
When technical difficulties occur with user sessions, a Help Desk 
Representative may instruct you to do a trace. If this situation occurs, 
these trace files are extremely helpful in diagnostic troubleshooting.

1. Select PREFERENCES from the user menu. See Figure 2-5, 
page 26. 

2. Check the Trace Each Session check-box before opening any 
sessions. By checking this box, you create a trace for every 
session you start.
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If your Help Desk Representative provides a filename, you can type it in 
the Trace Filename box. However, you should not enter a filename 
unless you are specifically instructed to do so.

Store User Files On:

Server 

Store user files on the WebConnect server system.

Desktop

If your administrator enables this option your user files can be stored 
on the local machine (desktop).

No user files:

You can also choose not to store files, such as Key Maps, or Hotspots, 
etc.

Single Sign-On
This option only displays in your menu options if your administrator 
has enabled it. However, you should only disable it if you are 
instructed to do so by your administrator or Help Desk 
Representative. Refer to the WebConnect Configuration and 
Administration Guide for more information about SSO.

Password Management
If the WebConnect administrator has enabled strong passwords, the 
following rules and conditions apply. 

Password strength is checked at logon and whenever it is changed. If 
the current password does not meet the required strength, you are 
prompted to supply a stronger password. 

Note: Users should reset (deselect) the “Trace Each Session” feature on the 
Preferences window after tracing a file so that traces do not continue to 
collect in the traces directory.
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Figure 2-10: Changing your Password

Password Length and Strength
The following tests are applied to passwords to determine their 
strength:

Number of character classes - The password is scanned to count 
the number of characters in the following categories: upper case 
alphabetic, lower case alphabetic, numeric, and other. Due to 
common usage patterns, an upper case alphabetic at the start of the 
password or a numeric at the end does not count toward the 
number of distinct classes found.

Password length - The minimum length of a password is coupled to 
the number of character classes found in the password. A password 
with 3 or 4 classes requires a minimum length of 8 characters. One 
with only 2 classes requires a minimum of 24 characters. The 
maximum allowed length is 80 characters.

Similarity to userid - A portion of the user's id cannot be used 
within a password. A 4 character or better match is considered 
similar. A reversed character sequence can also qualify as a match if 4 
characters or more.
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Similarity to prior password - When changed by the end-user, the 
current password is required as part of the change process. The new 
password is checked for similarity to the old password. A 4 character 
or better match is considered similar. A reversed character sequence 
also qualifies as a match if 4 characters or more.

Dictionary - The password is checked against a 4096 entry 
dictionary of common words. 

Password History

In addition, the password history mechanism precludes reuse of the 
current or 5 prior passwords. 

Password Examples

Character classes

The password “Abcd+++efg1” would appear to have 4 classes 
at first (upper case, lower case, numeric, other) but the upper 
case “A” and the numeric “1” don't count since they are at the 
start and end. This password is considered to have only 2 
classes. The password “abcd+1+Efg+” counts for all four 
classes since the upper case and numeric are in the body of 
the password.

Similarity to user id 

The password for userid “tester” cannot contain any substring 
of four characters or more of “tester”. The password 
“esteA1234+” is not valid since it contains the substring “este” 
from “tester”.

Similarity to prior password

The new password “abc0123XYZ&” cannot be used to replace 
password “MNO0123qrs*” since it contains the substring 
“0123” from the old password.

Dictionary

The dictionary contains the word “gene”, invalidating 
password “gene01ABCD+”.

Character Limitations for Passwords and User Names

The following special characters should not be used in either 
Passwords or User Names:



Password Management

Chapter 2—Using WebConnect 35

Tabl e 2-1: Invali d Ch aract ers

Na me Charac ter

Ampersand &

Angle Brackets < >

Aster i sk  *

BackSlash/S la sh \ /

Brackets [ ]

Colon :

Coma ,

Double  Quotat ion "

Pipe |

Plus  S ign +

Quest ion  Mark ?

Semicolon ;

Equals =

Parenthesis ()

Curly Bra ces {}

S ing le  Quotat ion ’
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3 Downloads

This chapter contains information about several additional 
components for WebConnect:

• ”Downloads with Java Runtime Environment (JRE)” on page 38.

• ”Installing WebPrint” on page 38.

• ”Uninstall WebPrint” on page 39.

• ”Installing the WebConnect Emulation API Package” on 
page 39.

• ”Downloads with Desktop Emulator Enabled” on page 40.]

• ”Installing WebConnect Desktop Emulator” on page 40.
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Downloads with Java Runtime Environment (JRE) 
When you select DOWNLOADS from the user menu the following 
window displays.

Figure 3-11: User Downloads

Installing WebPrint
WebPrint provides advanced printing capabilities for WebConnect 
applets.

Complete the following steps to install WebPrint.

1. Click DOWNLOADS on the user menu.

2. Click Install WebPrint as shown in Figure 3-11 above. 

The Install WebPrint for Java window displays OCWebPrint.exe, a 
zipped, self-extracting, executable file.

3. Click Download.

4. You are prompted to choose the download path on your system, 
and OCWebPrint.exe is saved to the path selected.

5. Execute OCWebPrint.exe from the saved location and follow the 
prompts to install WebPrint. 
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6. You must close and restart your Web browser to invoke the 
installation.

Uninstall WebPrint
To uninstall WebPrint see the windows control panel. 

Select Start>Settings>Control Panel>Add/Remove programs and 
follow the prompts to uninstall WebPrint.

Installing the WebConnect Emulation API Package
The WebConnect Emulation API Package provides COM (ActiveX) 
object API and EHLLAPI capabilities for WebConnect applets. Refer to 
the WebConnect Com Object Guide and the WebConnect EHLLAPI 
Reference Guide for more information about the WebConnect 
Emulation API Package. 

Complete the following steps to install WebConnect Emulation API 
Package.

1. Click DOWNLOADS In the SESSION panel, the 
DOWNLOADS window displays.

2. Click Install WebConnect Emulation API Package to open the 
installation window. 

3. Click Start Download.

4. Choose to save to disk and designate where to save 
wcemuapi.exe.

5. Terminate all WC 3270/5250 sessions.

6. Execute wcemuapi.exe and follow the prompts to install 
WebConnect Emulation API Package. 

7. Start your 3270/5250 sessions

Uninstall the WebConnect Emulation API Package

1. To uninstall see the windows control panel. 

2. Select Start>Settings>Control Panel>Add/Remove programs 
and follow the prompts to uninstall WebConnect Emulation API 
Package.
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Downloads with Desktop Emulator Enabled
When you select DOWNLOADS from the user menu and the 
WebConnect administrator has enabled download of the desktop 
emulator, the download page includes the WebConnect Desktop 
Emulator section as seen Figure 3-11, on page 38.

Installing WebConnect Desktop Emulator
The WebConnect Desktop Emulator provides a Windows application 
to access WebConnect Emulation Sessions without use of a web 
browser. See Chapter 20, "Desktop Emulator" for more information 
about the WebConnect Desktop Emulator.

Complete the following steps to install the WebConnect Desktop 
Emulator.

1. Click DOWNLOADS on the user menu.

2. Click Install WebConnect Desktop Emulation Package as shown 
in Figure 3-11, on page 38 above.

The Install WebConnect Desktop Emulator window displays 
WCDesktopApp.msi, a standard Windows Installer file.

3. Click Start Download.

4. You are prompted to run or save the installer file. Either execute 
the installer directly from the browser via the Run button or save 
the installer file and then execute from the saved location.

5. Follow the installation prompts to install the Desktop 
Application. You will need appropriate values for the portal 
configuration during the installation. These values will be 
provided by your WebConnect administrator.
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4 Classic Client 
Sessions 

This chapter contains information about the following subjects:

• ”Session Panel” on page 42.

• ”Controller Applet” on page 42.

• ”3270, 5250, and VT Client Emulation Features” on page 44.

• ”Menu Bar” on page 45.

• ”Macro Toolbar” on page 47.

• ”Session Toolbar Menu” on page 48.

• ”Emulation Space” on page 49.

• ”ClickPad” on page 50.

• ”Copy and Paste Features” on page 50

• ”3287 Client Emulation Features” on page 53.

• ”Menu Bar” on page 53.

• ”Session Window” on page 53.

• ”3812 Client Emulation Features” on page 54.

• ”Menu Bar” on page 54.

• ”Session Window” on page 54.

• ”Macro Record/Play” on page 55.

• ”Recording a Macro” on page 57.

• ”Saving a Macro File” on page 58.

• ”Playing a Macro” on page 59.

• ”Stopping a Macro During Play” on page 60.

• ”Deleting a Macro” on page 60.



42 

Session Panel  

WebConnect User Guide

Session Panel
The SESSION panel, shown in Figure 4-12, is the initial user window 
displayed by WebConnect and provides access to pre-configured 
sessions, user-configurable preferences, settings, and other 
components that have been implemented by your System 
Administrator. 

Figure 4-12: SESSION Panel

To initialize a session, click a session type icon in the SESSION panel. 
The emulation session opens in a separate window.

Controller Applet
If the WebConnect Administrator has enabled the Session Controller 
Applet feature, clicking on a session type icon in the SESSION panel of 
the HTML user interface opens a controller applet window followed 
by the emulation session itself. Figure 4-13 shows a Session 
Controller Applet with several sessions open.

Note: Do not use Pop-up Window Blockers as they can prevent the JRE 
placeholder window from starting. Disable all Pop-up Window Blockers.
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Figure 4-13: Session Controller Applet

The controller applet provides the means to manage multiple open 
sessions. It displays a list of all active sessions, grouped by default 
into emulation types and identified by their session ID number. 
Enabling Session Folder displays the folder names. Your WebConnect 
administrator can also specify custom group names.

Clicking a session in the controller applet's session list brings that 
session window to the foreground. Sessions that have been 
terminated due to network conditions or by the WebConnect Server 
appear in red. Sessions can also be individually or collectively 
stopped by using the Terminate Sessions or the Terminate All 
Sessions buttons. Figure 4-13 shows the Controller Applet with 
several sessions open. The first session in the list, the 3270-session 
number 28, is marked for termination. 

The controller applet also eliminates the need for the matching 
HTML window necessary to avoid the premature closing of a session 
by the JRE.



44 

3270, 5250, and VT Client Emulation Features  

WebConnect User Guide

3270, 5250, and VT Client Emulation Features
The 3270, 5250, and VT client emulation applets have similar user 
interfaces and share many interface features. The client window has 
a Menu Bar, an Emulator Screen Toolbar, a Macro Toolbar, an 
Emulation Space, and an optional ClickPad as shown in Figure 4-14 
below.

Figure 4-14: Client Window 

Click Pad
Enabled

Toolbar
Enabled

Toolbar
Enabled

Macro
Toolbar 
Enabled

Macro
Toolbar 
Scroll Button
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Menu Bar
Your administrator can enable different menu options for your user 
ID; therefore, all of the following functions may not be visible (3270, 
5250 and VT) on your Menu Bar.
Tabl e 4-2: S essi on  M en u Opti on s  (S hee t 1 of  2)

Me nu Defi ni ti on

F i le

New—opens a new session. If the session controller applet is 
enabled, the File>New option is unavailable. In that case, new 
sessions must be started from the main sessions panel of the user 
interface. 
Print Screen—prints the current screen.
Log Session to Printer—while enabled text displayed on the VT 
session is echoed to the printer.
Log Session to File—while enabled text displayed on the VT 
session is echoed to a file. 
Assoc Print Session—activates a user’s print option.
Macro Rec/Play—Play Macro (Stop Macro), Record Macro, Stop 
Recording, Cancel Recording, Delete Macro, and Save Macro.
Save User Settings—saves the user’s settings to the desktop.
File Transfer—transfers files between a Java client and an SNA host. 
Exit—closes the emulation window and exits the session.

Edi t

Copy—copies highlighted text from the screen to the clipboard.
Copy and Append—copies and appends (adds) data to the 
clipboard without destroying existing clipboard data.
Paste—paste the copied text from the clipboard to the highlighted 
area of the window.
Select All—selects the entire screen to be copied and pasted.

Preferences—Opens the following menu options:
Key Maps—edit the Key Maps for this session.
Hot Spots—edit the Hotspots for this session.
Colors—edit the Colors for this session. 
Attributes—edit the Attributes for this session.
Startup Macro—edit the Startup Macro for this session.
Macro Toolbar—configure the Macro Toolbar for this session.
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Figure 4-15: EHLLAPI Configuration Window

Sett ing

Font Size—window resize (7-24) to choose different font 
display sizes.
Click Pad—turn the ClickPad at the bottom of the session window 
on and off (view/hide).
Block Paste—default paste mode used to toggle between block 
and stream modes. Paste an entire block of vertical or columns of 
text.
Hot Spots—activate hot spots on the window.
Toolbar—activate the Toolbar under the Menu Bar.
Macro Toolbar—activate the Macro Toolbar beneath the Toolbar.
Cursor to Mouse—position cursor using the right mouse button.
Type-ahead—enter the next string of host information into a 
buffer without waiting for the next host screen (Reset/Disable set 
buffer size).
Suppress Trailing CR for Copy—removes last CR from copied text.
Cursor—set cursor options: Underscore Cursor, Blinking Cursor, 
Rule Lines, Horizontal Rule, Vertical Rule, Short Rules, Blue, Red, Pink, 
Green, Turquoise, Yellow, White.
Show Printer Dialog—ON/OFF
Lock Backspace—ON/OFF
Save Window Position/Size on Exit (ON/OFF)
Initial Window State (JRE ONLY) change to Normal, Iconified, or 
Maximized window settings (requires restarting session).
Proxy Server—allows setting to connect to a proxy server.
EHLLAPI—spawns EHLLAPI configuration window. Check Enable to 
allow EHLLAPI and COM programs to interact with the WebConnect 
applet. EHLLAPI supports up to a maximum of 26 concurrent 
sessions and uses ports incrementally starting from 63747. See 
Figure 4-15 below.

Help Open Help File

Tabl e 4-2 : S essi on  M enu  Opti on s  (S hee t 2 o f  2)

Men u D efi ni ti on
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Macro Toolbar 
Your administrator must enable the Macro Toolbar. You can toggle it 
ON/OFF under Settings>Macro Toolbar on the client window menu 
bar. See Table 4-2 on page 45.

To configure the contents of the Macro Toolbar complete the 
following steps:

1. Click, Edit>Preferences>Macro Toolbar. The Macro Toolbar 
Configuration window appears as shown below in Figure 4-16.

Figure 4-16: Macro Toolbar Configuration Window 

Tabl e 4-3: Macro Tool bar  Det ail s

I tem Def in it io n

Avai lable  Macros The list of Macros available to the user.

Macro  Too lbar The Macros that appear on the toolbar.

Label A unique descriptive name for the macro.

Up Move the selected macro up the list.

Down Move the selected macro down the list.

Remove Delete the selected macro from the list.

Add Add the macro selected in the Available Macros list to 
the Macro Toolbar list.

Save Save your changes.

C ancel Cancel the previous input.

Help Open Help. 
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2. Select the desired macro from the list of Available Macros on 
the left.

3. Assign another label to the macro by entering it into the Label 
box if desired. 

4. Click Add.

The macro now appears in the Macro Toolbar’s list on the right 
of the dialog box.

5. Change the position of the macro in the list by selecting a macro 
and using the Up and Down buttons.

6. Remove a macro from the Macro Toolbar’s list by first selecting 
the macro and then clicking Remove.

7. Save your changes by clicking Save.

Session Toolbar Menu
The Sessions Toolbar menu must be enabled by your administrator. 
You can toggle it ON/OFF under the Setting menu on the client 
window menu bar.

Tabl e 4-4 : Emu lati on  Icon  Va lu es  (S h eet 1 of  2)

Icon D efi ni ti on

New Session—Opens a new session emulation screen.

Exit Session—Exits the present session without saving 
information.

Print Screen—Sends the emulator screen to a print session.

File Transfer—Transfers files between a Java client and an SNA 
host application using standard IND$FILE transfer protocol.

Select All—Highlights the entire screen.
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Emulation Space
The Emulation Space, located below the Menu and Tool bars, 
displays detailed messages of the WebConnect server and the host 
connections. If encryption is used, messages regarding encryption 
key generation also displays in the emulation space. After a host 
connect is established, host data displays in the emulation space 
according to host data attributes, unless the Hot Spots option is 
active. See ”Configuring Hot Spots” on page 83.

Copy—Copies highlighted areas of the screen to the clipboard.

Copy and Append—Used to copy and append (add) data to the 
clipboard without destroying the existing data that is already on 
the clipboard. Use the Left mouse button to identify (highlight) text 
you want to copy.

Paste—Copies data from the clipboard to the highlighted area on 
the screen.

ClickPad—Turns the ClickPad (PF Keys) at the bottom of the 
screen on and off.

Play Recorded Macro—Displays a list of previously recorded 
macros and allows you to select one to play.

About Client—Displays detailed information about the client 
machine, browser, and version of WebConnect Client.

About Server—Displays detailed information about the 
WebConnect server and current emulation session (version, name, 
IP address, port, etc.).

Macro Toolbar Scroll—Scrolls the list of macros on the toolbar left 
or right. 

Tabl e 4-4: Emu lat ion  Icon  Valu es  ( Sh eet 2 of  2)
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ClickPad
The ClickPad displays below the Emulation Space if enabled as 
shown in Figure 4-14, on page 44.

Copy and Paste Features
The copy/paste feature can be set for either block (copy/paste 
selected columns) or stream (copy/paste rows) mode by setting the 
Block Paste option under the Setting menu. By default, this setting is 
block mode enabled. If disabled, the data is copied in stream mode.

Copy

To copy text to the clipboard, complete the following steps:

1. Mark the text by using one of the following copy methods:

• Select All from the Edit menu: Selects the current screen and 
the entire contents of the scroll buffers. 

• Highlighting text using a mouse: Click and hold the left 
mouse button at the beginning of the text you want to copy. 
Drag the cursor to highlight the entire text you want to copy.

• Highlighting text using the keyboard: Position the cursor at 
the beginning of text you want to mark and then use the key 
sequences in Table 4-5.

• Double left mouse to select entire field.

2. Select Copy from the Edit menu or toolbar. The text is copied to 
the clipboard.

You can use certain keys to highlight text on the screen, as 
defined in the following table.

Tabl e 4-5 : Keyboard M appi ng  

Key S equen ce M appi ng

Sh i f t  + Left Highlight the text to the left of the current select 
location.

Sh i f t +  Right Highlight the text to the right of the current select 
location.

Sh if t  +  Up Highlight the text above the current select location.

Sh i f t  + Down Highlight the text below the current select location.

Sh if t  +  Home Highlight the text to the beginning of the row of the 
current select location.
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These sequence functions are described below.

• Shift + Left: This marking function uses the shift key and left 
arrow key combination. If no text is selected, the current 
cursor position is selected. Otherwise, the character position 
to the left of the last selected character position becomes the 
new last character selected in the block. If the last selected 
character position is the beginning of a row, the last character 
of the previous row becomes the new last character selected.

• Shift + Right: This marking function uses the shift key and 
right arrow key combination. If no text is selected, the current 
cursor position is selected. Otherwise, the character position 
to the right of the last selected character position becomes 
the new last character selected in the block. If the last 
selected character position is the end of a row, the first 
character of the next row becomes the new last character 
selected.

• Shift + Up: This marking function uses the shift key and up 
arrow key combination. If no text is selected, the current 
cursor position and all characters up to but not including the 
character above the current cursor position is selected. 
Otherwise, the character position above the last selected 
character position becomes the new last character selected in 
the block. If the last selected character position is in the first 
row, the first character on the screen becomes the new last 
character selected. If Shift + Up is followed by a Shift + Down, 
the new last character selected is the position that was 
selected prior to the Shift + Up.

• Shift + Down: This marking function uses the shift key and 
down arrow key combination. If no text is selected, the 
current cursor position and all characters up to but not 
including the character below the current cursor position is 
selected. Otherwise, the character position below the last 
selected character position becomes the new last character 

Sh i f t  + End Highlight the text to the end of the row of the current 
select location.

Sh i f t +  Page Up Highlight the text from the current cursor position to 
the first row on the screen.

Sh i f t  + Page Down Highlight the text from the current cursor position to 
the last row on the screen.

Tabl e 4-5: Keyboard M appi ng   (Cont in ued)

Key S equen ce M appi ng
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selected in the block. If the last selected character position is 
in the last row, the last character on the screen becomes the 
new last character selected. If Shift + Down is followed by a 
Shift + Up, the new last character selected is the position that 
was selected prior to the Shift + Down.

• Shift + Home: This marking function uses the shift key and 
home key combination. If no text is selected, the current 
cursor position and all characters up to and including the first 
character in the row are selected. Otherwise, all characters 
from the last selected position to the first character in the row 
are selected unless it is already selected. If characters are 
already selected, then those characters are deselected.

• Shift + End: This marking function uses the shift key and end 
key combination. If no text is selected, the current cursor 
position and all characters up to and including the last 
character in the row are selected. Otherwise, all characters 
from the last selected position to the last character in the row 
are selected unless it is already selected. If characters are 
already selected, then those characters are deselected.

• Shift + Page Up: This marking function uses the shift key and 
page up key combination. When used, the current cursor 
position and all characters up to and including the first 
character on the screen are selected. Any characters that were 
previously selected but are not in this range are deselected.

• Shift + Page Down: This marking function uses the shift key 
and page down key combination. When used, the current 
cursor position and all characters up to and including the last 
character on the screen are selected. Any characters that were 
previously selected but are not in this range are deselected.

Paste

To paste text from the clipboard to the screen, complete the 
following steps:

1. Position the cursor where you want to begin copying text.

2. Select Paste from the Edit menu or toolbar.

Note:  You can reposition the cursor by selecting the Cursor to Mouse 
option in the Setting menu. Then click the position where you want to 
move the cursor.
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3287 Client Emulation Features
The 3287 session user interface is a display window that shows the 
progress of 3287 print jobs. A few user options can affect the printed 
output. These options, and other interface features, are explained 
below. 

Menu Bar
The Menu Bar allows you to perform the tasks outlined in Table 4-6 
on page 53.

Session Window
The Session Window displays the following information: 

• Connection Messages show details about attempts to connect to 
the WebConnect server and to the host. 

• Security Messages

When using encryption, messages about the generation of 
encryption keys are written to the 3287 session window.

• Print Job Messages report the following information:

• The status of the print job (started or ended).

• The number of print jobs completed.

• The number of pages printed

The following functions are available in the 3287 emulation client 
menus:

Tabl e 4-6: 328 7 M en u Fun ct io ns  (Sh eet  1 of  2)

M
en

u

I tem De script io n

Fi
le

P r int Forces print job to flush to printer (only needed under special circumstances).

Save User 
Sett ings Saves the current user’s settings.

Exi t
Terminates the mainframe connection and quits the applet. As long as the 
browser is running, the applet may remain cached and may not need to be 
downloaded again to start a new session.
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3812 Client Emulation Features
The 3812 session user interface displays a window with the progress 
of 3812 print jobs. A few user options can affect the printed output. 
These options and other user interface features are explained below.

Menu Bar
The Menu Bar allows you to perform the tasks outlined in Table 4-6.

Session Window
The Session Window displays the following information:

• Connection messages; details about attempts to connect 

Se
tt

in
g

Font  Auto f it

(Not available with JavaScript printing.)
Instructs the WebConnect applet to choose the font size that fits the line of 
print on the printed paper. This is most useful if the print session is to print 
jobs requiring different formats. For instance, one job may print out 80 
columns and another may print 132 columns. Setting this option would allow 
the applet to choose a larger font for the 80 column print job.

Raw Mode

(Not available with JavaScript printing. Only print-to-file support with JDK 
print in raw mode.)
Enable to bypass the graphical print API, allowing printer-specific codes to be 
passed in the data stream and sent directly to the printer.

Save Window 
Pos i t ion/Si ze  on  

Ex i t
Enable to save window position and size on exit. 

Show Printer 
Dialog

Available only with WebPrint. JDK and JavaScript print always shows the 
printer dialog.
If enabled, a dialog displays when a print job is created, allowing you to 
change printer settings (choose a printer, select landscape or portrait, etc.) If 
this option is not enabled, print jobs are sent to the default printer in portrait 
layout.

Proxy Server If instructed to do so by your administrator, select this option and enter a 
proxy server in the dialog that appears.

He
lp

About  C lient Select to view more information about the client operating system, applet 
version, and Java version.

About  Server Select to view more information about the WebConnect server.

Tabl e 4-6 : 328 7 M en u Fun ct ion s  ( Sh eet  2 of  2)
M

en
u

I tem De script io n
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to the WebConnect server and to the host.

• Security messages; details about the generation of encryption 
keys (when encryption is used), are written to the 3812 session 
window. 

• Print Job Messages; report the following information: 

• The status of the print job (started or ended) 

• The number of print jobs completed 

• The number of pages printed 

Macro Record/Play
You can record frequently used keystrokes and save them as macros 
to be activated and played back. Defined macros are either saved 
locally or to the server, depending on the Save User Files On setting 
option in your User Preferences. See ”Preferences” on page 29.. 
Select one of the following functions from the emulation session 
File> Macro Rec/Play> menu:

• Play Macro

• Stop Macro

• Record Macro

• Stop Recording

• Cancel Recording

• Delete Macro

• Save Macro File

Note: See Table 4-6 on page 53 for menu options.
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Figure 4-17: Record/Play Macro

Note: In some instances, your system administrator may have set your user 
preferences to restrict macro recording. If this is the case your menu only 
displays the “Play Macro” feature as in the following figure. The same is 
true for the play macro toolbar icon.
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Figure 4-18: Play Macro Menu

Recording a Macro
1. From the emulation session menu, click File> Macro 

Rec/Play> Record Macro.

Figure 4-19: Record Macro Name

2. In the Macro Name box, type a name for the new macro (for 
example, CICS Logon).

3. Click OK.
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4. Type the key sequence (i.e., the commonly used keystrokes) to 
record the macro.

5. When you have finished recording, click File> Macro Rec/Play> 
Stop Recording.

Figure 4-20: Stop Recording Macro

6. Click OK. 

Saving a Macro File
Immediately after recording a macro you must save it.

1. Select File> Macro Rec/Play> Save Macro File. The macro you 
recorded is saved and a confirmation message is displayed.

Note: Do not use the mouse or clickpad while recording. Only keystrokes can 
be recorded, not mouse actions. See ”Copy and Paste Features” on 
page 50 for instructions on using the keyboard to highlight text. For a 
list of the key mappings, see ”HTML Keyboard Mapping” on 
page 199., or select Key Maps from the emulation session Help menu.

Note: You MUST continue to the following instructions and SAVE the macro or 
your work can be lost.
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Figure 4-21: Save Recorded Macro

2. Click OK.

• The macro you recorded and saved is available to replay the 
next time you start a session.

Playing a Macro
1. Select File> Macro Rec/Play> Play Macro. The Play Macro 

window opens.

Figure 4-22: Play Recorded Macro

2. Select the name of the macro that you want to play from the 
drop-down menu list.
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3. Click OK. The macro keystrokes that you previously recorded 
automatically play back, activating the sequence.

Stopping a Macro During Play
This option stops a macro while it is running.

1. During a macro playback if a long time-out occurs and you need 
to stop it, select Macro Rec/Stop and Stop Macro.

Deleting a Macro
1. Select File> Macro Rec/Play> Delete Macro. The Delete Macro 

window displays.

Figure 4-23: Delete Macro

2. Select the macro to be deleted from the drop-down list.

3. Click OK to delete the macro. A confirmation message displays.

Note: For 3270, 5250, and VT sessions you can also play a macro from the 
Toolbar menu items. See, Table 4-4 on page 48.

Note: After the macro stops running, Stop Macro changes to Play Macro 
again.
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Figure 4-24: Delete Macro Confirmation

4. Click OK.
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5 Classic Client 
Printing

This chapter contains information about the following subjects:

• ”WebPrint” on page 63.

• ”Printing a Screen” on page 63.

• ”VT Session Logging” on page 64.

• ”3287 Print Session” on page 66.

• ”3812 Print Session” on page 66.

• ”Date/Time Stamp Operation” on page 67.

WebPrint
WebPrint allows full control over font size and style and 
automatically sizes a printed document based on display orientation.

OpenConnect’s system fonts have been enhanced with custom font 
technology from Bitstream Inc.™

WebPrint must be installed locally on the client system. See 
”Installing WebPrint” on page 38.

Printing a Screen
You can print a single session window after you select a print screen 
option, see the following steps:

1. From the open session window, select File>Print Screen from 
the menu. The printer dialog window for the system displays. If 
the “Print to File” option has been configured it opens instead.

2. Follow the system printing procedures.
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VT Session Logging
Activity during a VT session can be recorded in two different ways. 

• Log Session to Printer - while enabled text displayed on the VT 
session is echoed to the printer. 

• Log Session to File - while enabled text displayed on the VT 
session is echoed to the user selected file.

Simultaneous logging to file and printer are not allowed. 

When the user enables session logging, the applet sends a 
command to the WC server to start logging. The VT emulation in the 
server manages accumulation of log data and sends each line to be 
logged to the applet.

While logging, each printable character received is stored in a buffer 
in the WC server. The buffer is flushed to the applet for printing 
whenever the carriage return (CR) character is received from the 
host. Tab characters are expanded in the buffer for proper alignment 
of tabbed data in the printer log.

If host-initiated VT print (printer controller on) is started, the current 
logging buffer is flushed and logging suspended. Logging resumes 
when the print controller off sequence is received. Printer controller 
data is spooled to a separate print job by the applet to prevent 
mixing of printer controller data and session logging data.

The session logging feature uses the same applet print method 
configured for screen print and printer controller mode. This is 
configured in the session file or in the user's preferences.

VT Log Session to Printer

To use Session Logging complete the following steps from the 
session screen:
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Figure 5-25: Log VT Session to Printer

1. Select File>Log Session to Printer

A print dialog box appears.

2. Check the print settings, make changes as necessary, and click 
OK.

3. Continue with your session.

Data entered is stored in the print buffer until you are ready to 
print.

4. To print the accumulated session activity click Files>Log 
Session to Printer again. 

Your session is sent to your selected printer and session logging 
is disabled. 

VT Log Session to File

To use Session Logging complete the following steps from the 
session screen:

1. Select File>Log Session to File

The Specify Session Log Filename dialog box appears.

2. Enter a filename for the session log and click OK.

3. Continue with your session.

Data entered is stored in the session log file.

4. To discontinue session logging click Files>Log Session to File 
again. 
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3287 Print Session
Printing from any browser to a specific 3287 logical unit (LU) and 
gateway:

1. Select 3287 Print Session from the Start User Session panel. A 
3287 printer session window displays.

2. Be sure the correct gateway and LU displays in the printer 
session window.

3. Send a mainframe print job to the selected LU. The 3287 printer 
session window indicates that the session is printing.

3812 Print Session
You can use a 3812 print session to print an AS/400 based print job 
on the local or network printer. From the browser, select one of the 
3812 print sessions that has been configured.

To start a 3812 print session:

1. Select the desired 3812 Print Session from the SESSION panel.

The 3812 print session window displays.

2. If the connection fails, attempt to resolve the problem indicated 
by the error message. If the problem persists, try a different 3812 
print session.

3. Send an AS/400 print job to the print device connected to the 
3812 print session. The print device name (and other important 
information about the session) can be found on the About 
Server dialog located in the 3812 print session Help menu.

Note: To check the LU and gateway you are printing to, select About 
Server from the Help menu on the printer session window 
displayed when you start a 3287 print session. A status 
window opens identifying printer information, such as the 
number of jobs to print.
To run print jobs unattended, disable Show Printer Dialog 
from the session settings menu. This is not valid for JDK 
printing.
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Date/Time Stamp Operation
The date/time and user@host will print in the bottom margin of all 
pages generated by Print Screen. The user ID and PC host name will 
be at the left margin in the format user@host with the date/time 
printed at the right margin. US systems result in a date displaying as 
dd-mm-yy hh:mm:ss AM/PM format, 27-Sep-02 3:35.29 PM.

jdoe@ocs5555.oc.com 27-Sep-02 3:35.29 PM

Print to File Date/Time

This method does not render the page and then print it. Instead, 
each string is written to the file as it is received by the Print to File 
class.

Figure 5-26: Print to File Dialog

Print date/time stamp, user ID, and PC host name will print two text 
lines at the top of the screen, as in the following example:

user1@abc.oc.com 
27-Sep-02 3:35:29 PM

Figure 5-27: Print to File Time/Date Stamp

gtoye@ocs1355.oc.com   
27-Sep-02 3:35:29 PM 
    OOOOO                        CCCCCC                                           
   O     O                      C                                                 
   O     O  PPPP   EEEE  N   N  C         OOO   N   N  N   N  EEEE   CCC  TTTTT   
   O     O  P   P  E     NN  N  C        O   O  NN  N  NN  N  E     C       T     
   O     O  PPPP   EEE   N N N  C        O   O  N N N  N N N  EEE   C       T     
   O     O  P      E     N  NN  C        O   O  N  NN  N  NN  E     C       T     
    OOOOO   P      EEEE  N   N   CCCCCC   OOO   N   N  N   N  EEEE   CCC    T     
                                                                                  
   O p e n C o n n e c t   S y s t e m s   I n c .  -  D a l l a s , T e x a s    
                                                                                  
                      (Technical Support: 972-484-5200)                           
   ---------------------------  SNA NETWORK  ----------------------------------   
              Access application by entering sign-on command:                     
                                                                                  
              APPLICATION NAME                     SIGN-ON COMMAND                
              ================                     ===============                
              VM/CMS/PROFS                         VM                             
              MVS/TSO                              TSO                            
              MVS/CICS                             CICS                           
              MVS/IMS                              IMS                            
              NETVIEW                              NETVIEW                        
   ----------------------------------------------------------------------------   

(This terminal is controlled by MVS/VTAM on ES/9000)

gtoye@ocs1355.oc.com   
27-Sep-02 3:35:29 PM 
    OOOOO                        CCCCCC                                           
   O     O                      C                                                 
   O     O  PPPP   EEEE  N   N  C         OOO   N   N  N   N  EEEE   CCC  TTTTT   
   O     O  P   P  E     NN  N  C        O   O  NN  N  NN  N  E     C       T     
   O     O  PPPP   EEE   N N N  C        O   O  N N N  N N N  EEE   C       T     
   O     O  P      E     N  NN  C        O   O  N  NN  N  NN  E     C       T     
    OOOOO   P      EEEE  N   N   CCCCCC   OOO   N   N  N   N  EEEE   CCC    T     
                                                                                  
   O p e n C o n n e c t   S y s t e m s   I n c .  -  D a l l a s , T e x a s    
                                                                                  
                      (Technical Support: 972-484-5200)                           
   ---------------------------  SNA NETWORK  ----------------------------------   
              Access application by entering sign-on command:                     
                                                                                  
              APPLICATION NAME                     SIGN-ON COMMAND                
              ================                     ===============                
              VM/CMS/PROFS                         VM                             
              MVS/TSO                              TSO                            
              MVS/CICS                             CICS                           
              MVS/IMS                              IMS                            
              NETVIEW                              NETVIEW                        
   ----------------------------------------------------------------------------   

(This terminal is controlled by MVS/VTAM on ES/9000)

user1@abc123.oc.com

Time/Date
Stamp
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6 Classic Client File 
Transfer

WebConnect uses the standard IND$FILE protocol to transfer files 
between a Java client and an SNA host application. This capability 
can be used to address a variety of networking needs, including 
centralized data backups and data warehousing through an SNA 
host. 

Because SNA host files use different file formats from WebConnect 
files and Java client files, be sure to use the appropriate options for 
converting files to the receiving host’s file format during transfer. 
Format conversion allows the receiving host applications to use the 
file without further modification. SNA hosts and SNA applications 
used for transferring files are listed below as well as the IBM program 
number and operating system for each application:

• WebConnect supports only the DFT (Distributed Function 
Terminal) file transfer mode.

You must be familiar with the file transfer application program you 
use.

Select an option below for file transfer instructions: 

• "Sending and Receiving CICS/VS Files," page 70.

Note: The 3270 File Transfer menu option is only available if your administrator 
enables it.

Tab le 6-7: S N A Ho st/App li cati on Trans fer  

A ppli cati on  Prog ram Pro gram 
N u mber

Op erat in
g Syste m

3270 PC File Transfer for CICS 5798-DQH VS

3270 PC File Transfer for TSO 5665-311 MVS

3270 PC File Transfer for VM 5664-281 VM
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• "UNIX Format," page 71.

• "Sending and Receiving TSO Files," page 72.

• "Append a File," page 74.

• "Sending and Receiving VM Files," page 76.

• "Multiple File Transfers," page 79.

Sending and Receiving CICS/VS Files
WebConnect allows file transfer between a Java client and the 
Customer Information Control System/Virtual Storage (CICS/VS) SNA 
application.

See the following steps to transfer files to and from CICS/VS.

1. Make sure that the WebConnect client is connected to the 
desired SNA host and CICS application. 

2. From the File menu, select File Transfer.

The File Transfer option dialog appears.

Figure 6-28: File Transfer Options

3. Select CICS Send (or CICS Receive). The appropriate file transfer 
window displays.

4. Under Local File click Browse to search for a file. A file selection 
window displays.

Note: The procedures for searching for filenames vary by system.



Sending and Receiving CICS/VS Files

Chapter 6—Classic Client File Transfer 71

When you select a file the name displays in the text field of the Local 
File box.

UNIX Format
1. To transfer the file in UNIX format, click the UNIX Format button 

under Browse. UNIX format converts line separators to carriage 
return and line feed pairs during a Send operation. During a 
receive operation, carriage return and line feed pairs are 
converted to line separators.

Do not select the UNIX format when using the binary option or the 
binary data can be corrupted.

2. Type a host filename in the Data Set Name field in the Host File 
box. 

3. Type comments about the file being transferred in the Comment 
field in the Host File box. The comments are automatically 
included in the first record of the CICS/VS host file.

Transfer Options
1. Select a file type from the Transfer Options box to configure the 

way the file contents are treated during the transfer process. The 
choices are described below: 

• ASCII
This option instructs the SNA host to translate data between 
the EBCDIC and ASCII character formats. Use this option for 
transferring ASCII formatted files, such as text edit files or 
print files. Do not use the ASCII option for transferring binary 
data (such as output data from a database program) or object 
code files (such as C compiler object code). 

• Binary
This option instructs the SNA host to perform no character 
translation. Use this option to transfer encrypted data, 
compiled programs, and other noncharacter information. 

2. Click Append if a local file is to be added to the end of an SNA 
host file or if an SNA host file is to be appended to a local file. 

Note: The CICS filename can be a program name, a transaction identification, 
or identification selected by the CICS/VS application programmer. If the 
filename does not exist, the CICS/VS application automatically creates it. 
The filename can be one to eight characters long. The character in the 
first position must be alpha; other characters can be alpha or numeric.
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• If you do not select Append in the Receive dialog box, the 
SNA host file replaces the Java client file. 

• If you do not select Append in the Send dialog box, the 
TCP/IP host file replaces the SNA host file. 

3. If the CRLF option is desired, check CRLF. 

4. Click OK to begin the file transfer.

5. A Transfer Status window displays to confirm the transfer was 
successfully completed. Click OK.

Sending and Receiving TSO Files
WebConnect allows you to transfer files between a Java client and 
the Time Sharing Option (TSO) SNA application. 

See the following steps to transfer files to and from a TSO application 
from a User Session.

1. Make sure that the WebConnect client is connected to the 
desired SNA host and TSO application.

2. From the File menu, select File Transfer>TSO Send (or TSO 
Receive). The appropriate file transfer window displays.

Note: If you do not specify the CRLF option in send mode, the SNA host 
disregards the local file’s line separators.

Do not use the CRLF option for transferring binary data (such as output 
data from a database program) or object code files (such as C compiler 
object code).

Disabling the CRLF option in the Transfer Options dialog box instructs 
the CICS/VS host to copy the file unaltered to the appropriate TCP/IP 
host. This option can be used to transfer encrypted data, compiled 
programs, and other data that is unreadable. 
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Figure 6-29: TSO File Transfer Example

3. Click Browse under Local File to search for the peer’s file. A file 
selection window displays. for example, “Specify File to SEND.” 
(The procedures for searching for the peer filename may differ 
by system.) 

4. When you select the peer file and click Open, the name displays 
in the text field in the Local File box.

5. To transfer the file in UNIX format, click the UNIX Format button. 
UNIX format converts line separators to carriage return and line 
feed pairs during a Send operation. During a receive operation, 
carriage return and line feed pairs are converted to line 
separators.

6. Type a host filename in the Data Set Name field. 

7. Type a member name in the Member Name field. 

Note: The TSO host data set name must conform to IBM naming conventions. 
You can enter an existing data set name (stored in your library) or a new 
data set name. A closing quote does not display in the Member 
Name field.
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The member name is optional. If entered, the member name 
should be a member in a partitioned data set directory.

8. WebConnect does not create the partitioned data set. 
When you use the Send window to copy a file to a 
partitioned data set and include a member name, the 
partitioned data set must exist.

9. The TSO application adds a user ID prefix to the combined data 
set and member name. To eliminate the user ID prefix, enclose 
the data set and member name in single (right) quotation marks, 
for example,’smith.pds2.file1.’

10. If a password is required, type it in the Password field. A 
password is only required if password-protection has been 
specified for the TSO data set.

11. Select a file type from the Transfer Options box to configure the 
way the file contents are treated during the transfer process. The 
choices are described below:

• ASCII—this option commands the SNA host to translate data 
between the EBCDIC and ASCII character formats. Use this 
option for transferring ASCII formatted files, such as text edit 
files or print files. Do not use the ASCII option for transferring 
binary data (such as output data from a database program) or 
object code files (such as C compiler object code). 

• Binary—this option instructs the SNA host to perform no 
character translation. Use this option to transfer encrypted 
data, compiled programs, and other noncharacter 
information. 

Append a File
1. Click Append if you plan to add a local file to the end of an SNA 

host file, or the SNA host file appends a local file. The Append 
option overrides other values specified by the LRECL parameter 
and RECFM options in the Advanced section. 

• If you do not select Append in the Receive dialog box, the 
SNA host file replaces the Java client file. 

• If you do not select Append in the Send dialog box, the 
TCP/IP host file replaces the SNA host file.

Note: If you select the UNIX Format option when using the Binary option, the 
binary data can be corrupted.
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Advanced Options

Figure 6-30: Advanced Options

1. In the Record Format box, click a radio button for the desired 
record format. This is only valid when sending a file. The valid 
values are described below: 

• Fixed—indicates the data set’s records are fixed length.

• Variable—indicates the data set’s records are variable length.

• Undefined—indicates the data set contains undefined record 
lengths.

• None—indicates no record format is to be used.

2. To set the allocated amount of space for a new data set, click 
Blocks, Tracks, or Cylinders in the Space box. When you select 
Default, TSO uses the Blocks parameter default value which is 
determined by the specifications listed below: 

• Blocks—use the smallest storage entity.

• Tracks—use the middle-sized storage entity.

• Cylinders—use the largest storage entity.

• Primary—the primary allocation for the Blocks parameter.

• Increment—the increment allocation for the Blocks 
parameter.

3. If sending a file, type a size value (such as the data block size of a 
TSO data set) in the BLKSIZE field in the Record Format area. The 
variable you type represents a data block’s byte count. The 
default value is 80.

4. Type a logical record length value of the SNA host file in the 
LRECL field in the Record Format area. The parameter value 
represents the number of characters for each record. If the 
parameter is not entered, the record length is determined by the 
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file transfer operation. For new files, the parameter’s default 
value is 80. 

5. The characteristics of the existing file are used if you are 
replacing a file or appending information to a file. If you are 
transferring variable length records, the parameter represents 
the maximum record size. The parameter’s value becomes the 
longest record sent if you do not send a record of the maximum 
operating system size; only valid if you are sending a file.

6. Click OK to close the Advanced Options window.

7. Click OK again to begin the file transfer.

8. A Transfer Status window displays to confirm the transfer was 
successfully completed. Click OK.

Sending and Receiving VM Files
WebConnect allows file transfer between a Java client and the Virtual 
Machine/Conversational Monitor System (VM) SNA application.

See the following steps to transfer files to and from a VM application.

1. Make sure that the WebConnect client is connected to the 
desired SNA host and VM application.

2. From the File menu, select File Transfer>VM Send (or VM 
Receive). The appropriate file transfer window displays.

3. Click Browse under Local File to search for the peer’s file. A file 
selection window displays. The procedures for searching for the 
peer filename vary by system.

4. Select the peer file. The name displays in the text field in the 
Local File box.

To transfer the file in UNIX format, click the UNIX format button. 
UNIX format converts line separators to carriage return and line 
feed pairs during a Send operation. During a receive operation, 
carriage return and line feed pairs are converted to line 
separators.

5. Type a host filename in the Data Set Name field in the Host File 
area. The VM filename can be one to eight characters long. 

Note: The VM application automatically creates the receiving host’s filename if 
a filename does not exist.
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6. Type the appropriate file type in the VM File Type field. This 
parameter identifies the VM disk file type.

7. Type an appropriate value in the VM File Mode text box. This 
parameter identifies the VM disk file mode. If you do not enter a 
file mode parameter, the VM application uses the A1 default 
value.

8. Select a file type from the Transfer Options box to configure the 
way the file contents are treated during the transfer process. The 
choices are described below:

• ASCII—this option instructs the SNA host to translate data 
between the EBCDIC and ASCII character formats. Use this 
option for transferring ASCII formatted files, such as text edit 
files or print files. Do not use the ASCII option for transferring 
binary data (such as output data from a database program) or 
object code files (such as C compiler object code). 

• Binary—this option instructs the SNA host to perform no 
character translation. Use this option to transfer encrypted 
data, compiled programs, and other noncharacter 
information. 

9. Click Append if a local file is to be added to the end of an SNA 
host file or if an SNA host file is to be appended to a local file.

• If you do not select Append in the Receive dialog box, the 
SNA host file replaces the Java client file.

• If you do not select Append in the Send dialog box, the 
TCP/IP host file replaces the SNA host file. 

• To use the CRLF option, check CRLF. 

• During a Receive operation, carriage return and line feed 
pairs are converted to line separators.

• Disabling the CRLF option in the Transfer Options dialog box 
instructs the CICS/VS host to copy the file unaltered to the 
appropriate TCP/IP host. This option can be used to transfer 

Caution: Do not select the UNIX Format option when using the Binary option 
or the binary data is corrupted.

Note: You can click the UNIX Format check box for ASCII file transfers. This 
allows line separators to be converted to carriage return and line feed 
pairs during a Send operation.
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encrypted data, compiled programs, and other data that is 
unreadable. 

• If you do not activate the Append option in the Receive 
dialog box, the SNA host file replaces the Java client file. If you 
do not activate the Append option in the Send dialog box, 
the TCP/IP host file replaces the SNA host file.

10. To specify the record format, LRECL, click the Advanced button 
and the Advanced Options window displays. 

11. In the Record Format box, click a radio button for the desired 
record format. This is only valid when sending a file. The valid 
values are described below: 

• Fixed—indicates the data set’s records are fixed length.

• Variable—indicates the data set’s records are variable length.

• None—indicates no record format is to be used.

12. Type a logical record length value of the SNA host file in the 
LRECL field in the Record Format area. The parameter value 
represents the number of characters for each record. If the 
parameter is not entered, the record length is determined by the 
file transfer operation. For new files, the parameter’s default 
value is 80.

If you are replacing a file or appending information to a file, the 
characteristics of the existing file are used. If you are transferring 
variable length records, the parameter represents the maximum 
record size. If you do not send a record of the maximum operating 
system size, the parameter value becomes the longest record sent. 
This is only valid if you are sending a file.

13. Click OK to close the Advanced Options window. 

14. Click OK again to begin the file transfer.

15. A Transfer Status window displays to confirm the transfer was 
successfully completed. Click OK.

Caution: Do not use the ASCII or CRLF options for binary data such as output 
data from a data base program or object code files such as C compiler 
object code. 
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Multiple File Transfers
The WebConnect applet supports IND$FILE multiple file transfers. 
You can create and add files to a multi-file list, then transfer them as 
a group of files.

Please refer to "Sending and Receiving CICS/VS Files," page 70 for 
basic file transfer procedures and windows.

1. Select File>File Transfer from the applet menu.

2. Select the file transfer operation you want to use and click OK.

3. To select a local file, click the Browse button.

4. Name the file in the Host File and Data Set Name fields and click 
Add. The data set name you assigned displays in the host file 
name list.

a. To clear the list, click the Clear List button.

b. To define and save the list, click Lists (see Figure 6-31).

c. Double-click a name in the Local File list to display it in the 
Data Set Name field.

d. To delete a file from the list, select a file in the list and click 
Delete.

e. To replace a file in the list, select a file in the list and click 
Replace. The file named in the Host File field, replaces the 
selected file.

5. When all the files you want to transfer are in the Host File list, 
click OK.

• A Transfer Status window displays to confirm the transfer was 
successfully completed. Click OK.

• If there is no defined list, a single file transfer is assumed.
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File Transfer Lists

Figure 6-31: File Transfer List Name

1. This feature is designed for saving, deleting, and selecting 
multi-file transfer lists. The names of lists you have previously 
saved (if applicable) displays.

2. To add the currently defined list in Figure 6-32, on page 80, enter 
a list name and click Save.

Figure 6-32: Transfer List Name

Note: In this example the list name, “PrintLocalFiles1,” displays in Figure 6-32.
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3. You can save the file transfer list and use it again.

4. To delete or use a defined transfer list, select the transfer list and 
click Delete or Open, respectively.
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7 Classic Client User 
Preferences

This chapter contains information about editing user emulation 
session preferences from the menu bar of the Emulator Screen. The 
following topics are covered:

• ”Edit>Preferences Menu” on page 83.

• ”Configuring Hot Spots” on page 83.

• ”Configuring Colors” on page 85.

• ”Configuring Attributes” on page 86.

• ”The Setting Menu” on page 88.

• ”Cursor to Mouse (Light Pen)” on page 88.

• ”Type-ahead” on page 88.

• ”Cursor Options” on page 89.

Edit>Preferences Menu
This section contains information about the options available from 
the Edit>Preferences menu on the Emulation Client menu bar.

Configuring Hot Spots 
Hot Spots configuration allows you to select and display the 
definition of text strings as buttons when the strings appear on the 
screen.

Complete the following steps to set or modify hot spots.

1. Start your client session.
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Figure 7-33: Edit User Preferences

2. Select Edit>Preferences>Hot Spots from the Menu.

The Hot Spot Configuration screen displays.

Figure 7-34: Configure Hot Spots

3. To Edit existing text:
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The Screen Text box displays a column of text, as applicable. 
Locate the screen text you want to edit and click the text so that 
it displays in the Map to Key edit box.

4. To Add New text:

Type the text and the target key in the edit boxes.

5. Click Add/Replace to update the screen text-box columns.

6. Repeat the preceding steps for each hot spot change you want 
to make.

7. Click Save.

Configuring Colors
1. To change or enhance the color configuration, select 

Edit>Preferences>Color from the menu.

Figure 7-35: Edit Color Configuration

Note: The Associate with session: option allows you to associate 
the hotspot values with your user ID and the session file 
name. When selected, the settings apply to all sessions that 
you start with the same WebConnect session file. For 
example, using userid and 3270, your local filename is 
userid.hs3. If saved for the specific session (as in def3270 for 
this example), the filename would be userid-def3270.hs3.
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2. To edit a color, select the color you want to change. The selected 
color is marked by X (Black in this example).

3. Click on another color in the color (top) bar to change it.

4. Click on the grey scale (bottom) bar to change the color 
intensity.

5. Click Save when you complete the changes.

Configuring Attributes
Complete the following steps to edit your screen attributes and 
colors.

1. Select Edit from the Menu Bar.

2. Select Preferences>Attributes.

Note: The Associate with session: box allows you to associate 
the color values with your user ID and the session file name. 
When selected, the settings apply to all sessions that you 
start with the same WebConnect session file. For example, 
using userid and 3270, the user’s local filename is userid.cm3. 
If saved for the specific session (as in def3270 for this 
example), the filename would be userid-def3270.cm3.

Note: To assign or change a specific attribute color, see Configuring 
Attributes below.
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Figure 7-36: Attribute Configuration

3. The attribute configuration window displays an example of 
attributes supported by the terminal type (3270/5250/VT).

4. To assign a color to an attribute, select the attribute and select a 
color. The selected color is marked by “X” (Pink in this example), 
and the attributes are highlighted in the toolbar on the right, for 
example:

Figure 7-37: Attributes Toolbar

• Foreground/Background Color: toggles the color selection 
from the foreground color to the background color. Select 
another color from the color palette to change the color 
attribute.

• Bold Color: change the color to/from Bold.

• Reverse Foreground/Background Color: reverse the 
foreground/background colors (from black on green to green 
on black, for example).

Underline 

Bold ColorForeground/Background Color

Reverse Foreground/Background 

Blinking Color
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• Blinking Color: turn the blinking color on or off.

5. Click Save when you complete the changes.

The Setting Menu
This section contains information about the options available from 
the Setting menu on the Emulation Client menu bar.

Cursor to Mouse (Light Pen)
The Light Pen feature is designed to perform on-screen actions with 
or without using the keyboard. You can use it either of two ways.

1. Use Shift + Left Mouse Button (default).

Or you can activate the cursor to mouse operation from the 
Setting Menu.

2. Enable the Setting>Cursor to Mouse feature and click the right 
mouse button for the global Light Pen functionality, as follows. 

• Click the right mouse button and position the cursor in a light 
pen field to invoke the light pen functionality.

• Click and drag the cursor within a field to invoke the default 
block/highlighted functionality.

Type-ahead
In a normal 3270 or 5250 sessions, the keyboard locks after you press 
Enter or another AID key, and remains locked until the next buffer of 
information is received from the host. Enabling this option allows the 

Note: The Associate with session: box allows you to associate the 
attribute values with your user ID and the session file name. 
When selected, the settings apply to all sessions that you start 
with the same WebConnect session file. For example, using 
userid and 3270, the user's local filename is userid.at3. If saved 
for the specific session (as in def3270 for this example), the 
filename would be userid-def3270.at3.

Note: To change the color configuration, see "Configuring Colors," 
page 85.
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next string of host information to enter a buffer without waiting for 
the next host screen. When the next host screen returns, 
WebConnect sends the saved buffer of information to the host.

1. To enable Type-ahead, select the number of buffers to use from 
the Type-ahead submenu (Type-ahead is enabled by default).

2. To disable Type-ahead, select Disable from the Type-ahead 
submenu.

3. To reset Type-ahead to the default setting, select Reset from 
the Type-ahead submenu.

Cursor Options
A cross-hair cursor makes it easier for you to view full lines of data 
(vertical or horizontal rule, or both) on any emulation screen. To 
select this function, complete the following steps.

1. To activate the cursor options, select Setting>Cursor from the 
menu. This option is only available to you if your System 
Administrator has given you permission for this setting in your 
session profile.

Figure 7-38: Setting Cursor Menu

2. This feature contains many options as described below:
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• Rule Lines: select rule lines off/on. Move the cursor up or 
across the screen to the position you need.

• Horizontal Rule: select to view the horizontal rule.

• Vertical Rule: select to view the vertical rule.

• Short Rules: select to view the short rule or deselect to view 
the long rule across the entire screen.

Figure 7-39: Cross-hair Cursor

3. You can set a color for the rule line according to your preference:

• Blue

• Red

• Pink

• Green

• Turquoise

• Yellow

• White
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8 Classic Client WC 
Key Map, Macro, 
and VB Script 
Editor

The WebConnect Key Map/Macro Editor provides a way to create key 
commands and WebConnect Macros for 3270, 5250, or VT sessions.

Key Commands on page 93.

• Create a keyboard command by assigning a key or key 
sequence to a key combination.

• Allows users to access custom macros or key commands that 
were created by an administrator.

WebConnect Macros on page 101.

• Create a user, session, or server-level macro including basic 
program controls such as goto, input variables, prompts, wait 
statements, and other variables.

• Import, play, or edit pre-defined, third-party macros such as 
“Rumba *.rmc” macros.

VB Scripts on page 106.

• Create and edit user or session-level VB Scripts. 

• Import and edit pre-defined, third-party macros such as 
Attachmate EXTRA! *.ebm” macros.

• Ehllapi must be enabled for this feature to appear. See ”3270, 
5250, and VT Client Emulation Features” on page 44.

You can enable the Macro toolbar to make your macros easier to use, 
see ”Macro Toolbar” on page 47 for more details.
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User Key Map Configuration Window
To use the WebConnect Macro Editor complete the following steps:

1. Select a session (3270, 5250, or VT) from the SESSION panel, 
shown in Figure 8-40, by clicking on it.

Figure 8-40: SESSION panel

2. The session opens in a separate window as shown in Figure 8-41.

Figure 8-41: Key Map Menu
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3. Select Edit>Preferences>Key Maps.

The User Key Map Configuration window displays showing a Key 
Commands tab by default, as well as a WebConnect Macro tab.

Figure 8-42: Key Map/Macro Configuration

4. Select the tab for the one you intend to create or edit for this 
session. See ”Key Commands” on page 93, or "WebConnect 
Macros," page 101, or ”VB Scripts” on page 106.

Associate with session: is grayed out and does not apply to VB 
Scripts. 

Key Commands

Creating a New Key Command
1. Select the Key Commands tab (default tab).

2. Click New Key Command.

A dialog box appears as shown in Figure 8-43, on page 94. 
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Figure 8-43: Create Key Sequence

3. On the keyboard, enter the key or key sequence command you 
want to map. The selected keys automatically display in the 
shaded Key Sequence box.

4. When you have completed the key commands, click OK.

The new Key Command Name appears in the list as shown in 
Figure 8-44, on page 95.



Key Commands

Chapter 8—Classic Client WC Key Map, Macro, and VB Script Editor 95

Figure 8-44: Key Command Action

• The Key Command Name displays the key map sequence 
you entered.

• The Key Command Action shows that a definition is needed.

Editing a Key Command
To edit a Key Command complete the following steps:

1. Select Edit Key Command. The panel shown in Figure 8-45 
displays where commands can be mapped to the key(s) you 
entered.
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Figure 8-45: Add Key Map Commands

2. Select a command from the buttons menu that you want to add 
to the key command.

3. Click Add after each change.

Note: You can add multiple commands to a key command. Table 8-1 on 
page 96 contains the command menu definitions.

Tabl e 8-1 : Macro Edi tor  Comman d Des cript io ns 

Comma nd Des cript ion

Type Define characters and/or strings which are input as keystrokes. Also used to type the 
value of a selected variable or the current user ID and password values.

Move Moves the cursor to the configured row/column.

Past e Use to copy and then paste the contents of the configured file into the current cursor 
position within the emulation.

Pa use Use to pause the system for either a time interval or for a user response. User response 
mode allows setting a text message but does not capture any input data.

Execu te Use to execute a program external to the applet. You can specify any command line 
parameter needed by the program within the function configuration.

Wai t Use to enter a wait statement, see "Wait," page 97, Table 8-2 on page 98.
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4. Click OK when you are finished.

To play a key command use the mapped key or key sequence. 

Wait

Wait provides several formats that allow executing WebConnect 
Macros to wait on synchronized states or specific text messages. The 
following section discusses those formats.

Cursor

Allows you to pause macro execution until the emulation cursor is at 
the defined row/column location. The default time-out value of zero 
(0) waits for an unlimited time. 

Prompt Prompt the user for input which can be assigned to a variable or sent directly to the 
screen at the current cursor location.

Label Provides a marker where the Goto statement can direct macro execution.

Goto Add a Goto control statement to change the currently executing line of the script to 
Label.

Variab le

A variable String (add a name and value). 
A variable Screen places screen data at row/column, and places it in the variable “name.” 
You can specify 1) the length of screen data, 2) end of word, or 3) end of field.
A variable Prompt to create a specified 1) title, 2) message, 3) input length.

Play Execute a previously defined macro.

Funct ion
Add a selected function to this command from a pull-down menu. A definition for each 
function displays in the shaded box. You can find all standard AID Keys, such as Enter, 
Clear, PF1 through PF2 4, PA1, etc., under Function.

Compare
Provides the ability to compare existing variables to each other, or to compare constant 
values and then select a Goto branch based on an “equals” comparison or a “not equal” 
value.

Up/Down Use to organize the statements into desired command sequence.

Add Adds the command selected after the current line in the macro.

Replace Highlight a statement and replace one statement with another.

Remove Highlight a statement and delete it from the macro.

OK Use to save and exit the command configuration.

Apply Use to apply current changes to the command configuration.

Tabl e 8-1: Macro Edi tor  Comman d De script io ns  (Con ti nu ed)

Co mma nd Des cript io n
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By default, the wait starts immediately upon executing the line in the 
script. If the After next AID key box is checked, the operation does 
not take effect until after the next AID key has been processed by the 
emulation.

Wait Text

The Wait Text statement operates in one of two ways determined by 
the After next AID key check box. Having the After next AID key 
checked (enabled) provides backward compatibility with older wait 
text macros or named maps. 

In either case, the only required parameter is text in the Wait For Text 
dialog box. See "After next AID key Disabled (Default)," page 98 and 
"Editing macros built prior to WebConnect 6.3," page 99 for details 
about the two modes of operation.

Figure 8-46: Wait Tab

After next AID key Disabled (Default)
Executes the macro until the time-out value (optional) has 
elapsed, or text is matched on current host screen.

Tabl e 8-2 : Wai t Opt ion s— Af ter  nex t  A ID key D isa bled  (S hee t 1 o f  2)

Opt io n Avail abi li t y Des cript io n

Wait  For  Text : Required Alphanumeric string

Ignore Case:  U n avai la ble

At  Row/C olumn: Opt iona l Enable row and column designation in Row and 
Column below



Key Commands

Chapter 8—Classic Client WC Key Map, Macro, and VB Script Editor 99

Editing macros built prior to WebConnect 6.3 

After next AID key Enabled
Executes the macro when text matches that in the Wait For 
Text dialog box on any of the emulation screens as they occur 
until the time-out value has elapse if set.

Allows the macro to continue processing subsequent macro 
statements. AID (Attention Identifier) Keys from the macro 
may navigate to new host screens.

If you do not set either label, the macro execution resumes on 
the next macro statement after matching text or a time-out 
has expired.

Table 8-3 describes the options available with After next AID 
key enabled.

Unt i l  End Of  Sc reen:  Unavai lable

Row:  Avai lable  i f  At  
Row/C olumn i s checked.

Available if At Row/Column is checked. Specify 
exact row where text string is to begin.

Column: Avai lable  i f  At  
Row/C olumn i s checked.

Available if At Row/Column is checked. Specify 
exact column where text string is to begin.

Second(s)  Unt i l  T imeout  Opt ional Time in seconds until the wait is stopped

T imeout  Macro : Opt ional
The timeout condition can be used to trigger a 
Timeout Macro. Invoking the Timeout macro 
effectively ends the current macro.

After next  AID  Key:  UNC HECKED Disabled (default)

Proceed  Goto:  Unavai lable

T imeout  Goto : Unavai lable

Tabl e 8-2: Wai t Opt ion s— Af ter  n ex t AID key D is able d (S he et 2 of  2)

Op ti on Avail abi l it y De script io n

Tabl e 8-3: Wai t Opt ion s— Af ter  n ex t AID key E na bled  (S hee t 1 o f  2)

O pti ons Avai l abil i ty De script io ns

Wait  Fo r Text: Required Alphanumeric string

Ignore Case: Opt ional Ignore case in Wait For Text

At Row/Column: Opt ional Enable row and column designation in Row and Column 
below.

Unt i l  End Of  S creen:  C ondi t iona l Available if At Row/Column is enabled
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Keyboard Unlock

The macro execution pauses until the keyboard unlock 
command is received. You can configure the wait to only 
apply after the emulation parses the next AID key. This 
command is mainly used for synchronization purposes.

Clear Screen

The macro execution pauses until the clear screen command 
is received. You can configure the wait to only apply after the 
emulation parses the next AID key. This command is mainly 
used for synchronization purposes.

Row:  Cond i tiona l Available if At Row/Column is checked. Specify exact row 
where text string is to begin.

Co lumn: Cond i tiona l Available if At Row/Column is checked. Specify exact 
column where text string is to begin.

Second(s)  Unt i l  T imeout  Opt ional Time in seconds until the wait is stopped

T imeout  Macro: Unava ilab le N/A

After next  AID Key:  CHECKED Enabled

Proceed  Goto:  Opt ional If the wait text cannot be found, Goto statement label.

T imeout  Go to:  Opt ional  If the macro times-out before the text is found, Goto 
statement label.

Tabl e 8-3 : Wai t Opt ion s— Af ter  nex t  A ID key E nabl ed  (S heet  2  o f  2 )

O pti ons Avai la bil it y Des cript io ns
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WebConnect Macros

Figure 8-47: 3270 Session

Suppose, for example, you want to login to CICS from a current 3270 
session. This would require the following steps.

1. Type CICS and press Enter.

2. Enter your User ID and Password.

3. Press Enter.

Instead, you can create a WebConnect Macro to represent the 
command sequence. By automating the required logon procedures, 
you save time by entering a key command or macro to complete the 
steps.
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Create a WebConnect Macro
1. Select (click) a session (3270, 5250, or VT) from the SESSION 

panel. See Figure 8-40, on page 92.

Figure 8-48: WebConnect Macro Menu

2. From the emulation session, select Edit>Preferences>Key 
Maps.

Figure 8-49: WebConnect Macros
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3. The Key Map Configuration window displays a Key Commands 
tab (default) and a WebConnect Macro tab. Select the one you 
intend to create for this session.

Create a New WebConnect Macro
1. Click New Macro from the WebConnect Macro tab from any 

session type. See Figure 8-49.

2. Click New Macro. The New Macro dialog displays.

Figure 8-50: Name New Macro

3. Enter a new macro Name and click OK. 

The User Key Map Configuration dialog appears.

Figure 8-51: Define Macro Action

4. Select (highlight) the macro and click Edit Macro. 
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Figure 8-52: Configure New Macro

5. Select a command from the buttons menu to add commands to 
the WebConnect Macro.

6. Click Add after each change to the macro configuration.

7. Click OK when you are finished.

8. To play the macro, select Play Macro from the File>Macro 
Rec/Play>Play Macro emulation session Menu.

Import WebConnect Macro
You can import a macro from any of the type session selected (3270, 
5250, or VT).

1. Select the WebConnect Macros tab from any session macro 
editor, see Figure 8-53.

Note: You can add multiple commands to a key command or WebConnect 
Macro. For command menu definitions see Table 8-1 on page 96.
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Figure 8-53: Import Macro

2. Select Import Macro from the WebConnect Macro tab.

3. A File Browser window opens, Select Macro File to Import, 
where you can point to an existing macro file. If you have saved 
*.rmc Rumba files, select the directory or folder from the 
pull-down menu in the Look In window and select the location 
where the files are stored.

4. Select a macro file, *.rmc, and click Open on the browser dialog.

Figure 8-54: Imported Macro

The imported macro name displays in the “Key Map Configuration.”
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5. You can use or edit the macro as you normally would. See 
Table 8-1 on page 96, and "Create a New WebConnect Macro," 
page 103" for macro editor definitions.

6. Click Apply after each change you make.

7. Click OK when you are finished.

8. To play the macro, select Play Macro from the File>Macro 
Rec/Play>Play Macro emulation session Menu.

VB Scripts
All VB Scripts must be saved to the desktops where they are required 
to run. Otherwise, the scripts do not run. Alternatively, the 
administrator may create a shared drive common to all desktops and 
configure session parameters to run the VB Script from the central 
location.

1. Click New Macro from the WebConnect Macro tab from any 
session type. See Figure 8-55, on page 107.

Click New.

Note: Unsupported macro commands are converted to Pause commands 
with the message field indicating the unsupported command. The 
following Rumba macro commands are currently unsupported:

• Connect

• Disconnect run Application File Transfer receive

• File Transfer Send

• Compare values-except Goto (Label), which is supported

• Copy From

• Paste To
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2. The Key Map Configuration window displays. Select the VB 
Scripts tab.

Figure 8-55: VB Scripts Tab

Creating a New VB Script
To create a new VB script complete the following steps:

1. Click New VBScript. The script name dialog box appears as 
shown in Figure 8-56.

Figure 8-56: New VB Script Name

Note: If the VB Scripts Tab does not appear in the dialog box, you may not have 
EHLLAPI enabled from the applet. From a client emulation applet ensure 
that Setting>EHLLAPI is set. Exit and restart the Key Map configuration 
dialog. See also ”3270, 5250, and VT Client Emulation Features” on 
page 44.
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2. Enter a new VB Script Name and click OK. The new VB Script 
name now appears in the script list as shown in Figure 8-57, on 
page 108.

To edit the VB Script see ”Editing a VB Script” on page 109.

Figure 8-57: New VB Script

Import VB Script
You can import an Extra VB Script into the WebConnect VB Script 
Editor from any 3270 or 5250 session types you select.

1. Select the VB Script tab from any session macro editor. See 
Figure 8-55.

2. Click Import VB Script.

3. A File Browser window opens the Select VB Script to Import 
dialog box where you can select an existing VB Script file.

4. Select an Extra BASIC macro file (*.EBM) and click Open.

The selected macro file is converted to the WebConnect VB 
Script file format and the file name appears in the script list as 
shown in Figure 8-57.

5. You can use or edit the script as you normally would. 

Note: All VB Scripts must be manually copied to a shared drive common to the 
target desktops. Otherwise, the scripts do not run.
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Editing a VB Script
To edit a VB Script complete the following steps:

1. Click Edit VB Script.

2. The WebConnect Script Editor appears in a separate window as 
shown in Figure 8-58 below. See the WebConnect Script Editor 
User Guide and the WebConnect Script Language Reference Guide 
for more information about editing VB Scripts. 

Figure 8-58: WebConnect Script Editor

Remove a VB Script
To remove a VB Script complete the following steps:

1. Select the script you want to remove from the list in the Key Map 
Configuration window. See Figure 8-57, on page 108.

2. Click Remove VB Script. 

The Delete VB Script Confirmation dialog box appears.

3. Click Yes.

4. Click OK or Apply.

User Macro Autostart
The User Macro Autostart feature enables users to assign User 
Defined Startup Macros to specific session numbers and save them in 
their user preference settings. This feature requires no administrator 
intervention, providing users direct control over their startup macro 
configuration.

When using the User Macro Autostart feature keep in mind the 
following:
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• Each session type maintains its own session number list except 
when Cached Applets or the Controller Applet is used. In those 
cases, every session, type (3270, 5250, VT) use the same session 
number list. For more information about the Controller see 
”Controller Applet” on page 42.

• Session level startup macros take precedence over user autostart 
macros and start first. 

• Macro operation is exactly the same as if it were invoked through 
File-Macro Rec/Play-Play Macro menu option.

There are three modes of operation:

1. Default Macro set only—Each time the particular session icon is clicked 
the default macro is run. No session number association is required.

2. Default Macro set to None with macros assigned in the Startup 
Macro List—The first time the session icon is clicked the macro assigned 
to Session Number 1 runs. The second time the session icon is clicked, 
the macro assigned to Session Number 2 runs and so on. 

3. Default Macro set and macros assigned in the Startup Macro 
List—The first time the session icon is clicked the macro assigned to 
Session Number 1 runs. The second time the session icon is clicked, the 
macro assigned to Session Number 2 runs and so forth. Subsequent 
unassigned sessions run the default macro.

Note: When a session is terminated, the Session Number assigned to it on the 
Startup Macro List is left open. The next time that session type’s icon 
is clicked, the first open Session Number is assigned to the new session, 
and the corresponding macro assigned to that Session Number is 
started.

For example: A user assigns startup macros to four Session Numbers and 
starts those sessions. Later, the session assigned to Session Number 3 is 
lost for whatever reason. When the user clicks that session icon again, 
the resulting session is assigned to the open Session Number 3. If the 
user clicks the session icon once more, making a total of five sessions, 
the fifth session starts according to the Default Macro setting since a 
fifth session had not been assigned to a macro on the Startup Macro List. 
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Assigning Autostart Macros
To setup Macro Autostart complete the following steps:

1. Click Edit>Preference>Startup macro. See Figure 8-60, on 
page 112. 

Figure 8-59: User Autostart Macros

The Macro Operations panel appears as shown in Figure 8-60, 
on page 112.
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Figure 8-60: User Macro Autostart

Default Macro

2. Select a macro from the Select Default Macro list as the default 
startup macro for the current session type or leave it set to the 
default, None. 

Startup Macro List

3. Enter the subsequent session number (1-99), if any, you want to 
assign a startup macro to in the Assign To Session Number 
field.

4. Select a macro from the pull-down Select Macro For Startup 
List and click Add.

The selected macro appears in the Startup Macro List.

5. Repeat Steps 3 and 4 for additional sessions making sure to 
enter unique session numbers in the Assign To Session 
Number field for each macro. 

6. Click OK.

Note: Only keystroke macros for the current Session type are available along 
with Complex Macros. BASIC macros as are available for 3270 and 5250 
sessions. 
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Unassigning Startup Macros
To unassign and disassociate a macro from a session complete the 
following steps:

1. Click Edit>Preference>Startup macro. 

The Macro Operations panel appears as shown in Figure 8-60, 
on page 112.

2. Select None from the Select Default Macro list. Click OK.

3. Select the macro in the Startup Macro List that you wish to 
unassign, if any and click Delete.

4. Click OK.
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9 Swing Client 
Sessions

This chapter contains information about the following subjects:

• ”Session Panel” on page 116.

• ”3270, 5250, and VT Client Emulation Features” on page 116.

• ”Menu Bar” on page 118.

• ”Session Toolbar Menu” on page 120.

• ”Tab Bar” on page 121.

• ”Emulation Space” on page 122.

• ”ClickPad” on page 122.

• ”Copy and Paste Features” on page 123.

• ”Right-Click Menu” on page 126.

• ”3287 and 3812 Client Emulation Features” on page 127.

• ”Menu Bar” on page 127.

• ”Session Window” on page 128.

• ”Recording and Playing Macros” on page 128.

• ”Recording a Macro” on page 128.

• ”Saving a Macro File” on page 129.

• ”Stopping a Macro During Play” on page 131.

• ”Deleting a Macro” on page 131.

• ”Session List” on page 132.

The Java Swing Client requires Java 5 or higher.
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Session Panel
The SESSION panel, shown in Figure 9-61, is the initial user window 
displayed by WebConnect and provides access to pre-configured 
sessions, user-configurable preferences, settings, and other 
components that have been implemented by your System 
Administrator. 

Figure 9-61: SESSION Panel

3270, 5250, and VT Client Emulation Features
The 3270, 5250, and VT Swing client emulations have similar user 
interfaces and share many interface features. The client window has 
a Menu Bar, an Emulator Screen Toolbar, a Tab bar, an Emulation 
Space, and an optional undockable ClickPad as shown in Figure 9-62 
below.
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Figure 9-62: Swing Client Window 

Emulation Space 

ClickPad

Session Toolbar
Menu Bar

Tab bar
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Menu Bar
Your administrator can enable different menu options for your user 
ID; therefore, all of the following functions may not be visible (3270, 
5250 and VT) on your Menu Bar.

Tabl e 9-4 : S essi on  M enu  O pti on s  (S hee t 1 o f  2)

Me nu It em Def in it io n

Fi le

New Session Opens a new session.

Print Screen Prints the current screen.

S tar t As soci ated Pri nt Starts a print session if one is associated with this 
session.

S ave H i sto ry to Fi le Allows screen history to be saved to a file.

Macro

Play Macro Play a pre-recorded macro.

Record Macro
Record actions for macro 
until End Recording’ is 
clicked.

End Recording
Stop recording and save 
previous actions into a 
macro.

Cancel Macro Stop recording and discard 
recorded actions.

S ave S et ti ng s Saves the user’s settings.

Fil e  Tran sfer Transfers files between a Java client and an SNA 
host. 

Fi le  Trans fe r  L ist s Create and use lists of file transfers.

S es sio n Li st Lists all open sessions. Allows termination of 
sessions.

E x it Closes the emulation window and exits the session.
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Edi t

Cu t
Place selected text in clipboard. Replace 
unprotected portions of selected text with spaces. 
Not applicable for VT.

Copy Copies highlighted text from the screen to the 
clipboard.

Copy an d A ppen d Copies and appends (adds) data to the clipboard 
without destroying existing clipboard data.

Past e Paste the copied text from the clipboard to the 
highlighted area of the window.

Cont in ue Paste

When cursor reaches the last valid paste location 
the remainder of the clipboard data is saved and 
the menu option Continue Paste is enabled. When 
selected paste data comes from the saved buffer 
and not from the clipboard. It is disabled after all 
saved data has been pasted.

Se lec t Al l Selects the entire screen to be copied and pasted.

Pre fe ren ce s

Keyboard M aps Edit the Keyboard Maps for this session. 

Col ors Specify Colors.

Attri bu tes Edit the Attributes for this session.

Cli ckPad Turns ClickPad (PF Keys) at the bottom of the screen 
on and off.

H ot spot s Edit Hot Spots. 

VB  S cri pts Edit the VB Script Configuration window.

Sta rt up M acro Edit Startup Macros.

S ett in gs

Edit Audio, Copy/Paste, Cursor, Display, EHLLAPI, 
Keyboard, Mouse, Printer, Proxy, and Window 
Settings. See ”The Settings Menu” on page 164 for 
details.

Hel p

Ab out  Keys Displays a function key map.

Trace Keys Displays diagnostic information for EHLLAPI and 
keyboard macros previously executed.

Abo ut 
S es sio n

Cli ent
Displays Client, Session, and EHLLAPI details This 
information can be saved, printed, or copied to the 
clipboard from this dialog.

S essi on Displays encryption type and cipher used and the 
last WebConnect server connection.

Tabl e 9-4: S essi on  M en u Opti on s  (S hee t 2 of  2)

Me nu It em Def in it io n
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Session Toolbar Menu
The Sessions Toolbar menu must be enabled by your administrator. 
You can toggle it ON/OFF under the Preferences>Settings>Display 
menu on the client window menu bar.

Tabl e 9-5 : Emu lati on  Icon  Va lu es  (S h eet 1 of  2)

Icon D efi ni ti on

New Session—Opens a new session emulation screen.

Disconnect Session—Exits the present session without saving 
information.

Print Screen—Sends the emulator screen to a print session.

File Transfer—Transfers files between a Java client and an SNA 
host application using standard IND$FILE transfer protocol.

Select All—Highlights the entire screen.

Copy—Copies highlighted areas of the screen to the clipboard.
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Tab Bar
The Tab Bar displays a tab for each open session. Clicking on a tab 
displays the corresponding session in the emulation space.

Copy and Append—Used to copy and append (add) data to the 
clipboard without destroying the existing data that is already on 
the clipboard. Use the Left mouse button to identify (highlight) text 
you want to copy.

Paste—Copies data from the clipboard to the highlighted area on 
the screen.

Block Paste—Copies data from the clipboard to the highlighted 
area on the screen using Block mode.

ClickPad—Turns the ClickPad (PF Keys) at the bottom of the 
screen on and off.

Play Recorded Macro—Displays a list of previously recorded 
macros and allows you to select one to play.

About Session—Displays detailed information about the client 
machine, browser, and version of WebConnect Client. This 
information can be saved, printed, or copied to the clipboard from 
this dialog.

Tabl e 9-5: Emu lat ion  Icon  Valu es  ( Sh eet 2 of  2)
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Emulation Space
The Emulation Space, located below the Menu and Tool bars, 
displays detailed messages of the WebConnect server and the host 
connections. If encryption is used, messages regarding encryption 
key generation also displays in the emulation space. After a host 
connect is established, host data displays in the emulation space 
according to host data attributes, unless the Hot Spots option is 
active. See ”Configuring Hot Spots” on page 162.

ClickPad
The ClickPad displays below the Emulation Space if enabled by the 
administrator as shown in Figure 9-62, on page 117.

The ClickPad has a handle on the left hand side that can be used to 
click and drag the clickpad out of the emulation window. 

Click Preferences>ClickPad to access the ClickPad Configuration 
window.

Figure 9-63: ClickPad Configuration
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Copy and Paste Features
The copy/paste feature can be set for either block (copy/paste 
selected columns) or stream (copy/paste rows) mode by setting the 
Block Paste option under the Setting menu. By default, this setting is 
block mode enabled. If disabled, the data is copied in stream mode.

Copy

To copy text to the clipboard, complete the following steps:

1. Mark the text by using one of the following copy methods:

• Select All from the Edit menu: Selects the current screen and 
the entire contents of the scroll buffers. 

• Highlighting text using a mouse: Click and hold the left 
mouse button at the beginning of the text you want to copy. 
Drag the cursor to highlight the entire text you want to copy.

• Highlighting text using the keyboard: Position the cursor at 
the beginning of text you want to mark and then use the key 
sequences in Table 9-6.

• Double left mouse to select entire field.

2. Select Copy from the Edit menu or toolbar. The text is copied to 
the clipboard.

You can use certain keys to highlight text on the screen, as 
defined in the following table.

Tabl e 9-6: Keyboard M appi ng  

Key S equen ce M appi ng

Sh i f t  + Left Highlight the text to the left of the current select 
location.

Sh i f t  + R ight Highlight the text to the right of the current select 
location.

Sh i ft  +  Up Highlight the text above the current select location.

Sh i f t  + Down Highlight the text below the current select location.

Sh i f t +  Home Highlight the text to the beginning of the row of the 
current select location.

Sh i f t  + End Highlight the text to the end of the row of the current 
select location.
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These sequence functions are described below.

• Shift + Left: This marking function uses the shift key and left 
arrow key combination. If no text is selected, the current 
cursor position is selected. Otherwise, the character position 
to the left of the last selected character position becomes the 
new last character selected in the block. If the last selected 
character position is the beginning of a row, the last character 
of the previous row becomes the new last character selected.

• Shift + Right: This marking function uses the shift key and 
right arrow key combination. If no text is selected, the current 
cursor position is selected. Otherwise, the character position 
to the right of the last selected character position becomes 
the new last character selected in the block. If the last 
selected character position is the end of a row, the first 
character of the next row becomes the new last character 
selected.

• Shift + Up: This marking function uses the shift key and up 
arrow key combination. If no text is selected, the current 
cursor position and all characters up to but not including the 
character above the current cursor position is selected. 
Otherwise, the character position above the last selected 
character position becomes the new last character selected in 
the block. If the last selected character position is in the first 
row, the first character on the screen becomes the new last 
character selected. If Shift + Up is followed by a Shift + Down, 
the new last character selected is the position that was 
selected prior to the Shift + Up.

• Shift + Down: This marking function uses the shift key and 
down arrow key combination. If no text is selected, the 
current cursor position and all characters up to but not 
including the character below the current cursor position is 
selected. Otherwise, the character position below the last 
selected character position becomes the new last character 
selected in the block. If the last selected character position is 
in the last row, the last character on the screen becomes the 

Sh i ft  +  Page Up Highlight the text from the current cursor position to 
the first row on the screen.

Sh i f t  + Page Down Highlight the text from the current cursor position to 
the last row on the screen.

Tabl e 9-6 : Keyboard M appi ng   (Co nti n ued)

Key S equen ce M appi ng
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new last character selected. If Shift + Down is followed by a 
Shift + Up, the new last character selected is the position that 
was selected prior to the Shift + Down.

• Shift + Home: This marking function uses the shift key and 
home key combination. If no text is selected, the current 
cursor position and all characters up to and including the first 
character in the row are selected. Otherwise, all characters 
from the last selected position to the first character in the row 
are selected unless it is already selected. If characters are 
already selected, then those characters are deselected.

• Shift + End: This marking function uses the shift key and end 
key combination. If no text is selected, the current cursor 
position and all characters up to and including the last 
character in the row are selected. Otherwise, all characters 
from the last selected position to the last character in the row 
are selected unless it is already selected. If characters are 
already selected, then those characters are deselected.

• Shift + Page Up: This marking function uses the shift key and 
page up key combination. When used, the current cursor 
position and all characters up to and including the first 
character on the screen are selected. Any characters that were 
previously selected but are not in this range are deselected.

• Shift + Page Down: This marking function uses the shift key 
and page down key combination. When used, the current 
cursor position and all characters up to and including the last 
character on the screen are selected. Any characters that were 
previously selected but are not in this range are deselected.

Paste

To paste text from the clipboard to the screen, complete the 
following steps:

1. Position the cursor where you want to begin copying text.

2. Select Paste from the Edit menu or toolbar.

Note:  You can reposition the cursor by selecting the Cursor to Mouse 
option in the Setting menu. Then click the position where you want to 
move the cursor.
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Right-Click Menu
Many copy and paste tasks along with session switching can be 
accomplished using the right-click menu. Table 9-7 on page 126.
Tabl e 9-7 : R i ght - Cli ck  M enu

Item Def in it io n

Copy Copy the highlighted text to the clipboard.

Copy a nd 
Appe nd

Copy the highlighted text and append to the contents of 
the clipboard.

Pa ste Insert text from the clipboard at the cursor position.

S el ect  All Select all text on page.

M ove Curse r  
H ere Cause curser to reposition at selection.

Prin t 
S el ec ti on Send the selected text to the printer.

Sw i tch  to  
Se ssi on Change focus to session selected from the pick-list. 
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3287 and 3812 Client Emulation Features
The 3287 and 3812 session user interface is a tab that shows the 
progress of 3287 and 3812 print jobs. A few user options can affect 
the printed output. These options, and other interface features, are 
explained below. 

Figure 9-64: 3287 and 3812 Client Emulation

Menu Bar
The Menu Bar options are described in Table 9-8 below.

Tabl e 9-8: 328 7 M en u Fun ct io ns 

Menu I tem Descri pti on

F i le

New Sess ion Opens a new 3287 session emulation tab.

Save Sett ing Saves the current user’s settings.

Sess ion L i s t List all open sessions.

Exi t Close session tab

Preferences Sett ings See Table 12-17 on page 177

Help About  Sess ion Select to view more information about the client operating system, 
applet version, and Java version and WebConnect Server.
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Session Window
Information displayed about the print job in the session window are:

• Session ID

• Printer LU

• Printer State

• Total Print Jobs

• Total Pages Printed

• Total Pages Printed For This Job.

Recording and Playing Macros
You can record frequently used keystrokes and save them as macros 
to be activated and played back. Defined macros are either saved 
locally or to the server, depending on the Save User Files On setting 
option in your User Preferences. See "Preferences," page 29. Select 
one of the following functions from the emulation session File> 
Macro> menu:

• Play Macro

• Record Macro

• End Recording

• Cancel Macro

Recording a Macro
To record a macro complete the following steps:

1. From the emulation session menu, select File>Macro>Record 
Macro.

Note: In some instances, your system administrator may have set your user 
preferences to restrict macro recording. If this is the case your menu 
displays only the “Play Macro” feature. The same is true for the play 
macro toolbar icon.
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The New Macro Name dialog box appears as shown in 
Figure 9-65 below.

Figure 9-65: Record Macro Name

2. In the Macro Name box, type a name for the new macro (for 
example, CICS Logon).

3. Select Record to WebConnect Macro or Record to VBScript 
from the drop-down menu.

4. Click OK.

5. Type the key sequence (i.e., the commonly used keystrokes) to 
record the macro.

6. When you have finished recording, click File> Macro> End 
Recording.

7. Click OK. 

Saving a Macro File
Immediately after recording a macro you must save it.

1. Select File>Macro>End Recording Macro.

The Save New Macro dialog box appears. 

Note: Do not use the mouse or clickpad while recording. Only keystrokes can 
be recorded, not mouse actions. See ”Copy and Paste Features” on 
page 123 for instructions on using the keyboard to highlight text. For a 
list of the key mappings, select about keys from the emulation session 
Help menu.

Note: You MUST continue to the following instructions and SAVE the macro or 
your work will be lost.
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Figure 9-66: Save Recorded Macro

2. Click Yes.

The macro you recorded is saved.

The macro you recorded and saved is available to replay the next 
time you start a session.

Playing a Macro
1. Select File> Macro> Play Macro. 

The Play Macro window opens containing a list of available 
macros as shown in Figure 9-67, page 130.

Figure 9-67: Recorded Macro List

2. Select the name of the macro that you want to play from the list.
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3. Click OK. The macro keystrokes that you previously recorded 
automatically play back, activating the sequence.

Stopping a Macro During Play
This option stops a macro while it is running.

1. During a macro playback if a long time-out occurs and you need 
to stop it, select Macro and Cancel Macro.

Deleting a Macro
1. Select File>Preferences>Keyboard Map. The Key Macro 

window displays.

Figure 9-68: Key Macro Window

2. Click the WebConnect Macros Tab.

3. Select the macro to be deleted from the list.

4. Click Delete Macro to delete the macro as shown in Figure 9-69 
below.

Note: For 3270, 5250, and VT sessions you can also play a macro from the 
Toolbar menu items. See, Table 9-5 on page 120.
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Figure 9-69: Delete Macro

5. Click OK.

Session List
If the WebConnect Administrator has enabled the Display Session 
List on Startup feature, clicking on a session type icon in the SESSION 
panel of the HTML user interface opens a session list window 
followed by the emulation session itself. Figure 9-70shows a Session 
List window with several sessions open.

Figure 9-70: Session List

The session list provides the means to manage multiple open 
sessions. It displays a list of all active sessions identified by their 
session ID number. Your WebConnect administrator can specify 
custom group names. In this case, sessions will be listed by group 
name. Sessions that have been terminated due to network 
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conditions or by the WebConnect Server are listed in red. Sessions 
can also be individually or collectively stopped by using the 
Terminate Session or the Terminate All Sessions buttons.

The Session List window can also be enabled by selecting 
File>Session List from the session menu. 

Figure 9-71: JRE Placeholder

The JRE placeholder window is required by the WebConnect client. 
Close this window only after exiting the client.

Note: Do not use Pop-up Window Blockers as they can prevent the JRE 
placeholder window from starting. Disable all Pop-up Window Blockers
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10 Swing Client 
Printing

This chapter contains information about the following subjects:

• ”Printing a Screen” on page 135.

• ”Printing Part of a Screen” on page 135.

• ”VT Session Logging” on page 136.

• ”3287 Print Session” on page 138.

• ”Date/Time Stamp Operation” on page 138.

WebPrint allows full control over font size and style and 
automatically sizes a printed document based on display orientation.

OpenConnect’s system fonts have been enhanced with custom font 
technology from Bitstream Inc.™

WebPrint must be installed locally on the client system. See 
”Installing WebPrint” on page 38.

Printing a Screen
You can print a single session window after you select a print screen 
option, see the following steps:

1. From the open session window, select File>Print Screen from 
the menu. The printer dialog window for the system displays. If 
the “Print to File” option has been configured it opens instead.

2. Follow the system printing procedures.

Printing Part of a Screen 
To print a portion of the window text, highlight the desired area then 
right click and choose Print Selection. A printer dialog will display.
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VT Session Logging
Activity during a VT session can be recorded in two different ways. 

• Log Session to Printer - while enabled text displayed on the VT 
session is echoed to the printer. 

• Log Session to File - while enabled text displayed on the VT 
session is echoed to the user selected file.

Simultaneous logging to file and printer are not allowed. 

When the user enables session logging, the applet sends a 
command to the WC server to start logging. The VT emulation in the 
server manages accumulation of log data and sends each line to be 
logged to the applet.

While logging, each printable character received is stored in a buffer 
in the WC server. The buffer is flushed to the applet for printing 
whenever the carriage return (CR) character is received from the 
host. Tab characters are expanded in the buffer for proper alignment 
of tabbed data in the printer log.

If host-initiated VT print (printer controller on) is started, the current 
logging buffer is flushed and logging suspended. Logging resumes 
when the print controller off sequence is received. Printer controller 
data is spooled to a separate print job by the applet to prevent 
mixing of printer controller data and session logging data.

The session logging feature uses the same applet print method 
configured for screen print and printer controller mode. This is 
configured in the session file or in the user's preferences.

VT Log Session to Printer
To use Session Logging complete the following steps from the 
session screen:
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Figure 10-72: Log VT Session to Printer

1. Select File>Log Session>Log Session to Printer

A print dialog box appears.

2. Check the print settings, make changes as necessary, and click 
OK.

3. Continue with your session.

Data entered is stored in the print buffer until you are ready to 
print.

4. To print the accumulated session activity click Files>Log 
Session>Log Session to Printer again. 

Your session is sent to your selected printer and session logging 
is disabled. 

VT Log Session to File

To use Session Logging complete the following steps from the 
session screen:

1. Select File>Log Session>Log Session to File

The Specify Session Log Filename dialog box appears.

2. Enter a filename for the session log and click OK.

3. Continue with your session.

Data entered is stored in the session log file.
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4. To discontinue session logging click Files>Log Session>Log 
Session to File again. 

3287 Print Session
Printing from any browser to a specific 3287 logical unit (LU) and 
gateway:

1. Select 3287 Print Session from the Start User Session panel. A 
3287 printer session window displays.

2. Be sure the correct gateway and LU displays in the printer 
session window.

3. Send a mainframe print job to the selected LU. The 3287 printer 
session window indicates that the session is printing.

Date/Time Stamp Operation
The date/time and user@host will print in the bottom margin of all 
pages generated by Print Screen. The user ID and PC host name will 
be at the left margin in the format user@host with the date/time 
printed at the right margin. US systems result in a date displaying as 
dd-mm-yy hh:mm:ss AM/PM format, 27-Sep-02 3:35.29 PM.

jdoe@ocs5555.oc.com 27-Sep-02 3:35.29 PM

Print to File Date/Time

This method does not render the page and then print it. Instead, 
each string is written to the file as it is received by the Print to File 
class.

Note: To check the LU and gateway you are printing to, select About 
Server from the Help menu on the printer session window 
displayed when you start a 3287 print session. A status 
window will open identifying printer information, such as the 
number of jobs to print.
To run print jobs unattended, disable Show Printer Dialog 
from the session settings menu. This is not valid for JDK 
printing.
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Figure 10-73: Print to File Dialog

Print date/time stamp, user ID, and PC host name will print two text 
lines at the top of the screen, as in the following example:

user1@abc.oc.com 
27-Sep-02 3:35:29 PM

Figure 10-74: Print to File Time/Date Stamp

gtoye@ocs1355.oc.com   
27-Sep-02 3:35:29 PM 
    OOOOO                        CCCCCC                                           
   O     O                      C                                                 
   O     O  PPPP   EEEE  N   N  C         OOO   N   N  N   N  EEEE   CCC  TTTTT   
   O     O  P   P  E     NN  N  C        O   O  NN  N  NN  N  E     C       T     
   O     O  PPPP   EEE   N N N  C        O   O  N N N  N N N  EEE   C       T     
   O     O  P      E     N  NN  C        O   O  N  NN  N  NN  E     C       T     
    OOOOO   P      EEEE  N   N   CCCCCC   OOO   N   N  N   N  EEEE   CCC    T     
                                                                                  
   O p e n C o n n e c t   S y s t e m s   I n c .  -  D a l l a s , T e x a s    
                                                                                  
                      (Technical Support: 972-484-5200)                           
   ---------------------------  SNA NETWORK  ----------------------------------   
              Access application by entering sign-on command:                     
                                                                                  
              APPLICATION NAME                     SIGN-ON COMMAND                
              ================                     ===============                
              VM/CMS/PROFS                         VM                             
              MVS/TSO                              TSO                            
              MVS/CICS                             CICS                           
              MVS/IMS                              IMS                            
              NETVIEW                              NETVIEW                        
   ----------------------------------------------------------------------------   

(This terminal is controlled by MVS/VTAM on ES/9000)

gtoye@ocs1355.oc.com   
27-Sep-02 3:35:29 PM 
    OOOOO                        CCCCCC                                           
   O     O                      C                                                 
   O     O  PPPP   EEEE  N   N  C         OOO   N   N  N   N  EEEE   CCC  TTTTT   
   O     O  P   P  E     NN  N  C        O   O  NN  N  NN  N  E     C       T     
   O     O  PPPP   EEE   N N N  C        O   O  N N N  N N N  EEE   C       T     
   O     O  P      E     N  NN  C        O   O  N  NN  N  NN  E     C       T     
    OOOOO   P      EEEE  N   N   CCCCCC   OOO   N   N  N   N  EEEE   CCC    T     
                                                                                  
   O p e n C o n n e c t   S y s t e m s   I n c .  -  D a l l a s , T e x a s    
                                                                                  
                      (Technical Support: 972-484-5200)                           
   ---------------------------  SNA NETWORK  ----------------------------------   
              Access application by entering sign-on command:                     
                                                                                  
              APPLICATION NAME                     SIGN-ON COMMAND                
              ================                     ===============                
              VM/CMS/PROFS                         VM                             
              MVS/TSO                              TSO                            
              MVS/CICS                             CICS                           
              MVS/IMS                              IMS                            
              NETVIEW                              NETVIEW                        
   ----------------------------------------------------------------------------   

(This terminal is controlled by MVS/VTAM on ES/9000)

user1@abc123.oc.com

Time/Date
Stamp
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11 Swing Client File 
Transfer

WebConnect uses the standard IND$FILE protocol to transfer files 
between a Java client and an SNA host application. This capability 
can be used to address a variety of networking needs, including 
centralized data backups and data warehousing through an SNA 
host. 

Because SNA host files use different file formats from WebConnect 
files and Java client files, be sure to use the appropriate options for 
converting files to the receiving host’s file format during transfer. 
Format conversion allows the receiving host applications to use the 
file without further modification. SNA hosts and SNA applications 
used for transferring files are listed below as well as the IBM program 
number and operating system for each application:

• WebConnect supports only the DFT (Distributed Function 
Terminal) file transfer mode.

You must be familiar with the file transfer application program you 
use.

Select an option below for file transfer instructions: 

• "Sending and Receiving CICS/VS Files," page 142

Note: The 3270 File Transfer menu option is only available if it is enabled by 
your administrator.

Tab le 11 -9: S N A H ost/A ppli cati on  Tran sfer  

A ppli cati on  Prog ram Pro gram 
N u mber

Op erat in
g Syste m

3270 PC File Transfer for CICS 5798-DQH VS

3270 PC File Transfer for TSO 5665-311 MVS

3270 PC File Transfer for VM 5664-281 VM
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• "Sending and Receiving TSO Files," page 144

• "Sending and Receiving VM Files," page 148

• "Multiple File Transfers," page 151

Sending and Receiving CICS/VS Files
WebConnect allows file transfer between a Java client and the 
Customer Information Control System/Virtual Storage (CICS/VS) SNA 
application.

See the following steps to transfer files to and from CICS/VS.

1. Make sure that the WebConnect client is connected to the 
desired SNA host and CICS application. 

2. From the File menu, select File Transfer>To Host (or From 
Host). The appropriate file transfer window will display.

3. Select CICS tab. 

Figure 11-75: CICS/VS Files
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4. Under Local File click Browse to search for a file. A file selection 
window will display.

When you select a file the name will display in the text field of the 
Local File box.

UNIX Format
1. To transfer the file in UNIX format, click the UNIX Format button 

under Browse. UNIX format converts line separators to carriage 
return and line feed pairs during a Send operation. During a 
receive operation, carriage return and line feed pairs are 
converted to line separators.

Do not select the UNIX format when using the binary option or the 
binary data will be corrupted.

2. Type a host filename in the Data Set Name field in the CICS Tab 
box. 

3. Type comments about the file being transferred in the Comment 
field in the CICS Tab. The comments will be automatically 
included in the first record of the CICS/VS host file.

Transfer Options
1. Select a file type from the Transfer Options box to configure the 

way the file contents are treated during the transfer process. The 
choices are described below: 

• ASCII
This option instructs the SNA host to translate data between 
the EBCDIC and ASCII character formats. Use this option for 
transferring ASCII formatted files, such as text edit files or 
print files. Do not use the ASCII option for transferring binary 
data (such as output data from a database program) or object 
code files (such as C compiler object code). 

Note: The procedures for searching for filenames will vary by system.

Note: The CICS filename can be a program name, a transaction identification, 
or identification selected by the CICS/VS application programmer. If the 
filename does not exist, the CICS/VS application will automatically 
create it. The filename can be one to eight characters long. The character 
in the first position must be alpha; other characters can be alpha or 
numeric.
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• Binary
This option instructs the SNA host to perform no character 
translation. Use this option to transfer encrypted data, 
compiled programs, and other noncharacter information. 

2. Click Append if a local file is to be added to the end of an SNA 
host file or if an SNA host file is to be appended to a local file. 

• If you do not select Append in the Receive dialog box, the 
SNA host file will replace the Java client file. 

• If you do not select Append in the Send dialog box, the 
TCP/IP host file will replace the SNA host file. 

3. If the CRLF option is desired, check CRLF. 

4. Click Send or Receive to begin the file transfer.

5. A Transfer Status window will display to confirm the transfer was 
successfully completed. Click OK.

Sending and Receiving TSO Files
WebConnect allows you to transfer files between a Java client and 
the Time Sharing Option (TSO) SNA application. 

See the following steps to transfer files to and from a TSO application 
from a User Session.

1. Make sure that the WebConnect client is connected to the 
desired SNA host and TSO application.

2. From the File menu, select File Transfer>To Host (or From 
Host). 

3. Click the TSO tab.

The appropriate file transfer window will display.

Note: If you do not specify the CRLF option in send mode, the SNA host 
disregards the local file’s line separators.

Do not use the CRLF option for transferring binary data (such as output 
data from a database program) or object code files (such as C compiler 
object code).

Disabling the CRLF option in the Transfer Options dialog box instructs 
the CICS/VS host to copy the file unaltered to the appropriate TCP/IP 
host. This option can be used to transfer encrypted data, compiled 
programs, and other data that is unreadable. 
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Figure 11-76: TSO File Transfer Example

4. Click Browse under Local File to search for the peer’s file. A file 
selection window will display. for example, "Specify File to SEND." 
(The procedures for searching for the peer filename may differ 
by system.) 

5. When you select the peer file and click Open, the name will 
display in the text field in the Local File box.

6. To transfer the file in UNIX format, click the UNIX Format button. 
UNIX format converts line separators to carriage return and line 
feed pairs during a Send operation. During a receive operation, 
carriage return and line feed pairs are converted to line 
separators.

7. Type a host filename in the Data Set Name field. 

8. Type a member name in the Member Name field. 

Note: The TSO host data set name must conform to IBM naming conventions. 
You can enter an existing data set name (stored in your library) or a new 
data set name. A closing quote will not display in the Member 
Name field.
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The member name is optional. If entered, the member name 
should be a member in a partitioned data set directory.

9. WebConnect does not create the partitioned data set. 
When you use the Send window to copy a file to a 
partitioned data set and include a member name, the 
partitioned data set must exist.

10. The TSO application adds a user ID prefix to the combined data 
set and member name. To eliminate the user ID prefix, enclose 
the data set and member name in single (right) quotation marks, 
for example,’smith.pds2.file1.’

11. If a password is required, type it in the Password field. A 
password is only required if password-protection has been 
specified for the TSO data set.

12. Select a file type from the Transfer Options box to configure the 
way the file contents are treated during the transfer process. The 
choices are described below:

• ASCII—this option commands the SNA host to translate data 
between the EBCDIC and ASCII character formats. Use this 
option for transferring ASCII formatted files, such as text edit 
files or print files. Do not use the ASCII option for transferring 
binary data (such as output data from a database program) or 
object code files (such as C compiler object code). 

• Binary—this option instructs the SNA host to perform no 
character translation. Use this option to transfer encrypted 
data, compiled programs, and other noncharacter 
information. 

Append a File
1. Click Append if you plan to add a local file to the end of an SNA 

host file, or you will append an SNA host file to a local file. The 
Append option will override other values specified by the LRECL 
parameter and RECFM options in the Advanced section. 

• If you do not select Append in the Receive dialog box, the 
SNA host file will replace the Java client file. 

• If you do not select Append in the Send dialog box, the 
TCP/IP host file will replace the SNA host file.

Note: If you select the UNIX Format option when using the Binary option, the 
binary data will be corrupted.
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Record Format and Space Options

Figure 11-77: Record Format Options

1. In the Record Format box, click a radio button for the desired 
record format. This is only valid when sending a file. The valid 
values are described below: 

• Fixed—indicates the data set’s records are fixed length.

• Variable—indicates the data set’s records are variable length.

• Undefined—indicates the data set contains undefined record 
lengths.

• None—indicates no record format is to be used.

2. To set the allocated amount of space for a new data set, click 
Blocks, Tracks, or Cylinders on the Space tab. When you select 
Default, TSO uses the Blocks parameter default value which is 
determined by the specifications listed below: 

• Blocks—use the smallest storage entity.

• Tracks—use the middle-sized storage entity.

• Cylinders—use the largest storage entity.

• Primary—the primary allocation for the Blocks parameter.
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• Increment—the increment allocation for the Blocks 
parameter.

3. If sending a file, type a size value (such as the data block size of a 
TSO data set) in the BLKSIZE field in the Record Format area. The 
variable you type represents a data block’s byte count. The 
default value is 80.

4. Type a logical record length value of the SNA host file in the 
LRECL field in the Record Format area. The parameter value 
represents the number of characters for each record. If the 
parameter is not entered, the record length is determined by the 
file transfer operation. For new files, the parameter’s default 
value is 80. 

5. The characteristics of the existing file are used if you are 
replacing a file or appending information to a file. If you are 
transferring variable length records, the parameter represents 
the maximum record size. The parameter’s value becomes the 
longest record sent if you do not send a record of the maximum 
operating system size; only valid if you are sending a file.

6. Click Send to begin the file transfer.

7. Transfer Status will display at the bottom of the dialog to confirm 
the transfer was successfully completed. Click Exit.

Sending and Receiving VM Files
WebConnect allows file transfer between a Java client and the Virtual 
Machine/Conversational Monitor System (VM) SNA application.

See the following steps to transfer files to and from a VM application.

1. Make sure that the WebConnect client is connected to the 
desired SNA host and VM application.

2. From the File menu, select File Transfer>To Host (or From 
Host). The appropriate file transfer window will display.

3. Click VM tab.

4. Click Browse under Local File to search for the peer’s file. A file 
selection window displays. The procedures for searching for the 
peer filename vary by system.

5. Select the peer file. The name displays in the text field in the 
Local File box.

To transfer the file in UNIX format, click the UNIX format button. 
UNIX format converts line separators to carriage return and line 
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feed pairs during a Send operation. During a receive operation, 
carriage return and line feed pairs are converted to line 
separators.

6. Type a host filename in the Data Set Name field in the VM tab. 
The VM filename can be one to eight characters long. 

7. Type the appropriate file type in the VM File Type field. This 
parameter identifies the VM disk file type.

8. Type an appropriate value in the VM File Mode text box. This 
parameter identifies the VM disk file mode. If you do not enter a 
file mode parameter, the VM application uses the A1 default 
value.

9. Select a file type from the Transfer Options box to configure the 
way the file contents are treated during the transfer process. The 
choices are described below:

• ASCII—this option instructs the SNA host to translate data 
between the EBCDIC and ASCII character formats. Use this 
option for transferring ASCII formatted files, such as text edit 
files or print files. Do not use the ASCII option for transferring 
binary data (such as output data from a database program) or 
object code files (such as C compiler object code). 

• Binary—this option instructs the SNA host to perform no 
character translation. Use this option to transfer encrypted 
data, compiled programs, and other noncharacter 
information. 

10. Click Append if a local file is to be added to the end of an SNA 
host file or if an SNA host file is to be appended to a local file.

• If you do not select Append in the Receive dialog box, the 
SNA host file replaces the Java client file.

• If you do not select Append in the Send dialog box, the 
TCP/IP host file replaces the SNA host file. 

Note: The VM application automatically creates the receiving host’s filename if 
a filename does not exist.

Caution: Do not select the UNIX Format option when using the Binary option 
or the binary data will be corrupted.
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• To use the CRLF option, check CRLF. 

• During a Receive operation, carriage return and line feed 
pairs are converted to line separators.

• Disabling the CRLF option in the Transfer Options dialog box 
instructs the CICS/VS host to copy the file unaltered to the 
appropriate TCP/IP host. This option can be used to transfer 
encrypted data, compiled programs, and other data that is 
unreadable. 

• If you do not activate the Append option in the Receive 
dialog box, the SNA host file replaces the Java client file. If you 
do not activate the Append option in the Send dialog box, 
the TCP/IP host file replaces the SNA host file.

11. To specify the record format, LRECL, click the Record Format 
tab. 

12. In the Record Format area, click a radio button for the desired 
record format. This is only valid when sending a file. The valid 
values are described below: 

• Fixed—indicates the data set’s records are fixed length.

• Variable—indicates the data set’s records are variable length.

• Undefined—indicates the data set contains undefined record 
lengths.

• None—indicates no record format is to be used.

13. Type a logical record length value of the SNA host file in the 
LRECL field in the Record Format area. The parameter value 
represents the number of characters for each record. If the 
parameter is not entered, the record length is determined by the 
file transfer operation. For new files, the parameter’s default 
value is 80.

If you are replacing a file or appending information to a file, the 
characteristics of the existing file will be used. If you are transferring 

Note: You can click the UNIX Format check box for ASCII file transfers. This 
allows line separators to be converted to carriage return and line feed 
pairs during a Send operation.

Caution: Do not use the ASCII or CRLF options for binary data such as output 
data from a data base program or object code files such as C compiler 
object code. 
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variable length records, the parameter represents the maximum 
record size. If you do not send a record of the maximum operating 
system size, the parameter value becomes the longest record sent. 
This is only valid if you are sending a file.

14. Click Send again to begin the file transfer.

15. Transfer Status will display at the bottom of the dialog to confirm 
the transfer was successfully completed. Click Exit.

Multiple File Transfers
The WebConnect applet supports IND$FILE multiple file transfers. 
You can create and add files to a multi-file list, then transfer them as 
a group of files. These lists can be saved, edited and deleted from 
this menu. 

Please refer to "Sending and Receiving CICS/VS Files," page 142 for 
basic file transfer procedures and windows.

1. Select File>File Transfer Lists from the applet menu.

2. Select the Host Environment of either CICS, TSO, or VM.

Any lists you have previously saved will display.

Figure 11-78: Lists

3. Type a new list name and click Add.

4. Click Add File in the Current List area of the window. The 
INDFILE Transfer box displays.
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Figure 11-79: INDFILE Transfer

5. Select To Host or From Host.

6. To select a local file, click the Browse button.

7. Name the file in the Data Set Name field and select other 
appropriate data.

8. Click Send or Receive to add this file to the list.

a. To clear the list, click the Clear List button.

b. To define and save the list, click Save.

c. To delete a file from the list, select a file in the list and click 
Delete File.

d. To replace a file in the list, select a file in the list and click 
Edit File.

9. When all the files you want to transfer are in the Current List area 
click Transfer.

Transfer Status will display at the bottom of the dialog to confirm 
the transfer was successfully completed. Click Cancel.
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12 Swing Client User 
Preferences

This chapter contains information about editing user emulation 
session preferences from the menu bar of the Emulator Screen. The 
following topics are covered:

• ”Preferences Menu” on page 153.

• ”Configuring Colors” on page 153.

• ”Configuring Attributes” on page 154.

• ”Configuring the ClickPad” on page 156.

• ”Configuring Hot Spots” on page 162.

• ”The Settings Menu” on page 164.

• ”Cursor Options” on page 168.

• ”Type-ahead” on page 169.

• ”Move Cursor with Mouse (Light Pen)” on page 170.

Preferences Menu
This section contains information about the options available from 
the Preferences menu on the Emulation Client menu bar that 
control.

Configuring Colors
1. To change or enhance the color configuration, select 

Preferences>Colors from the menu.
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Figure 12-80: Edit Color Configuration

2. To edit a color, double-click the color you want to change. 

The color chooser dialog box appears.

3. Click on one of the basic colors or create a custom color and click 
OK.

4. Repeat as necessary and then click OK.

Configuring Attributes
Various screen behaviors associated with fields can be configured 
through the Attributes panel. Complete the following steps to edit 
your screen attributes and colors.

1. Select Preferences>Attributes.

Note: The Associate with session: box allows you to associate 
the color values with your user ID and the session file name. 
When selected, the settings will apply to all sessions that you 
start with the same WebConnect session file. For example, 
using userid and 3270, the user’s local filename will be 
userid.cm3. If saved for the specific session (as in def3270 for 
this example), the filename would be userid-def3270.cm3.

Note: To assign or change a specific attribute color, see Configuring 
Attributes below.
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Figure 12-81: Attribute Configuration

2. The attribute configuration window displays an example of 
attributes supported by the terminal type (3270/5250/VT).

3. Select an attribute from the list.

4. Select a Foreground and Background color from the drop-down 
lists. 

5. Select an Attribute such as Blinking, Reverse Video, Intense, or 
Underline if desired.

6. Click OK when you complete the changes.

Note: The Associate with session: box allows you to associate the 
attribute values with your user ID and the session file name. 
When selected, the settings will apply to all sessions that you 
start with the same WebConnect session file. For example, 
using userid and 3270, the user's local filename will be 
userid.at3. If saved for the specific session (as in def3270 for this 
example), the filename would be userid-def3270.at3.

Note: To change the color configuration, see "Configuring Colors," 
page 153.
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Configuring the ClickPad
Each emulation session type (3270, 5250 and VT) has an associated 
ClickPad for that session type. Swing (JAVA) clients have a feature 
listed under the Preferences Menu called ClickPad. Options under 
this feature allow users to customize the clickpad for their personal 
use. The user can add or delete keys, add macros, insert padding 
(blank buttons) to separate keys into groups and rearrange the 
ClickPad to the user's display preference.

When customizing, the user can apply the custom clickpad to all like 
session types, meaning all 3270 sessions or all 5250 sessions etc., or 
assign the custom clickpad to a particular session, solely for use with 
that particular session.

ClickPad Configuration: Row/Col Size and Docking Position
The Row/Col Size box allows the user to determine how many keys 
to place in a row (applicable in the East/West Docking Position) or in 
a column (applicable in the North/South Docking Position.)

Figure 12-82: ClickPad Configuration

In the following example, the Docking Position is East, and the 
Row/Col is set at 10. There are 10 rows of keys.
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Figure 12-83: ClickPad Docked East

In the next example, the Docking Position is North and the Row/Col 
is set at 10. There are 10 columns of keys.

Figure 12-84: ClickPad Docked North.
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Figure 12-85: Floating Enabled

Floating ClickPad
When the Floating checkbox is enabled, the ClickPad is totally 
detached from the session screen allowing the user to position it 
anywhere on their desktop display. The Floating ClickPad window 
will only be displayed when the associated session has focus on the 
screen. To bring it back to the session, click on the x in the upper 
right hand corner and the ClickPad will dock either North or West. 

You can also detach the ClickPad temporarily from the session by 
placing the cursor on the handler bar (the dotted bar) and dragging 
the ClickPad anywhere on the display space. 
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Figure 12-86: Handler Bar

To bring it back to the session, click on the x in the upper right hand 
corner and the ClickPad will return to its original position. 

Emulator Keys: Move Up, Move Down and Delete Buttons

Each emulator type (3270, 5250 or VT) will automatically 
accommodate the normal clickpad keys associated with the type of 
session. 

The Move Up and Move Down buttons provide the user with the 
ability to rearrange the layout of the ClickPad. To do this, simply 
place the cursor over the key that you want rearranged and use the 
Move Up and Move Down buttons to position the key to the 
desired location. 

The Delete button provides the ability to remove keys from the 
ClickPad.

Emulator Key Section
The Emulator Key drop down box contains a list of emulation keys 
for selection. 

As stated earlier, all relative session type standard keys are in this list 
as well as some additional keys that might be desired. After making a 
selection, press the Add Emulator Key button to add the selected key 
to the ClickPad.

Note: All associated standard session keys are also stored in the Emulator Key 
section, so if you accidentally delete a standard session key, you can 
always add it back.
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Padding
The Add Padding button is used to place padding (blanks or spacers) 
between sets of keys. In the example below, an Add Padding button 
was placed after PF24 to separate the PF keys from the PA keys and 
an Add Padding button was placed before the first macro key to 
place macros in their own row. See Figure 12-87, on page 160.

Figure 12-87: Padding

Macro Section
If you have created macros and would like to add a button on the 
clickpad for a macro, select the desired macro from the Macro drop 
down box, optionally, assign it a key label in the Macro Label box and 
click Add Macro. Use the Move Up and Move Down buttons for key 
placement on the ClickPad.
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Figure 12-88: Add Macro

Figure 12-89: Macros
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Display Preview
Clicking on the Display Preview button will display a preview screen 
of what the ClickPad will look like prior to selecting the OK button. 

If all looks well, simply close the window on the preview screen with 
the x button in the upper right hand corner and click the OK button.

Figure 12-90: ClickPad Preview

If the outcome was not as desired, close the preview window and 
continue customizing your ClickPad. 

Configuring Hot Spots 
Hot Spots configuration allows you to select and display the 
definition of text strings as clickable buttons when the strings 
appear on the screen.

Complete the following steps to set or modify hot spots.

1. Start your client session.

Note: Note: The Associate with session: option allows you to associate the 
clickpad values with your user ID and the session file name. When 
selected, the settings will apply to all sessions that you start with the 
same WebConnect session file type. For example, using userid and 3270, 
your local filename will be userid.ck3. If saved for the specific session (as 
in def3270 for this example), the filename would be userid-def3270.ck3.
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Figure 12-91: Edit User Preferences

2. Select Preferences>Hot Spots from the Menu.

The Hot Spot Configuration screen displays.

Figure 12-92: Configure Hot Spots

3. To edit existing HotSpot:

a. Highlight the Emulator Key you wish to edit.

b. Enter new text into the Match Text field.
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c. Click Replace HotSpot.

4. To add a New HotSpot:

a. Type the text into the Match Text field 

b. Select an Emulator Key from the pull-down menu. 

c. Click Add HotSpot.

5. Repeat the preceding steps for each hot spot change you want 
to make.

6. Click OK.

The Settings Menu
This section contains information about the options available from 
the Preferences>Settings menu on the Emulation Client menu bar.

The Settings window appears when Preferences>Settings is 
selected. 

Note: The Associate with session: option allows you to associate 
the hot spot values with your user ID and the session file 
name. When selected, the settings will apply to all sessions 
that you start with the same WebConnect session file. For 
example, using userid and 3270, your local filename will be 
userid.hs3. If saved for the specific session (as in def3270 for 
this example), the filename would be userid-def3270.hs3.
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Figure 12-93: Settings

Tabl e 12 -1: S et ti ng s Opti on s  (S hee t 1 of  4)

M en u Item De fi ni ti on

Audio

S ilence A larm Disable Audio Alarm

Please Se lec t  a Sound Event  for  
Emula t ion Beep

Use the default WebConnect Beep or choose an 
alternative from the list. Note: Sounds must be 
configured in OS prior to use by WebConnect. 

Copy/Cut

Stream Copy/Cut all fields between the beginning of the 
selection and the end of the selection. 

Block Default mode. Copy/Cut the columns inside the 
selection rectangle.

Suppress  Trai l ing Ca rriage Return on 
Copy Removes last CR from copied text.
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Paste

Stream
Characters from the paste buffer are processed as if 
typed by the user and advance from field to field 
based on the screen’s layout. 

Block

Attempts to paste the buffer onto the screen in a 
one-to-one model. Each line of the data maps to 
one row of the screen. Each character in that line is 
placed in the corresponding location on the screen 
if the location is unprotected.

Hybrid

Block paste with word wrapping. Paste starts at the 
current cursor location; all continuing fields will 
start at the same column location. If starting cursor 
location is a protected field the paste is terminated. 
Word and rest of the line are wrapped to next 
field(s) if it can not fit in current field. 

Paste  By F ie ld s (St ream/Hybr id Only )

Disabled by default. When enabled WebConnect 
detects TAB characters in the clipboard text. If 
disabled, TAB characters will be converted to ASCII 
SPACE characters. 

Cursor

Text Cur so r

B linking Cur sor Set Cursor to Blink

Cursor Type
Block (choice)

Underline (choice)

C urso r Behavior
Invert Text Color (choice)

Fixed Color (choice)

Cursor C olo r Pick a cursor color.

Rule  L ines

D isp lay Ru le  L ines Enable rule lines.

Hori zontal Display horizontal lines.

Ver ti cal Display vertical lines.

Short  L ines Use short lines.

Rule  L ine Color Pick a line color.

Tabl e 12 -1: S et ti ng s O pti on s  (S hee t 2 o f  4)

M enu Item Def in i ti on



The Settings Menu

Chapter 12—Swing Client User Preferences 167

Disp lay

Show Cli ckPad Display ClickPad if enabled.

Show HotSpots Display Hotspots if enabled.

Show ToolBar Display ToolBar if enabled.

Display  Font F amily Show current font family.

Enable  3270 Sc rol lBack Allow scrolling of 3270 screen history. Set number 
of 3270 screens to keep in history. 

Enable  5250 Sc rol lBack Allow scrolling of 5250 screen history. Set number 
of 5250 screens to keep in history.

Enable  VT  Sc ro llBack Allow scrolling of 3270 screen history. Set number 
of VT lines to keep in history. 

Browse Fonts Browse available fonts.

Look and  Feel

Toggle between Java and Platform. Java (default) 
emulation windows use SUN Java UI components. 
Platform emulation windows attempt to reflect 
system feel, Windows feel for Windows and Mac 
feel for Apple, etc. 

EHLLAPI Enable  EHLLAPI Check to enable EHLLAPI

Keyboard

TypeAhead See ”Cursor Options” on page 168.

Lock Backspace to F ie ld Prevent backspace out of current field.

Destruc t ive  Backspace Erase when backspacing.

Word Wrap  (3270 on ly)

Disabled by default. When typing in a text field, 
unprotected field, and cursor is at the last location 
on the field, the entire word is moved to the next 
field preventing word splits. A word is defined as 2 
or more contiguous characters separated by 
spaces. 

Mouse

Move cur so r with Ctr l+Left Button 
(3 270/5250 on ly)

See ”Move Cursor with Mouse (Light Pen)” on 
page 170.

Select  Word with  Left  Button 
Double- cl i ck  (3270/5250 only)

Double clicking a location on the display moves 
the cursor to that location and selects the entire 
contents of the field. On the first click of the double 
click, the cursor to mouse action will be performed 
if enabled. In any case, the cursor will be moved on 
the second click as part of the select field behavior.

Tabl e 12 -1: S et ti ng s Opti on s  (S hee t 3 of  4)

M en u Item De fi ni ti on
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Cursor Options
A cross-hair cursor makes it easier for you to view full lines of data 
(vertical or horizontal rule, or both) on any emulation screen. To 
select this function, complete the following steps.

1. To activate the cursor options, select 
Preferences>Settings>Cursor from the menu. This option is 
only available to you if your System Administrator has given you 
permission for this setting in your session profile.

Figure 12-94: Settings Cursor Menu

Pr inter

Show Pr inter D ialog Display printer dialog. Applicable only to WebPrint.

3287/3812 
AutoFi t  Pr inter  Font Automatically correct printer font to fit page.

Raw Mode Pr int ing Print without formatting.

Proxy
Hostname Set Hostname of proxy server.

Port Set Port of proxy server.

Window

Save Window State/Pos it ion Retain window state/position

In it ia l  
Window 
S tate  ( if  

not  saved)

Norma l Window appears as normal at start up.

Icon i f ied Window is iconified at start up.

Maximized Window appears maximized at start up.

Tabl e 12 -1: S et ti ng s O pti on s  (S hee t 4 o f  4)

M enu Item Def in i ti on



The Settings Menu

Chapter 12—Swing Client User Preferences 169

2. You will find many options with this feature as described below:

• Rule Lines: select rule lines off/on. 

• Horizontal Rule: select to view the horizontal rule.

• Vertical Rule: select to view the vertical rule.

• Short Rules: select to view the short rule or deselect to view 
the long rule across the entire screen.

Figure 12-95: Cross-hair Cursor

3. Select a color for the rule line using the drop-down menu.

Type-ahead
In a normal 3270 or 5250 sessions, the keyboard locks after you press 
Enter or another AID key, and it will remain locked until the next 
buffer of information is received from the host. Enabling this option 
allows the next string of host information to enter a buffer without 
waiting for the next host screen. When the next host screen returns, 
WebConnect sends the saved buffer of information to the host.

1. To enable Type-ahead, select the number of buffers to use from 
the Type-ahead submenu (Type-ahead is enabled by default).
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2. To disable Type-ahead, select Disable from the Type-ahead 
submenu.

Move Cursor with Mouse (Light Pen)
The Light Pen feature is designed to perform on-screen actions with 
or without using the keyboard. You can use it either of two ways.

1. Use Shift + Left Mouse Button (default).

Or you can activate the cursor to mouse operation from the 
Preferences>Settings>Mouse Menu.

2. Enable the Setting>Mouse>Move cursor with Left Button 
(3270/5250 only) feature and click the right mouse button for 
the global Light Pen functionality, as follows. 

• Click the right mouse button and position the cursor in a light 
pen field to invoke the light pen functionality.

• Click and drag the cursor within a field to invoke the default 
block/highlighted functionality.
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13 Swing Client WC 
Key Map, Macro, 
and VB Script 
Editor

The WebConnect Key Map/Macro Editor provides a way to create key 
commands and WebConnect Macro for 3270, 5250, or VT sessions.

Key Commands on page 174.

• Create a keyboard command by assigning a key or key 
sequence to a key combination.

• Allows users to access custom macros or key commands that 
were created by an administrator.

WebConnect Macros on page 180.

• Create a user, session, or server-level macro including basic 
program controls such as goto, input variables, prompts, wait 
statements, and other variables.

• Import, play, or edit pre-defined, third-party macros such as 
“Rumba *.rmc” macros.

VB Scripts on page 186.

• Create and edit user or session-level VB Scripts. 

• Import and edit pre-defined, third-party macros such as 
Attachmate EXTRA! *.ebm” macros.

• Ehllapi must be enabled for this feature to appear. See ”3270, 
5250, and VT Client Emulation Features” on page 44 and The 
WebConnect User Guide.

You can enable the Macro toolbar to make your macros easier to use, 
see ”Macro Toolbar” on page 47 for more details.
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User Key Map Configuration Window
To use the WebConnect Macro Editor complete the following steps:

1. Select a session (3270, 5250, or VT) from the SESSION panel, 
shown in Figure 13-96, by clicking on it.

Figure 13-96: SESSION panel

2. The session opens in a separate window as shown in 
Figure 13-97.
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Figure 13-97: Key Map Menu

3. Select Edit>Preferences>Key Maps.

The User Key Map Configuration window displays showing a Key 
Commands tab by default, as well as a WebConnect Macro tab.

Figure 13-98: Key Map/Macro Configuration

4. Select the tab for the one you intend to create or edit for this 
session. See ”Key Commands” on page 174, or "WebConnect 
Macros," page 180, or ”VB Scripts” on page 186.

Associate with session: is grayed out and does not apply to VB 
Scripts. 
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Key Commands

Creating a New Key Command
1. Select the Keys tab (default tab).

2. Click Add Key Sequence.

A dialog box appears as shown in Figure 13-99, on page 174. 

Figure 13-99: Create Key Sequence

3. On the keyboard, enter the key or key sequence command you 
want to map. The selected keys automatically display in the 
shaded Key Sequence box.

4. When you have completed the key commands, click OK.

The Key Sequence editor appears as shown in Figure 13-100, on 
page 175.

The title bar of the panel displays the key sequence you entered.

Editing a Key Command
To edit a Key Command complete the following steps:

1. Select Edit Key Sequence. The panel shown in Figure 13-100 
displays where commands can be mapped to the key(s) you 
entered.
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Figure 13-100: Add Key Map Commands

2. Select a command from the buttons menu that you want to add 
to the key command.

3. Click Add after each change.

Note: You can add multiple commands to a key command. Table 13-2 on 
page 175 contains the command menu definitions.

Tabl e 13 -2: M acro  Edi tor  Comman d Descri pti ons  

Comman d Des cript ion

Execu te

Use to execute a program external to the applet. You can specify any command line 
parameter needed by the program within the function configuration.

Variable

A variable String (add a name and value). 
A variable Screen places screen data at row/column, and places it in the variable 
“name.” You can specify 1) the length of screen data, 2) end of word, or 3) end of 
field.
A variable Prompt to create a specified 1) title, 2) message, 3) input length.

Paus e
Use to pause the system for either a time interval or for a user response. User 
response mode allows setting a text message but does not capture any input 
data.

Pa ste Use to copy and then paste the contents of the configured file into the current 
cursor position within the emulation.

Funct ion
Add a selected function to this command from a pull-down menu. A definition for 
each function displays in the shaded box. You can find all standard AID Keys, 
such as Enter, Clear, PF1 through PF2 4, PA1, etc., under Function.

Type Define characters and/or strings which are input as keystrokes. Also used to type 
the value of a selected variable or the current user ID and password values.
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4. Click OK when you are finished.

To play a key command use the mapped key or key sequence. 

Wait

Wait provides several formats that allow executing WebConnect 
Macros to wait on synchronized states or specific text messages. The 
following section discusses those formats.

Cursor

Allows you to pause macro execution until the emulation cursor is at 
the defined row/column location. The default time-out value of zero 
(0) waits for an unlimited time. 

By default, the wait starts immediately upon executing the line in the 
script. If the After next AID key box is checked the operation does 
not take effect until after the next AID key has been processed by the 
emulation.

Play Execute a previously defined macro from a drop-down list.

Move Moves the cursor to the configured row/column.

Wait Use to enter a wait statement, see "Wait," page 176, Table 13-3 on page 177.

Prompt Prompt the user for input which can be assigned to a variable or sent directly to 
the screen at the current cursor location.

Label Provides a marker to which the Goto statement can direct macro execution.

Goto Add a “Goto” control statement to change the currently executing line of the 
script to “Label.”

Compare
Provides the ability to compare existing variables to each other, or to compare 
constant values and then select a "Goto" branch based on an "equals" comparison 
or a "not equal" value.

Up/Down Use to organize the statements into desired command sequence.

Add Adds the command selected after the current line in the macro.

Replace Highlight a statement and replace one statement with another.

Delete Highlight a statement and delete it from the macro.

OK Save and exit the command configuration.

Cancel Cancel changes to the command configuration.

Tabl e 13 -2: M acro Edi tor  Comman d D escri pti ons   (Con ti nu ed)

Comman d Descri pt ion
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Wait Text

The Wait Text statement operates in one of two ways determined by 
the After next AID key check box. Having the After next AID key 
checked (enabled) provides backward compatibility with older wait 
text macros or named maps. 

In either case the only required parameter is text in the Wait For Text 
dialog box. See "After next AID key Disabled (Default)," page 177 and 
"Editing macros built prior to WebConnect 6.3," page 178 for details 
about the two modes of operation.

Figure 13-101: Wait Tab

After next AID key Disabled (Default)
Executes the macro until the time-out value (optional) has 
elapsed or text is matched on current host screen.

Tabl e 13 -3: Wa it  Opt i ons —Af t er  n ex t AID key Di sabl ed ( Sh eet 1 of  2)

Op ti on Avail abi l it y De script io n

Wait  For  Text : Required Alphanumeric string

Ignore Case:  Unavailable

At  Row/Column: Optional Enable row and column designation in Row and 
Column below

Unt i l  End Of  Sc reen:  Unavailable
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Editing macros built prior to WebConnect 6.3 

After next AID key Enabled
Executes the macro when text matches that in the Wait For 
Text dialog box on any of the emulation screens as they occur 
until the time-out value has elapse if set.

Allows the macro to continue processing subsequent macro 
statements. AID (Attention Identifier) Keys from the macro 
may navigate to new host screens.

If you do not set either label, the macro execution resumes on 
the next macro statement after matching text or a time-out 
has expired.

Table 13-4 describes the options available with After next AID 
key enabled.

Row:  Available if At 
Row/Column is checked.

Available if At Row/Column is checked. Specify 
exact row where text string is to begin.

Column: Available if At 
Row/Column is checked.

Available if At Row/Column is checked. Specify 
exact column where text string is to begin.

Second(s)  Unt il  T imeout  Optional Time in seconds until the wait is stopped

T imeout  Macro : Optional
The timeout condition can be used to trigger a 
Timeout Macro. Invoking the Timeout macro 
effectively ends the current macro.

After next  AID  Key:  UNCHECKED Disabled (default)

Proceed G oto:  Unavailable

T imeout  Goto : Unavailable

Tabl e 13 -3: Wa it  Opt io ns— Af te r  n ex t AID key Dis abl ed ( Sh eet 2 of  2)

Opt io n Avail abi li t y Des cript io n

Tabl e 13 -4: Wa it  Opt io ns— Af te r  n ex t AID key En able d (S he et 1 of  2)

O pti ons Avai la bil it y Des cript io ns

Wait  Fo r Text: Required Alphanumeric string

Ignore C ase: Optional Ignore case in Wait For Text

At  Row/Column: Optional Enable row and column designation in Row and Column 
below.

Unt i l  End Of  Sc reen:  Conditional Available if At Row/Column is enabled

Row:  Conditional Available if At Row/Column is checked. Specify exact row 
where text string is to begin.
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Keyboard Unlock

The macro execution pauses until the keyboard unlock 
command is received. You can configure the wait to only 
apply after the emulation parses the next AID key. This 
command is mainly used for synchronization purposes.

Clear Screen

The macro execution pauses until the clear screen command 
is received. You can configure the wait to only apply after the 
emulation parses the next AID key. This command is mainly 
used for synchronization purposes.

Co lumn: Conditional Available if At Row/Column is checked. Specify exact 
column where text string is to begin.

Second(s)  Unt i l  T imeout  Optional Time in seconds until the wait is stopped

T imeout  Macro: Unavailable

After next  AID Key : CHECKED Enabled

Proceed Goto:  Optional If the wait text cannot be found, Goto statement label.

T imeout G oto:  Optional  If the macro times-out before the text is found, Goto 
statement label.

Tabl e 13 -4: Wa it  Opt i ons —Af t er  n ex t AID key En able d (S he et 2 of  2)

O pti ons Avai l abil i ty De script io ns
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WebConnect Macros

Figure 13-102: 3270 Session

Suppose, for example, you want to login to CICS from a current 3270 
session. This would require the following steps.

1. Type CICS and press Enter.

2. Enter your User ID and Password.

3. Press Enter.

Instead, you can create a WebConnect Macro to represent the 
command sequence. By automating the required logon procedures, 
you save time by entering a key command or macro to complete the 
steps.

Create a WebConnect Macro
1. Select (click) a session (3270, 5250, or VT) from the SESSION 

panel. See Figure 13-96, on page 172.
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Figure 13-103: WebConnect Macro Menu

2. From the emulation session, select Preferences>Keyboard 
Maps. 

The Key Macro panel appears. 

The Key Map Configuration window displays a Key Commands 
tab (default) and a WebConnect Macro tab. Select the one you 
intend to create for this session, see "Key Commands," page 174, 
or "Create a New WebConnect Macro," page 182.

Click the WebConnect Macro tab. 
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Figure 13-104: WebConnect Macros Tab

Create a New WebConnect Macro
1. Click New Macro from the WebConnect Macro tab from any 

session type.

The New Macro Name dialog box appears.

Figure 13-105: Name New Macro

2. Enter a new macro Name and click OK.

The Macro Definition panel appears with the macro name.
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Figure 13-106: Define Macro Action

3. Select tabs and commands to add to the WebConnect Macro.

4. Click Add after each change to the macro configuration.

5. Click OK when you are finished.

6. To play the macro, select Play Macro from the File>Macro 
Rec/Play>Play Macro emulation session Menu.

Import WebConnect Macro
You can import a macro from any of the type session selected (3270, 
5250, or VT).

1. Select the WebConnect Macros tab from any session macro 
editor.

Note: You can add multiple commands to a key command or WebConnect 
Macro. For command menu definitions see Table 13-2 on page 175.
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Figure 13-107: Import Macro

2. Select Import Macro from the WebConnect Macro tab.

3. Click Import Macro.

The File Browser window appears.

Figure 13-108: Import Macro

4. Select a macro file and click Open on the browser dialog.
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Figure 13-109: Imported Macro

The imported macro name displays in the “Key Map Configuration.”

5. You can use or edit the macro as you normally would. See 
Table 13-2 on page 175, and "Create a New WebConnect Macro," 
page 182“ for macro editor definitions.

6. Click Apply after each change you make.

7. Click OK when you are finished.

8. To play the macro, select Play Macro from the File>Macro 
Rec/Play>Play Macro emulation session Menu.

Note: Unsupported macro commands are converted to Pause commands 
with the message field indicating the unsupported command. The 
following Rumba macro commands are currently unsupported:

• Connect

• Disconnect run Application File Transfer receive

• File Transfer Send

• Compare values-except Goto (Label), which is supported

• Copy From

• Paste To
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VB Scripts
All VB Scripts must be saved to the desktops where they are required 
to run, otherwise the scripts do not run. Alternatively, the 
administrator may create a shared drive common to all desktops and 
configure session parameters to run the VB Script from the central 
location.

1. Click New Macro from the WebConnect Macro tab from any 
session type. See Figure 13-110, on page 186.

Click New.

2. The Key Map Configuration window displays. Select the VB 
Scripts tab.

Figure 13-110: VB Scripts Tab

Creating a New VB Script
To create a new VB Script complete the following steps:

1. Click New VB Script. The script name dialog box appears as 
shown in Figure 13-111.

Note: If the VB Scripts Tab does not appear in the dialog box, you may not have 
EHLLAPI enabled from the applet. From a client emulation applet ensure 
that Setting>EHLLAPI is set. Exit and restart the Key Map configuration 
dialog. See also ”3270, 5250, and VT Client Emulation Features” on 
page 44.
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Figure 13-111: New VB Script Name

2. Enter a new VB Script Name and click OK. The new VB Script 
name now appears in the script list as shown in Figure 13-112, 
on page 187.

To edit the VB Script see ”Editing a VB Script” on page 188.

Figure 13-112: New VB Script

Import VB Script
You can import an Extra VB Script into the WebConnect VB Script 
Editor from any 3270 or 5250 session types you select.

1. Select the VB Script tab from any session macro editor. See 
Figure 13-110.

Note: All VB Scripts must be manually copied to a shared drive common to the 
target desktops, otherwise the scripts do not run.
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2. Click Import VB Script.

3. A File Browser window opens the Select VB Script to Import 
dialog box where you can select an existing VB Script file.

4. Select an Extra BASIC macro file (*.EBM) and click Open.

The selected macro file is converted to the WebConnect VB 
Script file format and the file name appears in the script list as 
shown in Figure 13-112.

5. You can use or edit the script as you normally would. 

Editing a VB Script
To edit a VB Script complete the following steps:

1. Click Edit VB Script.

2. The WebConnect Script Editor appears in a separate window as 
shown in Figure 13-113 below. See the WebConnect Script Editor 
User Guide and the WebConnect Script Language Reference Guide 
for more information about editing VB Scripts. 

Figure 13-113: WebConnect Script Editor

Remove a VB Script
To remove a VB Script complete the following steps:

1. Select the script you want to remove from the list in the Key Map 
Configuration window. See Figure 13-112, on page 187.

2. Click Remove VB Script. 

The Delete VB Script Confirmation dialog box appears.

3. Click Yes.

4. Click OK or Apply.
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User Macro Autostart
The User Macro Autostart feature enables users to assign User 
Defined Startup Macros to specific session numbers and save them in 
their user preference settings. This feature requires no administrator 
intervention, providing users direct control over their startup macro 
configuration.

When using the User Macro Autostart feature keep in mind the 
following:

• Each session type maintains its own session number list except 
when Cached Applets or the Controller Applet is used. In those 
cases, every session, type (3270, 5250, VT) use the same session 
number list. For more information about the Controller see 
”Controller Applet” on page 42.

• Session level startup macros take precedence over user autostart 
macros and start first. 

• Macro operation is exactly the same as if it were invoked through 
File-Macro Rec/Play-Play Macro menu option.

There are three modes of operation:

1. Default Macro set only—Each time the particular session icon is clicked 
the default macro is run. No session number association is required.

2. Default Macro set to None with macros assigned in the Startup 
Macro List—The first time the session icon is clicked the macro assigned 
to Session Number 1 runs. The second time the session icon is clicked, 
the macro assigned to Session Number 2 runs and so on. 

3. Default Macro set and macros assigned in the Startup Macro 
List—The first time the session icon is clicked the macro assigned to 
Session Number 1 runs. The second time the session icon is clicked, the 
macro assigned to Session Number 2 runs and so forth. Subsequent 
unassigned sessions run the default macro.
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Assigning Autostart Macros
To setup Macro Autostart complete the following steps:

1. Click Preference>Startup Macro. See Figure 13-115, on 
page 191. 

Figure 13-114: User Autostart Macros

The Macro Operations panel appears as shown in 
Figure 13-115, on page 191.

Note: When a session is terminated, the Session Number assigned to it on the 
Startup Macro List is left open. The next time that session type’s icon 
is clicked, the first open Session Number is assigned to the new session 
and the corresponding macro assigned to that Session Number is 
started.

For example: A user assigns startup macros to four Session Numbers and 
starts those sessions. Later, the session assigned to Session Number 3 is 
lost for whatever reason. When the user clicks that session icon again, 
the resulting session is assigned to the open Session Number 3. If the 
user clicks the session icon once more, making a total of five sessions, 
the fifth session starts according to the Default Macro setting since a 
fifth session had not been assigned to a macro on the Startup Macro List. 
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Figure 13-115: User Macro Autostart

Default Macro

2. Select a macro from the Select Default Macro list as the default 
startup macro for the current session type or leave it set to the 
default, None. 

Startup Macro List

3. Enter the subsequent session number (1-99), if any, you want to 
assign a startup macro to in the Assign To Session Number 
field.

4. Select a macro from the pull-down Select Macro For Startup 
List and click Add.

The selected macro appears in the Startup Macro List.

5. Repeat Steps 3 and 4 for additional sessions making sure to 
enter unique session numbers in the Assign To Session 
Number field for each macro. 

6. Click OK.

Note: Only keystroke macros for the current Session type are available along 
with Complex Macros. BASIC macros as are available for 3270 and 5250 
sessions. 
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Unassigning Startup Macros
To unassign and disassociate a macro from a session complete the 
following steps:

1. Click Edit>Preference>Startup macro. 

The Macro Operations panel appears as shown in 
Figure 13-115, on page 191.

2. Select None from the Select Default Macro list. Click OK.

3. Select the macro in the Startup Macro List that you wish to 
unassign, if any and click Delete.

4. Click OK.
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14 HTML Client 
Emulation

This chapter contains information about the following subjects:

• ”Session Panel” on page 193.

• ”3270 HTML Client” on page 194.

• ”5250 HTML Client” on page 195.

• ”3287 HTML Client” on page 196.

• ”Input Field Validation” on page 196.

• ”3270 Input” on page 197.

• ”5250 Input” on page 197.

• ”HTML Color Scheme” on page 197.

• ”HTML ClickPad Functions” on page 198.

• ”HTML Keyboard Mapping” on page 199.

• ”3287 Print to HTML Client” on page 200.

• ”3812 Print Session” on page 202.

Session Panel
From the SESSION panel you can access all pre-configured sessions, 
user-configurable preferences, settings, and other components 
described below, only if they are implemented by your System 
Administrator.
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Figure 14-116: SESSION panel

Select a 3270, 5250, or 3287 HTML Client. The session displays a 
HTML client window as in Figure 14-117, Figure 14-118, and 
Figure 14-119.

3270 HTML Client

Figure 14-117: 3270 HTML Client
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HTML client windows have a fixed, always-present, clickpad at the 
bottom of the window. The expanded keypad, rows two, and three, 
are displayed in these examples.

To expand and use rows two and three, click PAD in the first row. See 
Table 14-6 on page 198 and Table 14-7 on page 199 for 
corresponding Key function.

5250 HTML Client

Figure 14-118: 5250 HTML Client

Note: Depending on your default browser, HTML windows may 
appear slightly different from these examples.

Note: The browser POSTs the current HTML page back to the 
WebConnect server when you use the clickpad. Be sure to 
complete all data entry before using the clickpad to avoid 
posting incomplete information to the server. See Table 14-6 
on page 198 and Table 14-7 on page 199 for key functions.
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3287 HTML Client

Figure 14-119: 3287 HTML Print

For information about 3287 HTML Print, see ”3287 Print to HTML 
Client” on page 200.

Input Field Validation
WebConnect HTML validates field input data and generates an error 
message indicator in the Operator Input Area (OIA) if you type 
incorrect characters.

In this event, the current text field is highlighted in red to show 
which character is incorrect, and an error message indicator displays 
in the lower left hand section of the window, see the following 
Table 14-5.

Example: If you are typing the number 74006 and accidentally 
type alpha zeros instead of numeric and press Enter, the error 
message Num Only appears and 74oo6 displays in the input 
field to indicate the wrong keys were typed. The cursor 
automatically returns to the incorrect field, highlighted in red, 
and you are not able to continue until the error is resolved. 
Incorrect data type entry is not accepted or posted.
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3270 Input
3270 requires alphanumeric keystrokes, all numbers and alpha 
characters, both upper or lower case, are accepted.

5250 Input
5250 requires alpha only or numeric only field entries. Signed numeric 
and Mono case fields are also supported.

HTML Color Scheme
WebConnect offers a color scheme setting for browser and 
emulation window changes. This feature addresses the 
incompatibility with some operating system browsers that do not 
display HTML sessions clearly because of the background or text 
color. For example, a session window may be difficult to read if a 
browser window is black with green text and a HTML emulation 
session window is black with green text. The administrator can 
change it to enhance the color scheme, making highlighted fields 
and text input easier to read.

Tabl e 14 -5: OIA  In put  Fie ld Val idat ion  Symbol s

Symbol Descri pti on

N um On ly= Numeric only field. Please reenter data.

- N um Onl y= Signed Numeric only field. Please reenter data.

No  R oo m= Signed Numeric only field, no room for minus sign. 
Please reenter data.

A lph a Onl y= Alpha only field. Please reenter data.
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HTML ClickPad Functions

Tabl e 14 -6: H TML  Cl ien t Cl i ckPad Fun ct ion s

B ut ton Fun c ti ons

Lo
ca

l*

REFRESH

Refreshes the current HTML page. When using HTML 
and browser to represent a HOST screen, WebConnect 
has only one chance to respond to the most recent 
POST command. However, due to the nature of 3270 
and 5250 emulation an entire screen update may arrive 
in multiple write commands, and the Pro server may 
not be able to send all the data at one time. This button 
is used to basically re-paint the most recent screen and 
pick up any additional screen changes made since the 
last POST command.

INFO Displays clickpad help.

AT

Auto Tab local feature. If Auto Tab is ON while typing in 
a data field, the cursor automatically moves to the next 
logical field. If Auto Tab is OFF, Auto Tab or Auto Skip is 
disabled and you must manually move (Tab) to next 
field.

QUIT

Quit terminates the current 3270/5250-session and 
send a message “Host Connection Terminated.”
The actual window stays on the screen so that a user 
can view the WebConnect message.

PAD
The click-pad toggle button used to display or hide the 
2nd and 3rd row of buttons.
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HTML Keyboard Mapping

Em
ul

at
io

n*

ENTER Submit this form

CLEAR Clear

ATTN Attention

RESET Reset

SR System Request

Help Help key (5250 only)

UP Page up (5250 only)

DOWN Page down (5250 only)

PRT Host print (5250 only)

F1-F24 PF1-PF24

PA1-PA3 PA1-PA3 (3270 only)

*Using Local functions do not affect the server.
*Emulation functions are used to send information to the host.

Tabl e 14 -6: H TML  Cl ien t Cli ckPad Fun ct io ns (Co nti nu ed)

B ut ton Fun c ti ons

Tabl e 14 -7: H TML  32 70 & 525 0 Keyb oard M appi ng  

Keymap Def aul ts

F1 = PF1 SHIFT + F1 = PF13 CTRL + F1 = PA1 (3270 only)

F2 = PF2 SHIFT + F2 = PF14 CTRL + F2 = PA2 (3270 only)

F3 = PF3 SHIFT + F3 = PF15 CTRL + F3 = PA3 (3270 only)

F4 = PF4 SHIFT + F4 = PF16 CTRL + F4 = CLEAR

F5 = PF5 SHIFT + F5 = PF17 CTRL + F5 = RESET

F6 = PF6 SHIFT + F6 = PF18 CTRL + F6 =ATTN

F7 = PF7 SHIFT + F7 = PF19 CTRL + F7 = SYSTEM REQUEST

F8 = PF8 SHIFT + F8 = PF20 Page Up   = Page Up (5250 only)

F9 = PF9 SHIFT + F9 = PF21 Page Down = Page Down 
(5250 only)

F10 = PF10 SHIFT + F10 = PF22 ENTER = SUBMIT
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3287 Print to HTML Client
Unlike the applet implementation which sends print jobs directly to 
the printer, HTML print sessions are stored in a temporary server 
“spool” directory. You can then view the print sessions through a 
browser window and print them with the browser’s print capability. 
The HTML 3287 print feature is available as a standalone printer or 
associated printer.

HTML 3270/3287 Associated Printer Session

1. From the SESSION panel, select a 3270 HTML Client with the 
3287 associated print process enabled.

Figure 14-120: 3287 Associated Print

2. The About 3287 Print button indicates that the printer session 
has started successfully. For a list of helpful client server 

F11 = PF11 SHIFT + F11 = PF23 CTRL+L = Lock Backspace

F12 = PF12 SHIFT + F12 = PF24

Note: For additional HTML client and Cascading Style Sheet 
information, contact your system administrator.

Tabl e 14 -7: H TML  32 70 & 525 0 K eyb oard M appi ng   (Con ti nu ed)

Keymap Defa ul ts
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information, click About 3287 Print to access the following 
window.

Figure 14-121: About Server 3287 Print

3. Click Close to return to the client session window.

4. After you have submitted jobs to the associated printer and the 
emulation panel has been refreshed, a second 3287 Print Jobs 
button will display to indicate that print jobs are complete.

Figure 14-122: 3287 Associated Print Jobs

5. Click 3287 Print Jobs to view a print jobs list.
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Figure 14-123: 3287 Print Jobs

A list of completed print jobs for each session will display in the 
browser window. The print job names will be the same, except for 
different print job number extensions.

6. Select (click) a print job name and the file content will display in 
the browser window.

7. You can use the browser printer capabilities to print the file.

Print jobs associated with the current session will be deleted when the 
session is terminated.

3812 Print Session
You can use a 3812 print session to print an AS/400 based print job 
on the local or network printer. From the browser, select one of the 
3812 print sessions that has been configured.

To start a 3812 print session:

1. Select the desired 3812 Print Session from the SESSION panel.

The 3812 print session window will display.

2. If the connection fails, attempt to resolve the problem indicated 
by the error message. If the problem persists, try a different 3812 
print session.

3. Send an AS/400 print job to the print device connected to the 
3812 print session. You will find the print device name (and other 
important information about the session) on the About Server 
dialog located in the 3812 print session Help menu.
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15 HTML5
Componentless 
Sessions

This chapter contains information about the following subjects:

• ”Session Panel” on page 204.

• ”3270, 5250, and VT Client Emulation Features” on page 204.

• ”Menu Bar” on page 206.

• ”Emulation Space” on page 207.

• ”ClickPad” on page 207.

• ”Copy and Paste Features” on page 208.

• ”Right-Click Menu” on page 212.

• ”Recording and Playing Macros” on page 214.

• ”3287 Client Emulation Features” on page 212.

• ”Menu Bar” on page 213.

• ”Session Window” on page 213

• ”Recording and Playing Macros” on page 214.

• ”Recording a Macro” on page 214.

• ”Saving a Macro File” on page 215.

• ”Playing a Macro” on page 216.

• ”Stopping a Macro During Play” on page 216.

• ”Deleting a Macro” on page 216.

• ”Tablet Device Support” on page 218.

• ”Apple OS and Safari 7+” on page 220.

• ”Android and Chrome 40+” on page 220.

• ”On-screen Keyboard Support” on page 221.
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Session Panel
The SESSION panel, shown in Figure 15-124, is the initial user 
window displayed by WebConnect and provides access to 
pre-configured sessions, user-configurable preferences, settings, and 
other components that have been implemented by your System 
Administrator. 

Figure 15-124: SESSION Panel

3270, 5250, and VT Client Emulation Features
The 3270, 5250, and VT HTML5/Componentless client emulations 
have similar user interfaces and share many interface features. The 
client window has a Menu Bar, an Emulation Space, and an optional 
ClickPad as shown in Figure 15-125.
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Figure 15-125: HTML5/Client Window 

Emulation Space 

ClickPad

Menu Bar
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Menu Bar
Your administrator can enable different menu options for your user 
ID; therefore, all of the following functions may not be visible (3270, 
5250 and VT) on your Menu Bar.

Tabl e 15 -8: S ess ion  M en u Opti on s  (S h eet 1 of  2)

Men u Ite m D efi ni ti on

F i le

Print Screen Prints the current screen.

Start Associated Print Starts a print session if one is associated with this 
session.

M acro

Play Macro Play a pre-recorded macro.

Record Macro Record actions for macro until 
’End Recording’ is clicked.

End Recording Stop recording and save 
previous actions into a macro.

Cancel Macro Stop recording and discard 
recorded actions.

Fil e  Tran sfer Transfers files between an HTML5 client and a SNA host.

S ave S ett in gs Saves the user’s settings.

Dis con n ect
Disconnects the emulation session. To close the 
window, click the X on the right hand corner of the 
window.

Edi t Paste Displays a dialog with a text field allowing text to be 
pushed into the emulation.

Preferen ce s

Keybo ard M aps Edit the Keyboard Maps for this session. 

Colo rs Specify Colors.

At tri bute s Edit the Attributes for this session.

Cl ick Pad Turns ClickPad (PF Keys) at the bottom of the screen on 
and off.

H otsp ots Edit Hot Spots. 

S et ti ng s
Edit Audio, Copy/Paste, Cursor, Display, EHLLAPI, 
Keyboard, Mouse, Printer, Proxy, and Window Settings. 
See ”The Settings Menu” on page 251 for details.
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Emulation Space
The Emulation Space, located below the Menu and Tool bars, 
displays detailed messages of the WebConnect server and the host 
connections. If encryption is used, messages regarding encryption 
key generation also displays in the emulation space. After a host 
connect is established, host data displays in the emulation space 
according to host data attributes, unless the Hot Spots option is 
active. See ”Configuring Hot Spots” on page 162.

ClickPad
The ClickPad displays below the Emulation Space if enabled by the 
administrator as shown in Figure 15-125, on page 205.

Click Preferences>ClickPad to access the ClickPad Configuration 
window.

H el p

Abo ut  Keys Displays a function key map.

Trace Keys Displays diagnostic information and keyboard macros 
previously executed.

Abou t 
S essi on

Cli ent
Displays Client, and Session details This information can 
be saved, printed, or copied to the clipboard from this 
dialog.

S essi on Displays encryption type and cipher used and the last 
WebConnect server connection.

Tabl e 15 -8: S ess ion  Men u Opt ion s  ( Sh eet 2 of  2)

Me nu Ite m Defi ni ti on
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Figure 15-126: ClickPad Configuration

Copy and Paste Features
The copy/paste feature can be set for either block (copy/paste 
selected columns) or stream (copy/paste rows) mode by setting the 
Block Paste option under the Setting menu. By default, this setting is 
block mode enabled. If disabled, the data is copied in stream mode.

Copy

To copy text to the clipboard, complete the following steps:

1. Mark the text by using one of the following copy methods:

• Highlighting text using a mouse: Click and hold the left 
mouse button at the beginning of the text you want to copy. 
Drag the cursor to highlight the entire text you want to copy.

• Highlighting text using the keyboard: Position the cursor at 
the beginning of text you want to mark and then use the key 
sequences in Table 15-9.

• Double left mouse to select entire field.

2. Select Copy from the Edit menu. The text is copied to the 
clipboard.
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You can use certain keys to highlight text on the screen, as 
defined in the following table.

These sequence functions are described below.

• Shift + Left: This marking function uses the shift key and left 
arrow key combination. If no text is selected, the current 
cursor position is selected. Otherwise, the character position 
to the left of the last selected character position becomes the 
new last character selected in the block. If the last selected 
character position is the beginning of a row, the last character 
of the previous row becomes the new last character selected.

• Shift + Right: This marking function uses the shift key and 
right arrow key combination. If no text is selected, the current 
cursor position is selected. Otherwise, the character position 
to the right of the last selected character position becomes 
the new last character selected in the block. If the last 
selected character position is the end of a row, the first 
character of the next row becomes the new last character 
selected.

• Shift + Up: This marking function uses the shift key and up 
arrow key combination. If no text is selected, the current 
cursor position and all characters up to but not including the 
character above the current cursor position is selected. 
Otherwise, the character position above the last selected 

Tabl e 15 -9: Keyboa rd Mapp in g 

Key S equen ce M appi ng

Sh i f t  + Left Highlight the text to the left of the current select 
location.

Sh i f t  + R ight Highlight the text to the right of the current select 
location.

Sh i ft  +  Up Highlight the text above the current select location.

Sh i f t  + Down Highlight the text below the current select location.

Sh i f t +  Home Highlight the text to the beginning of the row of the 
current select location.

Sh i f t  + End Highlight the text to the end of the row of the current 
select location.

Sh i f t +  Page Up Highlight the text from the current cursor position to 
the first row on the screen.

Sh i f t  + Page Down Highlight the text from the current cursor position to 
the last row on the screen.
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character position becomes the new last character selected in 
the block. If the last selected character position is in the first 
row, the first character on the screen becomes the new last 
character selected. If Shift + Up is followed by a Shift + Down, 
the new last character selected is the position that was 
selected prior to the Shift + Up.

• Shift + Down: This marking function uses the shift key and 
down arrow key combination. If no text is selected, the 
current cursor position and all characters up to but not 
including the character below the current cursor position is 
selected. Otherwise, the character position below the last 
selected character position becomes the new last character 
selected in the block. If the last selected character position is 
in the last row, the last character on the screen becomes the 
new last character selected. If Shift + Down is followed by a 
Shift + Up, the new last character selected is the position that 
was selected prior to the Shift + Down.

• Shift + Home: This marking function uses the shift key and 
home key combination. If no text is selected, the current 
cursor position and all characters up to and including the first 
character in the row are selected. Otherwise, all characters 
from the last selected position to the first character in the row 
are selected unless it is already selected. If characters are 
already selected, then those characters are deselected.

• Shift + End: This marking function uses the shift key and end 
key combination. If no text is selected, the current cursor 
position and all characters up to and including the last 
character in the row are selected. Otherwise, all characters 
from the last selected position to the last character in the row 
are selected unless it is already selected. If characters are 
already selected, then those characters are deselected.

• Shift + Page Up: This marking function uses the shift key and 
page up key combination. When used, the current cursor 
position and all characters up to and including the first 
character on the screen are selected. Any characters that were 
previously selected but are not in this range are deselected.

• Shift + Page Down: This marking function uses the shift key 
and page down key combination. When used, the current 
cursor position and all characters up to and including the last 
character on the screen are selected. Any characters that were 
previously selected but are not in this range are deselected.
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Paste

To paste text from the clipboard to the screen, complete the 
following steps:

1. Position the cursor where you want to begin pasting text.

2. Select Paste from the Edit menu.

The Paste dialog opens.

Figure 15-127: Paste Dialog

3. Type Ctrl+V to initiate the paste action.

4. The contents of the clipboard is pasted and the dialog dismissed.

Note:  You can reposition the cursor by selecting the Cursor to Mouse 
option in the Setting menu. Then click the position where you want to 
move the cursor.
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HTML5 Direct Paste

When enabled using Preferences>Settings>Copy/Paste>Direct 
Paste Mode (Ctrl-V to paste) this feature bypasses any WebConnect 
key mapping for Ctrl-V and passes it directly to the browser allowing 
clipboard data to be pasted into the emulation session without the 
use of the intermediate dialog. The current paste configuration 
(stream vs. block, etc.) is used to process the clipboard data. 

The administrator can also control the default behavior in the 
session configuration. This behavior is only available for Ctrl-V. Use of 
the Edit>Paste menu item or the Paste item on the context menu 
still requires the intermediate dialog. When Direct Paste is not 
enabled, the paste operates normally, including any keystroke 
mapped to the paste behavior. 

Right-Click Menu
Many copy and paste tasks along with session switching can be 
accomplished using the right-click menu. Table 15-10 on page 212.
Tabl e 15 -10: R ig ht- Cl i ck  Men u

3287 Client Emulation Features
The 3287 session user interface is a window that shows the progress 
of 3287. A few user options can affect the printed output. These 
options, and other interface features, are explained below. 

I tem Def in it io n

Copy Copy the highlighted text to the clipboard.

Pa ste Insert text from the clipboard at the cursor position.

S el ect  All Select all text on page.
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Figure 15-128: 3287 Client Emulation

Menu Bar
The Menu Bar options are described in Table 15-11 below.

Session Window
Information displayed about the print job in the session window are:

• Session ID

• Printer LU

• Printer State

Tabl e 15 -11: 3 287 M enu  Fu nc ti on s 

Menu I tem Descri pti on

F i le
Save Sett ing Saves the current user’s settings.

Disconnect Disconnect session from server.

Preferences Sett ings See Table 12-17 on page 177

Help About  Sess ion Select to view more information about the client operating system, 
applet version, and Java version and WebConnect Server.
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• Total Print Jobs

• Total Pages Printed

• Total Pages Printed For Current/Last Job.

Recording and Playing Macros
You can record frequently used keystrokes and save them as macros 
to be activated and played back. Defined macros are saved to the 
server. Select one of the following functions from the emulation 
session File> Macro> menu:

• Play Macro

• Record Macro

• End Recording

• Cancel Macro

Recording a Macro
To record a macro complete the following steps:

1. From the emulation session menu, select File>Macro>Record 
Macro.

The New Macro Name dialog box appears as shown in 
Figure 15-129 below.

Figure 15-129: Record Macro Name

Note: In some instances, your system administrator may have set your user 
preferences to restrict macro recording. If this is the case your menu 
displays only the “Play Macro” feature. The same is true for the play 
macro toolbar icon.
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2. In the Macro Name box, type a name for the new macro (for 
example, CICS Logon).

3. Click OK.

4. Type the key sequence (i.e., the commonly used keystrokes) to 
record the macro.

5. When you have finished recording, click File> Macro> End 
Recording.

6. Click OK. 

Saving a Macro File
Immediately after recording a macro you must save it.

1. Select File>Macro>End Recording Macro.

The Save New Macro dialog box appears. 

Figure 15-130: Save Recorded Macro

2. Click Yes.

The macro you recorded is saved.

The macro you recorded and saved is available to replay the next 
time you start a session.

Note: Do not use the mouse or clickpad while recording. Only keystrokes can 
be recorded, not mouse actions. See ”Recording and Playing Macros” on 
page 214 for instructions on using the keyboard to highlight text. For a 
list of the key mappings, select about keys from the emulation session 
Help menu.

Note: You MUST continue to the following instructions and SAVE the macro or 
your work will be lost.
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Playing a Macro
1. Select File> Macro> Play Macro. 

The Play Macro window opens containing a list of available 
macros as shown in Figure 15-131, page 216.

Figure 15-131: Recorded Macro List

2. Select the name of the macro that you want to play from the list.

3. Click OK. The macro keystrokes that you previously recorded 
automatically play back, activating the sequence.

Stopping a Macro During Play
This option stops a macro while it is running.

1. During a macro playback if a long time-out occurs and you need 
to stop it, select Macro and Cancel Macro.

Deleting a Macro
1. Select File>Preferences>Keyboard Map. The Key Macro 

window displays.
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Figure 15-132: Key Macro Window

2. Click the WebConnect Macros Tab.

3. Select the macro to be deleted from the list.

4. Click Delete Macro to delete the macro as shown in 
Figure 15-133 below.

Figure 15-133: Delete Macro

5. Click OK.



218 

Tablet Device Support  

WebConnect User Guide

Tablet Device Support
The HTML5/Componentless client supports on-screen touch 
keyboards on tablet devices running the Safari or Chrome browsers. 

Figure 15-134: The Keyboard Key

Pressing the Key button opens the touch keyboard. 

Keyboard Button
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Figure 15-135: The Keyboard
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There are limitations and behavioral characteristics to be aware of 
when using the HTML5/Componentless client and on-screen touch 
keyboards since the client is JavaScript code executing within a 
browser and is therefore limited to the capabilities of JavaScript and 
the support provided by the browser.

Apple OS and Safari 7+
Safari works with both the standard Apple on-screen touch keyboard 
and external Bluetooth keyboards. However, Safari intercepts 
specific keys, not passing them to the emulation, such as cursor up 
and down used for browser interactions such as scrolling on external 
keyboards. 

It is necessary to enable the keyboard by pressing the Key  
on-screen keyboard button even when using an external Bluetooth 
keyboard.

OpenConnect does not certify other browsers that are available for 
iOS even though they may work or support other third-party 
keyboards.

Android and Chrome 40+
Chrome works with both the standard Google on-screen touch 
keyboard, with conditions described below, and external Bluetooth 
keyboards. Note that more keys such as cursor keys work as 
expected within the emulation on external keyboards, unlike iOS 
Safari. 

It is necessary to enable the keyboard by pressing the Key  
on-screen keyboard button even when using an external Bluetooth 
keyboard.

OpenConnect does not validate other third-party keyboards, certify 
other browsers available for Android that may work or support other 
tablet or mobile platforms including Windows Mobile.

Note: When the iPad is locked, current versions of iOS disconnect the 
WebSocket connection from the WebConnect server. The 
HTML5/Componentless Client cannot control this iOS behavior. 
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On-screen Keyboard Support
When considering keyboards, consider that keyboard interaction at 
the JavaScript level consists of three types of events: key press, key 
release, and key typed. The key typed event represents a key that 
generates normal text such as A or 1. The key typed event is 
important to the client for the processing of those keys. When using 
an external Bluetooth keyboard as described above, all three types 
of events are generated just as when using a browser on a desktop 
system with a physical keyboard attached. However, when using an 
on-screen keyboard, the situation is more complicated. Android 
on-screen keyboards may not generate keypress events within 
Chrome. For Android, the HTML5/Componentless client has been 
updated to use input events rather than raw keystroke events which 
are often not available. A password type keyboard is used to avoid 
issues from auto-completion.

In addition to event processing, there can be idiosyncratic behaviors 
relating to on-screen keyboards. Dismissing the keyboard 
immediately after pressing the Key button may make it 
necessary to click on the emulation display to make the keyboard 
display via the Key button again. This behavior results from a lack of 
direct control of the keyboard through JavaScript. The table browser 
must be tricked into displaying the on-screen keyboard by setting 
focus to an off-screen input field. Once displayed, the focus must be 
shifted off that input field. Otherwise, the browser considers focus 
already on the input field and does not redisplay the keyboard when 
pressing the Key button again. Logic in the HTML5/Componentless 
client attempts to do this automatically. 
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16 HTML5
Componentless 
Client
Printing

Printing a Screen
You can print a single session window after you select a print screen 
option, see the following steps:
1. From the open session window, select File>Print Screen from the menu. The 

printer dialog window for the system displays.

1. Follow the system printing procedures.

3287 Print Session
Printing from any browser to a specific 3287 logical unit (LU) and 
gateway:

1. Select 3287 Print Session from the Start User Session panel. A 
3287 printer session window displays.

2. Be sure the correct gateway and LU displays in the printer 
session window.

3. Send a mainframe print job to the selected LU. The 3287 printer 
session window indicates that the session is printing.

Note: To check the LU and gateway you are printing to, select About 
Server from the Help menu on the printer session window 
displayed when you start a 3287 print session. A status 
window will open identifying printer information, such as the 
number of jobs to print.
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Associated Print
1. Select File>Start Associated Print. The Printer Icon appears in 

the upper right hand corner of the client window as seen in 
Figure 16-136, on page 224.

Figure 16-136: Associated Print Icon

There are three states to the Printer Icon:

• Green - There are no print jobs available.

• Blue - There are one or more print jobs available. 

• Blinking - Print job in progress
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2. Click the printer icon to open the Print job dialog.

Figure 16-137: Print Job Dialog

You can Flush Print Job, Disconnect, or Close. 

3. Start the print job. 

The print icon flashes indicating the print job is in progress. 
When the icon turns blue you can view the print job in the print 
job dialog. Click the Printer icon. The print job dialog appears, 
showing the completed print job.
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Figure 16-138: Completed Print Job

4. Click the Print Job link to view the result.
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17 HTML5
Componentless 
Client File 
Transfer

WebConnect uses the standard IND$FILE protocol to transfer files 
between HTML5/Componentless and an SNA host application. This 
capability can be used to address a variety of networking needs, 
including centralized data backups and data warehousing through 
an SNA host. 

Because SNA host files use different file formats from client files, be 
sure to use the appropriate options for converting files to the 
receiving host’s file format during transfer. Format conversion allows 
the receiving host applications to use the file without further 
modification. SNA hosts and SNA applications used for transferring 
files are listed below as well as the IBM program number and 
operating system for each application:

• WebConnect supports only the DFT (Distributed Function 
Terminal) file transfer mode.

You must be familiar with the file transfer application program you 
use.

Select an option below for file transfer instructions: 

Tab le 17 -12 : SN A  H ost /Appl icat ion  Tran sfer  

A ppli cati on  Prog ram Pro gram 
N u mber

Op erat in
g Syste m

3270 PC File Transfer for CICS 5798-DQH VS

3270 PC File Transfer for TSO 5665-311 MVS

3270 PC File Transfer for VM 5664-281 VM
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• "File Size Limitations," page 228

• "Sending and Receiving CICS/VS Files," page 229

• "Sending and Receiving TSO Files," page 232

• "Sending and Receiving VM Files," page 237

File Size Limitations
Due to browser memory limitations file transfers cannot exceed 100 
MB.

To Host

The Maximum file size limit for uploads is 100 MB. Attempts to 
upload larger files cause the following error dialog to be displayed.

Figure 17-139: File Transfer Error

Files in excess of 100 MB must be manually split at the host into 100 
MB portions and then manually reassembled after they have been 
transfered. One method of reassembly after transfer is the use of the 
Windows copy command. From the Windows Command Prompt 
type:
copy /b file1 + file2 + file3 unified_file

where file1, file2, file3 are the file portions and unified_file is the 
assembled file. 

From Host

The Maximum file size limit for downloads is 100 MB. Attempts to 
upload larger files cause the following message dialog to be 
displayed.
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Figure 17-140: File Transfer Message

Files in excess of 100 MB are automatically split into 100 MB portions 
before transfer and must be manually reassembled after they have 
been transfered. One method of reassembly after transfer is the use 
of the Windows copy command. From the Windows Command 
Prompt type:
copy /b file1 + file2 + file3 unified_file

where file1, file2, file3 are the file portions and unified_file is the 
assembled file. 

Sending and Receiving CICS/VS Files
WebConnect allows file transfer between a HTML5 client and the 
Customer Information Control System/Virtual Storage (CICS/VS) SNA 
application.

See the following steps to transfer files to and from CICS/VS.

1. Make sure that the WebConnect client is connected to the 
desired SNA host and CICS application. 

2. From the File menu, select File Transfer>To Host (or From 
Host). The appropriate file transfer window will display.

3. Select CICS tab. 
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Figure 17-141: CICS/VS File Transfer To Host Example

Figure 17-142: CICS/VS File Transfer From Host Example

4. Under Local File to search for a file. 
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• If sending To Host, click Browse and navigate to the Local 
File.

• If receiving From Host, enter the Local File pathname in the 
text box.

When you select a file the name displays in the text field of the Local 
File box.

File sizes cannot exceed 100 MB. See ”File Size Limitations” on 
page 228 for complete details.

UNIX Format
1. To transfer the file in UNIX format, click the UNIX Format button 

under Browse. UNIX format converts line separators to carriage 
return and line feed pairs during a Send operation. During a 
receive operation, carriage return and line feed pairs are 
converted to line separators.

Do not select the UNIX format when using the binary option or the 
binary data will be corrupted.

2. Type a host filename in the Data Set Name field in the CICS Tab 
box. 

3. Type comments about the file being transferred in the Comment 
field in the CICS Tab. The comments will be automatically 
included in the first record of the CICS/VS host file.

Transfer Options
1. Select a file type from the Transfer Options box to configure the 

way the file contents are treated during the transfer process. The 
choices are described below: 

• ASCII
This option instructs the SNA host to translate data between 
the EBCDIC and ASCII character formats. Use this option for 

Note: The procedures for searching for filename vary by system.

Note: The CICS filename can be a program name, a transaction identification, 
or identification selected by the CICS/VS application programmer. If the 
filename does not exist, the CICS/VS application will automatically 
create it. The filename can be one to eight characters long. The character 
in the first position must be alpha; other characters can be alpha or 
numeric.
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transferring ASCII formatted files, such as text edit files or 
print files. Do not use the ASCII option for transferring binary 
data (such as output data from a database program) or object 
code files (such as C compiler object code). 

• Binary
This option instructs the SNA host to perform no character 
translation. Use this option to transfer encrypted data, 
compiled programs, and other noncharacter information. 

2. Click Append if a local file is to be added to the end of an SNA 
host file. 

• If you do not select Append in the Receive dialog box, the 
SNA host file will replace the Java client file. 

3. If the CRLF option is desired, check CRLF. 

4. Click Send or Receive to begin the file transfer.

5. The Transfer Status displays to confirm the transfer was 
successfully completed. 

If receiving, a dialog displays to allow the file (complete or 
partial) to be saved from browser memory. See ”File Size 
Limitations” on page 228.

Sending and Receiving TSO Files
WebConnect allows you to transfer files between a HTML5 client and 
the Time Sharing Option (TSO) SNA application. 

See the following steps to transfer files to and from a TSO application 
from a User Session.

Note: If you do not specify the CRLF option in send mode, the SNA host 
disregards the local file’s line separators.

Do not use the CRLF option for transferring binary data (such as output 
data from a database program) or object code files (such as C compiler 
object code).

Disabling the CRLF option in the Transfer Options dialog box instructs 
the CICS/VS host to copy the file unaltered to the appropriate TCP/IP 
host. This option can be used to transfer encrypted data, compiled 
programs, and other data that is unreadable. 
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1. Make sure that the WebConnect client is connected to the 
desired SNA host and TSO application.

2. From the File menu, select File Transfer>To Host (or From 
Host). 

3. Click the TSO tab.

The appropriate file transfer window will display.

Figure 17-143: TSO File Transfer To Host Example
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Figure 17-144: TSO File Transfer From Host Example

4. Under Local File to search for a file. 

• If sending To Host, click Browse and navigate to the Local 
File.

• If receiving From Host, enter the Local File pathname in the 
text box.

File sizes cannot exceed 100 MB. See ”File Size Limitations” on 
page 228 for complete details.

5. When you select a file the name displays in the text field of the 
Local File box.When you select the peer file and click Open, the 
name will display in the text field in the Local File box.

6. To transfer the file in UNIX format, click the UNIX Format button. 
UNIX format converts line separators to carriage return and line 
feed pairs during a Send operation. During a receive operation, 
carriage return and line feed pairs are converted to line 
separators.

7. Type a host filename in the Data Set Name field. 

Note: The procedures for searching for filename vary by system.
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8. Type a member name in the Member Name field. 

The member name is optional. If entered, the member name 
should be a member in a partitioned data set directory.

9. WebConnect does not create the partitioned data set. 
When you use the Send window to copy a file to a 
partitioned data set and include a member name, the 
partitioned data set must exist.

10. The TSO application adds a user ID prefix to the combined data 
set and member name. To eliminate the user ID prefix, enclose 
the data set and member name in single (right) quotation marks, 
for example,’smith.pds2.file1.’

11. If a password is required, type it in the Password field. A 
password is only required if password-protection has been 
specified for the TSO data set.

12. Select a file type from the Transfer Options box to configure the 
way the file contents are treated during the transfer process. The 
choices are described below:

• ASCII—this option commands the SNA host to translate data 
between the EBCDIC and ASCII character formats. Use this 
option for transferring ASCII formatted files, such as text edit 
files or print files. Do not use the ASCII option for transferring 
binary data (such as output data from a database program) or 
object code files (such as C compiler object code). 

• Binary—this option instructs the SNA host to perform no 
character translation. Use this option to transfer encrypted 
data, compiled programs, and other noncharacter 
information. 

Append a File
1. Click Append if you plan to add a local file to the end of an SNA 

host file.The Append option will override other values specified 

Note: The TSO host data set name must conform to IBM naming conventions. 
You can enter an existing data set name (stored in your library) or a new 
data set name. A closing quote will not display in the Member 
Name field.

Note: If you select the UNIX Format option when using the Binary option, the 
binary data will be corrupted.
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by the LRECL parameter and RECFM options in the Advanced 
section. 

If you do not select Append in the Send dialog box, the TCP/IP 
host file will replace the SNA host file.

Record Format and Space Options

Figure 17-145: Record Format Options

1. In the Record Format box, click a radio button for the desired 
record format. This is only valid when sending a file. The valid 
values are described below: 

• Fixed—indicates the data set’s records are fixed length.

• Variable—indicates the data set’s records are variable length.

• Undefined—indicates the data set contains undefined record 
lengths.

• None—indicates no record format is to be used.

2. To set the allocated amount of space for a new data set, click 
Blocks, Tracks, or Cylinders on the Space tab. When you select 
Default, TSO uses the Blocks parameter default value which is 
determined by the specifications listed below: 

• Blocks—use the smallest storage entity.

• Tracks—use the middle-sized storage entity.
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• Cylinders—use the largest storage entity.

• Primary—the primary allocation for the Blocks parameter.

• Increment—the increment allocation for the Blocks 
parameter.

3. If sending a file, type a size value (such as the data block size of a 
TSO data set) in the BLKSIZE field in the Record Format area. The 
variable you type represents a data block’s byte count. The 
default value is 80.

4. Type a logical record length value of the SNA host file in the 
LRECL field in the Record Format area. The parameter value 
represents the number of characters for each record. If the 
parameter is not entered, the record length is determined by the 
file transfer operation. For new files, the parameter’s default 
value is 80. 

5. The characteristics of the existing file are used if you are 
replacing a file or appending information to a file. If you are 
transferring variable length records, the parameter represents 
the maximum record size. The parameter’s value becomes the 
longest record sent if you do not send a record of the maximum 
operating system size; only valid if you are sending a file.

6. Click Send to begin the file transfer.

7. Transfer Status will display at the bottom of the dialog to confirm 
the transfer was successfully completed. Click Exit.

8. The Transfer Status displays to confirm the transfer was 
successfully completed. 

If receiving, a dialog displays to allow the file (complete or 
partial) to be saved from browser memory. See ”File Size 
Limitations” on page 228.

Sending and Receiving VM Files
WebConnect allows file transfer between a HTML5 client and the 
Virtual Machine/Conversational Monitor System (VM) SNA 
application.

See the following steps to transfer files to and from a VM application.

1. Make sure that the WebConnect client is connected to the 
desired SNA host and VM application.

2. From the File menu, select File Transfer>To Host (or From 
Host). The appropriate file transfer window will display.
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3. Click VM tab.

4. Under Local File to search for a file. 

• If sending To Host, click Browse and navigate to the Local 
File.

• If receiving From Host, enter the Local File pathname in the 
text box.

File sizes cannot exceed 100 MB. See ”File Size Limitations” on 
page 228 for complete details.

5. When you select a file the name displays in the text field of the 
Local File box.Select the peer file. The name displays in the text 
field in the Local File box.

To transfer the file in UNIX format, click the UNIX format button. 
UNIX format converts line separators to carriage return and line 
feed pairs during a Send operation. During a receive operation, 
carriage return and line feed pairs are converted to line 
separators.

6. Type a host filename in the Data Set Name field in the VM tab. 
The VM filename can be one to eight characters long. 

7. Type the appropriate file type in the VM File Type field. This 
parameter identifies the VM disk file type.

8. Type an appropriate value in the VM File Mode text box. This 
parameter identifies the VM disk file mode. If you do not enter a 
file mode parameter, the VM application uses the A1 default 
value.

9. Select a file type from the Transfer Options box to configure the 
way the file contents are treated during the transfer process. The 
choices are described below:

• ASCII—this option instructs the SNA host to translate data 
between the EBCDIC and ASCII character formats. Use this 
option for transferring ASCII formatted files, such as text edit 
files or print files. Do not use the ASCII option for transferring 
binary data (such as output data from a database program) or 
object code files (such as C compiler object code). 

Note: The procedures for searching for filename vary by system.

Note: The VM application automatically creates the receiving host’s filename if 
a filename does not exist.
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• Binary—this option instructs the SNA host to perform no 
character translation. Use this option to transfer encrypted 
data, compiled programs, and other noncharacter 
information. 

10. Click Append if a local file is to be added to the end of an SNA 
host file.

• If you do not select Append in the Send dialog box, the 
TCP/IP host file replaces the SNA host file. 

• To use the CRLF option, check CRLF. 

• During a Receive operation, carriage return and line feed 
pairs are converted to line separators.

• Disabling the CRLF option in the Transfer Options dialog box 
instructs the CICS/VS host to copy the file unaltered to the 
appropriate TCP/IP host. This option can be used to transfer 
encrypted data, compiled programs, and other data that is 
unreadable. 

• If you do not activate the Append option in the Receive 
dialog box, the SNA host file replaces the Java client file. If you 
do not activate the Append option in the Send dialog box, 
the TCP/IP host file replaces the SNA host file.

11. To specify the record format, LRECL, click the Record Format 
tab. 

12. In the Record Format area, click a radio button for the desired 
record format. This is only valid when sending a file. The valid 
values are described below: 

• Fixed—indicates the data set’s records are fixed length.

Caution: Do not select the UNIX Format option when using the Binary option 
or the binary data will be corrupted.

Note: You can click the UNIX Format check box for ASCII file transfers. This 
allows line separators to be converted to carriage return and line feed 
pairs during a Send operation.

Caution: Do not use the ASCII or CRLF options for binary data such as output 
data from a data base program or object code files such as C compiler 
object code. 
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• Variable—indicates the data set’s records are variable length.

• Undefined—indicates the data set contains undefined record 
lengths.

• None—indicates no record format is to be used.

13. Type a logical record length value of the SNA host file in the 
LRECL field in the Record Format area. The parameter value 
represents the number of characters for each record. If the 
parameter is not entered, the record length is determined by the 
file transfer operation. For new files, the parameter’s default 
value is 80.

If you are replacing a file or appending information to a file, the 
characteristics of the existing file will be used. If you are transferring 
variable length records, the parameter represents the maximum 
record size. If you do not send a record of the maximum operating 
system size, the parameter value becomes the longest record sent. 
This is only valid if you are sending a file.

14. Click Send again to begin the file transfer.

15. Transfer Status will display at the bottom of the dialog to confirm 
the transfer was successfully completed. Click Exit.

If receiving, a dialog displays to allow the file (complete or 
partial) to be saved from browser memory. See ”File Size 
Limitations” on page 228.
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18 HTML5
Componentless 
Client
User Preferences

This chapter contains information about editing user emulation 
session preferences from the menu bar of the Emulator Screen. The 
following topics are covered:

• ”Preferences Menu” on page 241.

• ”Configuring Colors” on page 242.

• ”Configuring Attributes” on page 243.

• ”Configuring the ClickPad” on page 244.

• ”Configuring Hot Spots” on page 249.

• ”The Settings Menu” on page 251.

• ”Cursor Options” on page 254.

• ”Move Cursor with Mouse (Light Pen)” on page 255.

Preferences Menu
This section contains information about the options available from 
the Preferences menu on the Emulation Client menu bar that 
control.

Local Storage of HTML5 Settings
HTML5 settings can be configured to be stored on the server or 
locally on the desktop as long as a User ID is available from either the 
authentication process or the prompt. If the User ID is not available, 
only local storage of HTML5 settings is possible.
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Local storage is an internal storage of data within the browser and 
controlled per website. Unlike server storage, an HTML5 client from 
one WebConnect server cannot read the local storage from an 
HTML5 client at a different server. A User's configuration settings 
cannot be shared between different WebConnect instances unless 
they share a hostname. Also, local storage can be erased by the 
browser by clearing browser data at the appropriate level. For the 
Edge browser, that is Cookies and saved website data. 

Configuring Colors
1. To change or enhance the color configuration, select 

Preferences>Colors from the menu.

Figure 18-146: Edit Color Configuration

2. To edit a color, double-click the color you want to change. 

The color chooser dialog box appears.

3. Click on one of the basic colors or create a custom color and click 
OK.

Note: The Associate with session: box allows you to associate 
the color values with your user ID and the session file name. 
When selected, the settings will apply to all sessions that you 
start with the same WebConnect session file. For example, 
using userid and 3270, the user’s local filename will be 
userid.cm3. If saved for the specific session (as in def3270 for 
this example), the filename would be userid-def3270.cm3.
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4. Repeat as necessary and then click OK.

Configuring Attributes
Various screen behaviors associated with fields can be configured 
through the Attributes panel. Complete the following steps to edit 
your screen attributes and colors.

1. Select Preferences>Attributes.

Figure 18-147: Attribute Configuration

2. The attribute configuration window displays an example of 
attributes supported by the terminal type (3270/5250/VT).

3. Select an attribute from the list.

4. Select a Foreground and Background color from the drop-down 
lists. 

5. Select an Attribute such as Blinking, Reverse Video, Intense, or 
Underline if desired.

Note: To assign or change a specific attribute color, see Configuring 
Attributes below.

Note: The Associate with session: box allows you to associate the 
attribute values with your user ID and the session file name. 
When selected, the settings will apply to all sessions that you 
start with the same WebConnect session file. For example, 
using userid and 3270, the user's local filename will be 
userid.at3. If saved for the specific session (as in def3270 for this 
example), the filename would be userid-def3270.at3.
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6. Click OK when you complete the changes.

Configuring the ClickPad
Each emulation session type (3270, 5250 and VT) has an associated 
ClickPad for that session type. HTML5 clients have a feature listed 
under the Preferences Menu called ClickPad. Options under this 
feature allow users to customize the clickpad for their personal use. 
The user can add or delete keys, add macros, insert padding (blank 
buttons) to separate keys into groups and rearrange the ClickPad to 
the user's display preference.

When customizing, the user can apply the custom clickpad to all like 
session types, meaning all 3270 sessions or all 5250 sessions etc., or 
assign the custom clickpad to a particular session, solely for use with 
that particular session.

Figure 18-148: ClickPad Configuration

Note: To change the color configuration, see "Configuring Colors," 
page 242.
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Emulator Keys: Move Up, Move Down and Delete Buttons

Each emulator type (3270, 5250 or VT) will automatically 
accommodate the normal clickpad keys associated with the type of 
session. 

The Move Up and Move Down buttons provide the user with the 
ability to rearrange the layout of the ClickPad. To do this, simply 
place the cursor over the key that you want rearranged and use the 
Move Up and Move Down buttons to position the key to the 
desired location. 

The Delete button provides the ability to remove keys from the 
ClickPad.

Emulator Key Section
The Emulator Key drop down box contains a list of emulation keys 
for selection. 

As stated earlier, all relative session type standard keys are in this list 
as well as some additional keys that might be desired. After making a 
selection, press the Add Emulator Key button to add the selected key 
to the ClickPad.

Padding
The Add Padding button is used to place padding (blanks or 
spacers) between sets of keys. In the example below, an Add 
Padding button was placed after PF24 to separate the PF keys from 
the PA keys and an Add Padding button was placed before the first 
macro key to place macros in their own row. See Figure 18-149, on 
page 246.

Note: All associated standard session keys are also stored in the Emulator Key 
section, so if you accidentally delete a standard session key, you can 
always add it back.
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Figure 18-149: Click Pad Options
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Figure 18-150: Padding

Macro Section
If you have created macros and would like to add a button on the 
clickpad for a macro, select the desired macro from the Macro drop 
down box, optionally, assign it a key label in the Macro Label box and 
click Add Macro. Use the Move Up and Move Down buttons for key 
placement on the ClickPad. See Figure 18-149, on page 246 for the 
Clickpad options panel.
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Figure 18-151: Macros
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Configuring Hot Spots 
Hot Spots configuration allows you to select and display the 
definition of text strings as clickable buttons when the strings 
appear on the screen.

Complete the following steps to set or modify hot spots.

1. Start your client session.

Figure 18-152: Edit User Preferences

2. Select Preferences>Hot Spots from the Menu.

The Hot Spot Configuration screen displays.
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Figure 18-153: Configure Hot Spots

3. To edit existing HotSpot:

a. Highlight the Emulator Key you wish to edit.

b. Enter new text into the Match Text field.

c. Click Replace HotSpot.

4. To add a New HotSpot:

a. Type the text into the Match Text field 

b. Select an Emulator Key from the pull-down menu. 

c. Click Add HotSpot.

5. Repeat the preceding steps for each hot spot change you want 
to make.

6. Click OK.

Note: The Associate with session: option allows you to associate 
the hot spot values with your user ID and the session file 
name. When selected, the settings will apply to all sessions 
that you start with the same WebConnect session file. For 
example, using userid and 3270, your local filename will be 
userid.hs3. If saved for the specific session (as in def3270 for 
this example), the filename would be userid-def3270.hs3.
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The Settings Menu
This section contains information about the options available from 
the Preferences>Settings menu on the Emulation Client menu bar.

The Settings window appears when Preferences>Settings is 
selected. 

Figure 18-154: Settings/Cursor

Tabl e 18 -1: S et ti ng s Opti on s  (S hee t 1 of  3)

M en u Item De fi ni ti on

Audio S ilence A larm Disable Audio Alarm
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Copy/Paste

Copy/Cut

Stream Copy rows.

Block Copy selected columns. The default.

Suppress  Tra il ing  
C arriage Return  on 

Copy

Selections have any trailing carriage returns 
removed. 

Paste

Stream Copy rows.

Block Copy selected columns. The default.

Hybrid

Block paste with word wrapping. Paste
starts at the current cursor location; all
continuing fields start at the same
column location. If starting cursor location
is a protected field the paste is terminated.
Word and rest of the line are wrapped to
next field(s) if it can not fit in current field.

Paste  By  F ie lds  
(St ream/Hybr id Only )

Disabled by default. When enabled
WebConnect detects TAB characters in the
clipboard text. If disabled, TAB characters
will be converted to ASCII SPACE
characters.

Direct  Paste  Mode 
(Ctr l -V  to paste)

Disabled by default. Bypasses any WebConnect key 
mapping for Ctrl-V and passes it directly to the 
browser allowing clipboard data to be pasted into 
the emulation session without use of the 
intermediate dialog. The current paste config 
(stream vs block, etc.) is used to process the 
clipboard data. The administrator can also control 
this through the session configuration.

For more info rmat ion, see ”Copy  and Paste  Features” on  page 208.

Tabl e 18 -1: S et ti ng s O pti on s  (S hee t 2 o f  3)

M enu Item Def in i ti on
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Cursor

Text C ur so r

B linking Cursor Set Cursor to Blink.

Cursor Type
Block (choice)

Underline (choice)

C urso r Behavior
Invert Text Color (choice)

Fixed Color (choice)

Cursor  Color Pick a cursor color.

Rule  L ines

D isp lay Rule  L ines Enable rule lines.

Hor izonta l Display horizontal lines.

Ver t ical Display vertical lines.

Short  L ines Use short lines.

Disp lay
Show Cli ckPad Display ClickPad if enabled.

Show HotSpots Display Hotspots if enabled.

Keyboard

Lock Backspace to F ie ld Prevent backspace out of current field.

Destruc t ive  Backspace Erase when backspacing.

Word Wrap  (3270 on ly)

Disabled by default. When typing in a text field, 
unprotected field, and cursor is at the last location 
on the field, the entire word is moved to the next 
field preventing word splits. A word is defined as 2 
or more contiguous characters separated by 
spaces. 

Mouse Move cursor with  Left  Button 
(3 270/5250 on ly)

See ”Move Cursor with Mouse (Light Pen)” on 
page 255.

Pr inter

32 87 AutoFi t  Printer  Font Automatically correct printer font to fit
page.

Page 
Orientation

Portra it Height of the printed area is greater than the width.

Landscape Height of the printed area is less than the width.

Window Save/Restore Window Posi t ion

Disabled by default. The HTML5 client saves its 
current window position and size whenever the 
window is resized. Due to browser limitations 
simple window relocation are not saved. The 
administrator can also control this through the 
session configuration.

Tabl e 18 -1: S et ti ng s Opti on s  (S hee t 3 of  3)

M en u Item De fi ni ti on
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Cursor Options
A cross-hair cursor makes it easier for you to view full lines of data 
(vertical or horizontal rule, or both) on any emulation screen. To 
select this function, complete the following steps.

1. To activate the cursor options, select 
Preferences>Settings>Cursor from the menu. This option is 
only available to you if your System Administrator has given you 
permission for this setting in your session profile.

Figure 18-155: Settings Cursor Menu

2. You will find many options with this feature as described below:

• Rule Lines: select rule lines off/on. 

• Horizontal Rule: select to view the horizontal rule.

• Vertical Rule: select to view the vertical rule.

• Short Rules: select to view the short rule or deselect to view 
the long rule across the entire screen.
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Figure 18-156: Cross-hair Cursor

3. Select a color for the rule line using the drop-down menu.

Move Cursor with Mouse (Light Pen)
The Light Pen feature is designed to perform on-screen actions with 
or without using the keyboard. You can use it either of two ways.

1. Use Shift + Left Mouse Button (default).

Or you can activate the cursor to mouse operation from the 
Preferences>Settings>Mouse Menu.

2. Enable the Setting>Mouse>Move cursor with Left Button 
(3270/5250 only) feature and click the right mouse button for 
the global Light Pen functionality, as follows. 
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• Click the right mouse button and position the cursor in a light 
pen field to invoke the light pen functionality.

• Click and drag the cursor within a field to invoke the default 
block/highlighted functionality.
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19 HTML5
Componentless 
Client
WC Key Map and 
Macro Editor

The WebConnect Key Map/Macro Editor provides a way to create key 
commands and WebConnect Macro for 3270, 5250, or VT sessions.

Key Commands on page 260.

• Create a keyboard command by assigning a key or key 
sequence to a key combination.

• Allows users to access custom macros or key commands that 
were created by an administrator.

WebConnect Macros on page 263.

• Create a user, session, or server-level macro including basic 
program controls such as goto, input variables, prompts, wait 
statements, and other variables.

• Import, play, or edit pre-defined, third-party macros such as 
“Rumba *.rmc” macros.

You can enable the Macro toolbar to make your macros easier to use, 
see ”Macro Toolbar” on page 47 for more details.
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User Key Map Configuration Window
To use the WebConnect Macro Editor complete the following steps:

1. Select a session (3270, 5250, or VT) from the SESSION panel, 
shown in Figure 19-157, by clicking on it.

Figure 19-157: SESSION panel

2. The session opens in a separate window as shown in 
Figure 19-158.
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Figure 19-158: Key Map Menu

3. Select Edit>Preferences>Key Maps.

The User Key Map Configuration window displays showing a Key 
Commands tab by default, as well as a WebConnect Macro tab.

Figure 19-159: Key Map/Macro Configuration
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4. Select the tab for the one you intend to create or edit for this 
session. See ”Key Commands” on page 260, or "WebConnect 
Macros," page 263.

Associate with session: is grayed out and does not apply to VB 
Scripts. 

Key Commands

Creating a New Key Command
1. Select the Keys tab (default tab).

2. Click Add Key Sequence.

A dialog box appears as shown in Figure 19-160, on page 260. 

Figure 19-160: Create Key Sequence

3. On the keyboard, enter the key or key sequence command you 
want to map. The selected keys automatically display in the 
shaded Key Sequence box.

4. When you have completed the key commands, click OK.

The Key Sequence editor appears as shown in Figure 19-161, on 
page 261.

The title bar of the panel displays the key sequence you entered.

Editing a Key Command
To edit a Key Command complete the following steps:

1. Select Edit Key Sequence. The panel shown in Figure 19-161 
displays where commands can be mapped to the key(s) you 
entered.
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Figure 19-161: Add Key Map Commands

2. Select a command from the buttons menu that you want to add 
to the key command.

3. Click Add after each change.

Note: You can add multiple commands to a key command. Table 19-2 on 
page 261 contains the command menu definitions.

Tabl e 19 -2: M acro  Edi tor  Comman d Descri pti ons  

Comman d Des cript ion

Paus e Use to pause the system for either a time interval or for a user response. User 
response mode allows setting a text message but does not capture any input data.

Funct ion
Add a selected function to this command from a pull-down menu. A definition for 
each function displays in the shaded box. You can find all standard AID Keys, such 
as Enter, Clear, PF1 through PF2 4, PA1, etc., under Function.

Type Define characters and/or strings which are input as keystrokes. Also used to type the 
value of a selected variable or the current user ID and password values.

Play Execute a previously defined macro from a drop-down list.

M ove Moves the cursor to the configured row/column.

Wait Use to enter a wait statement, see "Wait," page 266, Table 19-3 on page 267.

Prompt Prompt the user for input which can be assigned to a variable or sent directly to the 
screen at the current cursor location.

Label Provides a marker to which the Goto statement can direct macro execution.
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4. Click OK when you are finished.

To play a key command use the mapped key or key sequence. 

Goto Add a “Goto” control statement to change the currently executing line of the script 
to “Label.”

Compare
Provides the ability to compare existing variables to each other, or to compare 
constant values and then select a "Goto" branch based on an "equals" comparison or 
a "not equal" value.

Up/Down Use to organize the statements into desired command sequence.

Add Adds the command selected after the current line in the macro.

Replace Highlight a statement and replace one statement with another.

Delete Highlight a statement and delete it from the macro.

OK Save and exit the command configuration.

Cancel Cancel changes to the command configuration.

Tabl e 19 -2: M acro Edi tor  Comman d D escri pti ons   (Con ti nu ed)

Comman d Des cript ion
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WebConnect Macros

Figure 19-162: 3270 Session

Suppose, for example, you want to login to CICS from a current 3270 
session. This would require the following steps.

1. Type CICS and press Enter.

2. Enter your User ID and Password.

3. Press Enter.

Instead, you can create a WebConnect Macro to represent the 
command sequence. By automating the required logon procedures, 
you save time by entering a key command or macro to complete the 
steps.
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Create a WebConnect Macro
1. Select (click) a session (3270, 5250, or VT) from the SESSION 

panel. See Figure 19-157, on page 258.

Figure 19-163: WebConnect Macro Menu

2. From the emulation session, select Preferences>Keyboard 
Maps. 

The Key Macro panel appears. 

The Key Map Configuration window displays a Key Commands 
tab (default) and a WebConnect Macro tab. Select the one you 
intend to create for this session, see "Key Commands," page 260, 
or "Create a New WebConnect Macro," page 265.

Click the WebConnect Macro tab. 
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Figure 19-164: WebConnect Macros Tab

Create a New WebConnect Macro
1. Click New Macro from the WebConnect Macro tab from any 

session type.

The New Macro Name dialog box appears.

Figure 19-165: Name New Macro

2. Enter a New Macro Name and click OK.

The Macro Definition panel appears with the macro name.
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Figure 19-166: Define Macro Action

3. Select tabs and commands to add to the WebConnect Macro.

4. Click Add after each change to the macro configuration.

5. Click OK when you are finished.

6. To play the macro, select Play Macro from the File>Macro 
Rec/Play>Play Macro emulation session Menu.

Wait

Wait provides several formats that allow executing WebConnect 
Macros to wait on synchronized states or specific text messages. The 
following section discusses those formats.

Cursor

Allows you to pause macro execution until the emulation cursor is at 
the defined row/column location. The default time-out value of zero 
(0) waits for an unlimited time. 

By default, the wait starts immediately upon executing the line in the 
script. If the After next AID key box is checked the operation does 
not take effect until after the next AID key has been processed by the 
emulation.

Note: You can add multiple commands to a key command or WebConnect 
Macro. For command menu definitions see Table 19-2 on page 261.
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Wait Text

The Wait Text statement operates in one of two ways determined by 
the After next AID key check box. Having the After next AID key 
checked (enabled) provides backward compatibility with older wait 
text macros or named maps. 

In either case the only required parameter is text in the Wait For Text 
dialog box. See "After next AID key Disabled (Default)," page 267 and 
"Editing macros built prior to WebConnect 6.3," page 268 for details 
about the two modes of operation.

Figure 19-167: Wait Tab

After next AID key Disabled (Default)
Executes the macro until the time-out value (optional) has 
elapsed or text is matched on current host screen.

Tabl e 19 -3: Wa it  Opt i ons —Af t er  n ex t AID key Di sabl ed ( Sh eet 1 of  2)

Op ti on Avail abi l it y De script io n

Wait  For  Text : Required Alphanumeric string

Ignore Case:  Unavailable

At  Row/Column: Optional Enable row and column designation in Row and 
Column below

Unt i l  End Of  Sc reen:  Unavailable
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Editing macros built prior to WebConnect 6.3 

After next AID key Enabled
Executes the macro when text matches that in the Wait For 
Text dialog box on any of the emulation screens as they occur 
until the time-out value has elapse if set.

Allows the macro to continue processing subsequent macro 
statements. AID (Attention Identifier) Keys from the macro 
may navigate to new host screens.

If you do not set either label, the macro execution resumes on 
the next macro statement after matching text or a time-out 
has expired.

Table 19-4 describes the options available with After next AID 
key enabled.

Row:  Available if At 
Row/Column is checked.

Available if At Row/Column is checked. Specify 
exact row where text string is to begin.

Column: Available if At 
Row/Column is checked.

Available if At Row/Column is checked. Specify 
exact column where text string is to begin.

Second(s)  Unt il  T imeout  Optional Time in seconds until the wait is stopped

T imeout  Macro : Optional
The timeout condition can be used to trigger a 
Timeout Macro. Invoking the Timeout macro 
effectively ends the current macro.

After next  AID  Key:  UNCHECKED Disabled (default)

Proceed G oto:  Unavailable

T imeout  Goto : Unavailable

Tabl e 19 -3: Wa it  Opt io ns— Af te r  n ex t AID key Dis abl ed ( Sh eet 2 of  2)

Opt io n Avail abi li t y Des cript io n

Tabl e 19 -4: Wa it  Opt io ns— Af te r  n ex t AID key En able d (S he et 1 of  2)

O pti ons Avai la bil it y Des cript io ns

Wait  Fo r Text: Required Alphanumeric string

Ignore C ase: Optional Ignore case in Wait For Text

At  Row/Column: Optional Enable row and column designation in Row and Column 
below.

Unt i l  End Of  Sc reen:  Conditional Available if At Row/Column is enabled

Row:  Conditional Available if At Row/Column is checked. Specify exact row 
where text string is to begin.
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Keyboard Unlock

The macro execution pauses until the keyboard unlock 
command is received. You can configure the wait to only 
apply after the emulation parses the next AID key. This 
command is mainly used for synchronization purposes.

Clear Screen

The macro execution pauses until the clear screen command 
is received. You can configure the wait to only apply after the 
emulation parses the next AID key. This command is mainly 
used for synchronization purposes.

Create an Open URL Macro (HTML 5 ONLY)
The Open URL Macro opens a URL in a new window allowing you to 
perform operations on a web page.

In this example, we create a macro to extract information from a 
screen, combine it with static text to build a URL and perform a 
lookup at a website. 

1. Select (click) a session (3270, 5250, or VT) from the SESSION 
panel, select Preferences>Keyboard Maps from the emulation 
session. See ”Create a WebConnect Macro” on page 264.

2. Select the WebConnect Macro tab. 

3. Click New Macro from the WebConnect Macro tab.

4. Enter a New Macro Name and click OK.

5. Create the variable to extract information from the screen.

a. Select the Variable tab.

Co lumn: Conditional Available if At Row/Column is checked. Specify exact 
column where text string is to begin.

Second(s)  Unt i l  T imeout  Optional Time in seconds until the wait is stopped

T imeout  Macro: Unavailable

After next  AID Key : CHECKED Enabled

Proceed Goto:  Optional If the wait text cannot be found, Goto statement label.

T imeout G oto:  Optional  If the macro times-out before the text is found, Goto 
statement label.

Tabl e 19 -4: Wa it  Opt i ons —Af t er  n ex t AID key En able d (S he et 2 of  2)

O pti ons Avai l abil i ty De script io ns
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b. Enter a Variable Name.

c. Select the Screen tab.

d. Enter the Row and Column and the Length of the data, 
such as a claim number, you wish to extract from screen.

e. Click Add.

The Define Screen Variable element appears in the macro.

Figure 19-168: Variable Tab

6. Create the Open URL component of the macro.

a. Select the Open URL tab.

b. Click beneath the Define Screen Variable entry to place the 
Open URL expression after it.
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Figure 19-169: Open URL

7. Enter the URL.

8. Click Add Static Text.

9. Enter the Static Text. 

Figure 19-170: Add Static Text

10. Click OK.

11. Click Add Variable. 

12. Select the "Define Screen Variable: acctnum" variable and click 
OK.

13. Click Add. 
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Figure 19-171: Open URL

14. Click OK. 

15. To run the macro.

a. Select File>Macro>Play Macro. The Play Macro dialog 
appears.

b. Select the macro from the list.

c. Click Play. 

The macro executes. 
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20 Desktop Emulator

This chapter contains information about the following subjects:

• ”Desktop Emulator” on page 273.

• ”Installing the Desktop Emulator” on page 273.

• ”Starting the Desktop Emulator” on page 274.

• ”Sessions Tab/Window” on page 275.

• ”Authentication” on page 278.

• ”Basic Authentication” on page 278.

• ”Portal Form Authentication” on page 278.

• ”Proxy Authentication” on page 279.

• ”Updates” on page 280.

Desktop Emulator
The WebConnect Desktop Emulator provides an alternative to the 
browser-based emulator to access WebConnect sessions. It is a 
self-contained emulator that does not require installation of a 
standalone copy of the Oracle Java Run Time. However, it is based on 
the Swing Client (as described in Chapter 15 through Chapter 13) 
and operates in the same manner for emulation. This section 
described the additional features added to the Swing Client to 
support standalone operation.

Installing the Desktop Emulator
To install the Desktop Emulator, complete the following steps:

1. Select DOWNLOADS. 

2. Click Install WebConnect Desktop Emulation Package.

3. Download the WCDesktopApp.msi by clicking the Start 
Download button.
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4. Select Save or Run from your browser’s download manager.

5. Run WCDesktopApp.msi.

The WebConnect Desktop Emulator Setup Wizard appears.

6. Click Next.

The End-User License Agreement appears.

7. Select I accept the terms in the License Agreement and click 
Next.

The Destination Folder dialog appears.

8. Change the default location or click Next.

The WebConnect Portal dialog appears.

9. Enter the WebConnect Portal URL host.

10. Select a WebConnect Portal File Extension from the pull-down 
menu. The choices are asp, html, and jsp.

11. Enter an optional WebConnect Portal File Extension if desired. 

12. Enter optional comma separated WebConnect Portal Cookies if 
desired and click Next.

The WebConnect Desktop Emulator Options dialog appears.

13. Select the Session Display Format using the pull-down menu. 
The choices are Icon and List. 

14. Select a Window Mode of either Single Window with Tabs or 
Separate Windows and click Next.

The Ready to Install dialog appears.

15. Click Install.

16. Click Finish. 

Starting the Desktop Emulator
The Desktop Emulator is installed as a standard Windows application 
and is started in the same manner. A WebConnect Desktop 
Emulator program group is added to the Start menu. Inside of that 
group are two entries:

• WebConnect Desktop Emulator

• WebConnect Desktop Emulator (Console)
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Both entries start the Desktop Emulator. The WebConnect Desktop 
Emulator (Console) also opens a Windows console window to 
display debugging output and other information similar to the Java 
Console with the browser-based clients.

Execution of the installer requires Administration privileges. Normal 
usage of the Desktop Emulator, including automatic version 
updates, requires only standard user permissions.

Window Mode, selected during installation, allows the Desktop 
Emulator to operate in a mode where each emulation session is in a 
separate window or where each is a tab in a single window. 

Sessions Tab/Window
Initially, the Desktop Emulator displays a Sessions Tab or Window 
similar in appearance to the default user interface for browser-based 
users. Unlike emulation tabs or windows within the Swing client, this 
cannot be closed. Depending on the configuration of the 
WebConnect user, the Session may display all available session icons, 
a unique list defined for that user, or folders containing selected 
session icons. Generally, the user sees the same display of sessions 
when using the browser-based default user interface or the Sessions 
Tab within the Desktop Emulator. The tab is titled WebConnect 
Sessions by default, but the title can be changed when the emulator 
is installed (or by a custom portal implementation).

The sessions can be displayed in a grid of icons or in a single column 
of description text with small icons. This display format is selected at 
installation time.
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Figure 20-172: WebConnect Sessions tab

A session is started by clicking on an icon. Right-clicking an icon 
allows the session to be started with Single Session Tracing enabled.

Figure 20-173: Icon context menu
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Figure 20-174: List mode

A right-click within the tab space around an icon displays a context 
menu allowing the Session Tab to be refreshed by reloading the icons 
from the portal.

Figure 20-175: Tab space context menu
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Authentication
Although the Desktop Emulator is a stand-alone Windows 
application, it still communicates with the WebConnect user 
interface to obtain the list of sessions as well as necessary 
parameters when starting a session. These communications are via a 
HTTP web portal. A standard portal is included in the WebConnect 
Server. Customers may also choose to implement a custom portal. 
Depending on the choices made by the WebConnect Administrator 
when deploying WebConnect, it may be necessary to authenticate 
before displaying the Sessions Tab. Additionally, if a client HTTP 
Proxy is in use, authentication to the HTTP Proxy may be required. 

Basic Authentication
If the portal is configured for Basic Authentication, that are User IDs 
and Passwords, the Desktop Emulator prompts for the credentials 
before displaying the main window with the Sessions Tab.

Figure 20-176: WebConnect User Credentials

If incorrect credentials are entered, the dialog is redisplayed. If 
Cancel is chosen, the main window displays with an empty Sessions 
Tab. Without proper credentials, the only useful options are to exit 
the emulator at this time or to refresh the Sessions Tab and provide 
the proper credentials.

For security reasons, this information is not cached from one 
execution of the Desktop Emulator to another.

Portal Form Authentication
If the WebConnect server is configured for Token Authentication or a 
custom portal with forms-based authentication is in use, access to a 
browser page to obtain the necessary authentication cookies is still 
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required. In these situations, the Desktop Emulator opens a 
restricted browser within a window. The browser is loaded with the 
portal authentication page specified within the HTTP response to 
the Desktop Emulator. When the authentication process has been 
successfully completed, the browser window automatically closes 
and the main window with the Sessions Tab is displayed. If the user 
closes the browser window before completing the portal login, the 
result is the same as if clicking Cancel on the Basic Authentication 
dialog.

Proxy Authentication
If Windows is configured to use a client-side HTTP proxy, the 
Desktop Emulator will use that proxy automatically. If the proxy 
requires authentication, the Desktop Emulator prompts for the proxy 
credentials. This prompt is separate from any Basic Authentication 
prompts that may be required.

Figure 20-177: Web Proxy Credentials

For security reasons, this information is not cached from one 
execution of the Desktop Emulator to another.

If a client-side HTTP proxy is combined with Portal Form 
authentication, the browser window may prompt for the proxy 
credentials separate from the Desktop Application, leading to two 
prompts. This is the result of using a standard Microsoft browser 
component for the Forms authentication. It is not possible to pass 
the proxy credentials from the Desktop Application into this browser 
component, leading possibly to two prompts. The Microsoft 
component caches that credential so the double prompting is not 
likely each time the Desktop Emulator is started.
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Updates
When the Desktop Emulator starts, it checks the portal to determine 
the proper version of the emulation engine to use. When this version 
does not match the current version for the user, the new version is 
automatically downloaded and the Desktop Emulator restarted to 
use the new version.

Figure 20-178: Emulation Update
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Glossary

3270 emulation

Imitation of an IBM 3270 computer terminal on a terminal connected 
to a TCP/IP computer so that the imitating system accepts the same 
data, executes the same computer programs, and achieves the same 
results as the imitated IBM terminal.

3270 session

The name of a session when the TCP/IP computer is communicating 
with the host computer through the SNA3270 Presentation Services 
or 3270 TELNET Server.

3287 emulation

Imitation of an IBM 3287 printer terminal connected to a TCP/IP 
computer so that the imitating system accepts the same data, 
executes the same commands, and achieves the same results as the 
imitated printer.

3287 session

The name of a print session when the TCP/IP computer is 
communicating with the host computer through the SNA3270 
Presentation Services or 3270 TELNET Server.

3812 emulation

Imitation of an IBM 3812 computer terminal on a terminal connected 
to a TCP/IP computer so that the imitating system accepts the same 
data, executes the same programs, and achieves the same results as 
the imitated IBM terminal. 

3812 session

The name of a print session when the TCP/IP computer is 
communicating with the host computer through the SNA3270 
Presentation Services.
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5250 emulation

Imitation of an IBM 5250 computer terminal on a terminal connected 
to a TCP/IP computer so that the imitating system accepts the same 
data, executes the same programs, and achieves the same results as 
the imitated IBM terminal.

5250 session

The name of a session when the TCP/IP computer is communicating 
with the host computer through its Presentation Services.

API (Application Program Interface)

A language and message format used by an application program to 
communicate with the operating system or other system program 
such as a database management system (DBMS). APIs are 
implemented by writing function calls in the program, which 
provide the linkage to a specific subroutine for execution. Thus, an 
API implies that some program module or routine is either already in 
place or must be linked in to perform the tasks requested by the 
function call.

APPC

Short for Advanced Program-to-Program Communications. Also known as 
LU 6.2 and based on IBM's SNA, APPC is a communication protocol 
that transaction programs in a distributed computing environment 
can use to talk to each other. 

Applet

A small Java program that can be embedded in an HTML page. 
Applets differ from full-fledged Java applications in that they are not 
allowed to access certain resources on the local computer, such as 
files and serial devices (modems, printers, etc.), and are prohibited 
from communicating with most other computers across a network. 
The current rule is that an applet can only make an Internet 
connection to the computer from which the applet was sent. 
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ASCII

American Standard Code for Information Interchange. A standard 
coded character set, consisting of 7-bit coded characters (8 bits 
including a parity check bit), used for information exchange among 
most non-IBM data processing systems, data communication 
systems, and associated equipment. The basic-ASCII character set 
contains English language characters.

Attribute Byte

The byte used to establish the characteristics of the field that follows 
it, for example, a byte that indicates the following field is blinking, 
highlighted, or unprotected.

Browser

The program that serves as the front end to the World Wide Web on 
the Internet. To view a site, type its address (URL) into the browser’s 
Location field. Type www.computerlanguage.com, for example, 
and the home page of that site is downloaded to your browser. The 
home page is an index to other pages on that site that you can jump 
to by clicking a Click here message or an icon. Links on that site may 
take you to other related sites.

Byte

A sequence of eight adjacent binary digits that are operated upon as 
a unit and that constitute the smallest addressable unit in the 
system.

CSS

Short for Cascading Style Sheets, a new feature added to HTML that 
gives both administrators and users more control over how pages 
are displayed. With CSS, designers and users can create style sheets 
that define how different elements, such as headers and links, 
appear. These style sheets can then be applied to any Web page. The 
term cascading derives from the fact that multiple style sheets can 
be applied to the same Web page. CSS was developed by the World 
Wide Web Consortium (W3C).
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Certificate

The digital equivalent of an ID card. A certificate specifies the name 
of an individual, company, or other entity and certifies that a public 
key, which is included in the certificate, belongs to that entity. A 
certificate's validity can be verified by checking the CA's digital 
signature. Also called digital ID, digital passport, public-key 
certificate, X.509 certificate, and security certificate.

Certificate Authority (CA)

An organization that issues digital certificates (digital IDs) and makes 
its’ public key widely available to the intended audience. A certificate 
is only issued after verifying the identity of the person or entity the 
certificate is intended to identify. A CA also renews and revokes 
certificates and generates a list of revoked certificates at regular 
intervals.

Certificate Fingerprint

A unique number associated with a certificate. The number is not 
part of the certificate itself but is produced by applying a 
mathematical function to the contents of the certificate. If the 
contents of the certificate change, even by a single character, the 
function produces a different number. Certificate fingerprints can 
therefore be used to verify that certificates have not been tampered 
with.

CGI (Common Gateway Interface)

A set of rules that describe how a Web server communicates with 
another piece of software on the same machine, and how the other 
piece of software (the “CGI program”) talks to the Web server. Any 
piece of software can be a CGI program if it handles input and 
output according to the CGI standard. Usually a CGI program is a 
small program that takes data from a Web server and does 
something with it, like putting the content of a form into an email 
message, or turning the data into a database query. You can often 
tell that a CGI program is being used by observing CGI-bin in a URL.
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CGI-bin

The most common name of a directory on a Web server in which CGI 
programs are stored. The bin part of CGI-bin is a shorthand version of 
binary, because executable versions of programs are sometimes 
called binaries. In real life, most programs found in CGI-bin 
directories are text files—scripts executed by binaries located 
elsewhere on the same machine. 

Client

In the TCP/IP network environment, a process that employs (or 
consumes) resources provided by a server. Client is initiated by the 
user when issuing a networking command. The client process sends 
a request for service to a server process on the remote host. If the 
request is honored, a connection is established between the local 
client and the remote server processes. 

Code page

A table that defines a coded character set by assignment of a 
character meaning to each code point in the table for a language or 
a country.

Configurator

The WebConnect automated, menu-driven utility used for 
customizing configuration files for the WebConnect server.

Configuration

(1) The arrangement of a computer system or network as defined by 
the nature, number, and the chief characteristics of its functional 
units. (2) The devices and programs that make up a system, 
subsystem, or network.

Daemon

A program running all the time on a UNIX system.
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Digital Certificate

The digital equivalent to an ID card in the RSA public key encryption 
system. Also called digital IDs, digital certificates are issued by 
certification organizations after verifying that a public key belongs to 
a certain owner. The certification process varies depending on the 
certification authority (CA) that issues the certificates and the level of 
certification.

Domain Name

The unique name that identifies an Internet site. Domain Names 
always have two or more parts separated by a dot. The part on the 
left is the most specific, and the part on the right is the most general. 
A given machine can have more than one Domain Name, but a given 
Domain Name points to only one machine.

E-mail (Electronic Mail)

Messages, usually text, sent from one person to another via 
computer. E-mail can also be sent automatically to a large number of 
addresses (mailing list).

EBCDIC

Extended Binary Coded Decimal Interchange Code. A standard 
mainframe coded character set, consisting of 8-bit coded characters, 
used for information exchange among most IBM mainframe systems, 
data communications systems, and associated equipment.

Emulation

The imitation of all or part of one system by another so the imitating 
system accepts the same data, executes the same programs, and 
achieves the same results as the imitated computer system.
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Extranet

Business-to-business communications. A network that allows an 
organization’s partners and suppliers to interact with corporate 
information and applications. This communication is typically done 
via a public or private switched network or virtual private network, 
VPN.

Firewall

A combination of hardware and software that separates a LAN into 
two or more parts for security purposes.

FTP (File Transfer Protocol)

A common method of moving files between two Internet sites. FTP is 
a special way to log in to another Internet site for the purpose of 
retrieving and/or sending files. Many Internet sites have established 
publicly accessible repositories of material that can be obtained 
using FTP by logging in with the account name anonymous; thus 
these sites are called anonymous FTP servers.

Gateway

(1) A functional unit that connects two computer networks or 
different network architectures. (2) A special purpose, dedicated 
computer that attaches to two or more networks and routes packets 
from one to the other.

Host

Any computer on a network that is a repository for services available 
to other computers on the network.

Host application subsystem

The program running on the host mainframe to and from which data 
is sent and received using the emulated station. Any VTAM 
application which supports 3270 display stations or printers can be 
accessed through the WebConnect server. For 3270 sessions, these 
host application programs include Customer Information Control 
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System/Virtual Storage (CICS/VS), Information Management System 
(IMS), Time Sharing Option (TSO), and Virtual 
Machine/Conversational Monitor System (VM/CMS).

HTML (HyperText Markup Language)

The coding language used to create Hypertext documents for use on 
the World Wide Web. HTML looks a lot like old-fashioned typesetting 
code, where you surround a block of text with codes that indicate 
how it should appear. Additionally, in HTML you can specify that a 
block of text, or a word, is linked to another file on the Internet. 
HTML files are meant to be viewed using a World Wide Web Client 
Program Internet Explorer. 

HTTP (HyperText Transport Protocol)

The protocol for moving hypertext files across the Internet. A HTTP 
client program is required on one end, and a HTTP server program 
on the other end. HTTP is the most important protocol used in the 
World Wide Web (http://www). 

HTTP error code 302

This error indicates to the browser that its desired resource is 
unavailable and provides a new location for the browser to display 
instead. This location will be the URL configured by the 
administrator. This allows any page on any web server to be 
displayed as the result of a user ID failure.

HTTP error code 403

This error code indicates that the requested resource is forbidden 
and browsers will display an error page to the user indicating the 
resource is forbidden.

Hypertext

Generally, any text that contains links to other documents—words or 
phrases in the document that can be chosen by a reader and cause 
another document to be retrieved and displayed.
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IBM channel

In the IBM System/370 and 370/XA architecture, the processor that 
does all of the actual input/output (I/O) processing.

Internet (uppercase I)

The collection of independent and autonomous networks linked by 
gateways that use primarily the TCP/IP protocol suite and function as 
a single, cooperative virtual network.

internet (lowercase i)

Any connection of two or more networks—as in international or 
interstate.

Internet address

The 32-bit address assigned to hosts on a TCP/IP internet.

Intranet

A private network inside a company or organization that uses the 
same kinds of software you find on the public Internet, but that is 
only for internal use. As the Internet has become more popular many 
of the tools used on the Internet are being used in private networks, 
for example, many companies have Web servers that are available 
only to employees. Note that an Intranet may not actually be an 
internet—it may simply be a network.

IP Address (Internet Protocol Address)

The physical address of a computer attached to a TCP/IP network. 
Every client and server station must have a unique IP address. Client 
workstations have either a permanent address or one that is 
dynamically assigned for each dial-up session (see Domain Name.). 
IP addresses are written as four sets of numbers separated by 
periods; for example, 204.171.64.2.
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IP (Internet Protocol)

The TCP/IP standard protocol that defines the basic unit of 
information passed across the Internet.

IP Routing

Protocol routing that provides a virtual connection from one 
TCP/IP-based LAN to another TCP/IP-based LAN through an SNA 
environment.

Java

A network-oriented programming language invented by Sun 
Microsystems that is specifically designed for writing programs that 
can be safely downloaded to your computer through the Internet 
and immediately run without fear of viruses or other harm to your 
computer or files.

JDK (Java Development Kit)

A software development package from Sun Microsystems that 
implements the basic set of tools needed to write, test and debug 
Java applications and applets.

JVM (Java Virtual Machine)

A Java interpreter from the JavaSoft division of Sun. It converts the 
Java intermediate language (byte code) into machine language one 
line at a time and then executes it. The Java Virtual Machine is 
licensed to software companies that incorporate it into their 
browsers and server software. Since it is used on all major platforms, 
Java programs run in most computers. Microsoft also calls its Java 
interpreter a Java Virtual Machine.

Keyboard Mapping

The process whereby the Terminal Emulator maps the IBM 3270 keys 
to the keyboard of the particular display station attached to the 
TCP/IP computer.
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LU (Logical Unit)

In SNA, a port through which an end user accesses the SNA network 
in order to communicate with another end user and through which 
the end user accesses the functions provided by System Services 
Control Points (SSCPs).

LU type

Shortened form for LU-LU session type. In SNA, the classification of 
an LU-LU session in terms of the specific subset of SNA protocols and 
options supported by the logical units (LUs) for that session. The 
3270 terminal emulator supports LUs for display stations (LU type 2) 
and for printers (LU types 1 and 3). The 3287 printer emulator 
supports LU types 1 and 3.

Plug-in

A piece of software that adds features to a larger piece of software. 
Common examples are plug-ins for the Internet Explorer browser 
and Web server. The idea behind plug-ins is that a small piece of 
software is loaded into memory by the larger program, adding a new 
feature. Users need only install the few plug-ins they need, out of a 
much larger pool of possibilities. Plug-ins are often created by 
people other than the publishers of the software the plug-in works 
with.

Port

A place where information enters or leaves a computer, or both. On 
the Internet, port often refers to a number that is part of a URL, 
appearing after a colon (:) right after the domain name. Every service 
on an Internet server listens on a particular port number on that 
server. Most services have standard port numbers; for example, Web 
servers normally listen on port 80.

Protocol

A set of procedures or conventions used to formalize data transfer 
between points.
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PU (Physical Unit)

In SNA, the component that manages and monitors the resources 
(such as attached links and adjacent link stations) of a node, as 
requested by an SSCP via an SSCP-SSCP session.

Security Certificate

A chunk of information (often stored as a text file) used by the SSL 
protocol to establish a secure connection. Security Certificates 
contain information about the certificate owner, the certificate 
issuer, a unique serial number or other unique identification, valid 
dates, and an encrypted "fingerprint" that can be used to verify the 
contents of the certificate. In order for an SSL connection to be 
created, both sides must have a valid Security Certificate.

Server

In a TCP/IP network environment, a process that provides resources 
to a network. The server is the remote host process that services the 
request made by the client. The server is a background process that 
listens for incoming service requests. When a server receives a 
request, it establishes a connection with the requesting client, 
spawns a subprocess, and returns to listening for more incoming 
requests. 

Session

A logical connection between two stations that allows them to 
communicate.

Single Sign-On (SSO)

The Single Sign-On feature operates by scripting logon to 3270 hosts 
and applications. Instead of having to record the log-on sequence 
and store the log-on credentials locally on the desktop, all user 
log-on credentials are stored and encrypted on the server.
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SNMP (Simple Network Management Protocol)

A set of standards for communication with devices connected to a 
TCP/IP network. Examples of these devices include routers, hubs, 
and switches. A device is said to be “SNMP compatible” if it can be 
monitored and/or controlled using SNMP messages. SNMP 
messages are known as PDUs - Protocol Data Units. Devices that are 
SNMP compatible contain SNMP “agent” software to receive, send, 
and act on SNMP messages.

SSL (Secure Sockets Layer)

A protocol designed by Netscape Communications to enable 
encrypted, authenticated communications across the Internet. SSL is 
used mostly (but not exclusively) in communications between Web 
browsers and Web servers. URLs that begin with HTTPS indicate that 
an SSL connection will be used. SSL provides three important things: 
privacy, authentication, and message Integrity.

TCP/IP 
(Transmission Control Protocol/Internet Protocol)

(1) A connection-oriented byte-stream service that is reliable and 
flow controlled (TCP)and a connectionless datagram service that 
transparently forwards messages through the gateway (IP). TCP is 
built on top of IP. TCP/IP protocols are defined by the Department of 
Defense Advanced Research Projects Agency (DARPA). (2) Synonym 
for TCP/IP Application Suite. See TCP/IP Application Suite.

TCP/IP Application Suite

A collective term used for referring to DARPA-standard applications 
commonly distributed with the TCP/IP protocol. Two such 
applications are File Transfer Protocol (FTP) and Terminal Emulator 
Protocol (TELNET).

TELNET

(1) Acronym for teletype network. (2) A TCP/IP protocol used for 
remote login between hosts.
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Terminal

A display station, RJE workstation, or printer.

Terminal emulator

The OpenConnect Server’s SNA3270 Terminal Emulator provides IBM 
3270 Information Display System emulation of IBM 3278 Display 
Stations, IBM 3278 Color Display Stations, and IBM 3287 Printers. The 
5250 TELNET Server terminal emulation emulates IBM 5250 
midrange terminal types.

URL (Uniform Resource Locator)

The standard way to give the address of any resource on the Internet 
that is part of the World Wide Web (http://www.URL.com).

VT emulation

Imitation of a VT220 computer terminal on a terminal connected to a 
TCP/IP computer so that the imitating system accepts the same data, 
executes the same programs, and achieves the same results as the 
imitated IBM terminal.

VT session

The name of a session when the TCP/IP computer is communicating 
with the host computer through its Presentation Services.
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Index

3287
Emulation Client Features, 53, 127, 214
Menu

File, 53, 127, 213
Help, 54, 127, 213
Setting, 54, 127, 213

Print, 66, 138, 223
Print to HTML Client, 200, 202

3812
Emulation Client Features, 54, 127
Print, 66, 202

3812 Emulation Client Features, 54, 127

A
About Keys, 119, 207

About Session, 119, 207

Advanced Options, 75

API, 39

Append, 74, 77, 146, 149, 235, 239

Apple OS, 220

Applet, 42

ASCII, 74, 77, 146, 149, 235, 238

Associated Print, 224

Associated Printer, 200

Attributes, 86, 119
Associate with session, 88

Audio
Silence Alarm, 165, 251
Sound Event, 165, 251

Auto Tab, 198

B
BASIC Script

remove, 109, 188

Binary, 74, 77, 146, 149, 235, 239

Bluetooth Keyboard, 220, 221

C
Chrome, 218, 221

CICS VS Files
Sending and Receiving, 70, 142, 229

Clear Screen, 100, 179, 269

ClickPad, 50, 119, 122, 157, 195, 207

Client, 119, 207
Emulation Features, 204

Client Emulation Features, 44, 69, 116, 141, 227

Color
Associate with session, 86
Preferences, 85
Swing Preferences, 153, 242

Colors, 119

Com, 39

Configuration
EHLLAPI, 46
Key Commands, 93, 95, 96, 97, 98, 99, 174, 175, 176, 177, 
178, 260, 261, 266, 267, 268
Key commands, 97, 176, 266
Key Map/Macro Editor, 91, 171, 257
Light Pen, 88
Light Pen, HTML5 client, 255
Light Pen, swing client, 170
WebConnect macros, 101, 180, 263

Continue Paste, 119

Controller Applet, 42

Copy, 119
and Append, 126
Append, 119
block, 50, 123, 208
Macro File, 106, 186
right-click menu, 126, 212
select field, 50, 123, 208
stream, 50, 123, 208
Suppress Trailing CR, 46

Copy/Cut
Block, 165
Stream, 165
Suppress CR, 165

Cross-hair Cursor, 90
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swing client, 169, 255

Cursor
Menu, 89

HTML5 client, 253
swing client, 166, 168, 254

Mouse, 88
HTML5 client, 255
setting, 88
swing client, 170

Mouse setting
swing client, 170, 255

Move Here, 126
Options, 89

swing client, 168, 254
Settings, 46

Cut, 119

D
Data Set Name, 71, 143, 231

Date/Time
Print to File, 67, 138

Deleting a Macro, 60, 131, 216

Desktop Emulator, 40, 273–280
Authentication, 278–279
Installation, 40
Updates, 280

DFT, 69, 141, 227

Display Language, 38, 39

Downloads, 38, 39

E
Edit

Append, 119, 206
Continue Paste, 119, 206
Copy, 119, 206
Cut, 119, 206
Key Map, 45
Past, 119, 206
See also Copy, 46

EHLLAPI, 39, 91, 167, 171
Configuration Window, 46
enable, 46

Emulation Space, 49, 122, 207

Emulator
Authentication, 278–279

Desktop, 40, 273–280
Icon Values, 48, 120
Toolbar definitions, 48, 120
Updates, 280

error
code 302 HTTP, 288
code 403 HTTP, 288

F
File

Macro, 118
New Session, 118
Print Screen, 118
Save, 118
Session List, 118
Start Print, 118
Transfer, 118

File Transfer, 69, 141, 227
Lists, 80
Multiple, 79

fingerprint, 292

Folders, 26, 28

Font, 46, 54, 167, 168

Function, 97, 175, 261
AID Keys, 97, 175, 261

H
Help, 119

HMTL5
Associated Print, 224

Hot Spots, 83
swing client, 162, 249

Hotspots, 119

HTML, 200
3270/3287 Associated Printer Session, 200
5250, 195
ClickPad Functions, 198
Color Scheme, 197
Keyboard Mapping, 199
print 3287, 200

HTML5
3270, 204
3287, 212
5250, 204
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Attributes
Associate with session, 243

ClickPad Functions, 207
Color

Associate with session, 242
Key Command, 260, 262
Key Maps, 258–260
Macros, 214–218
Preferences, 241

Edit Attributes, 243
Printing, 223
Tablet Device Support, 218
VT, 204
WebConnect Macros, 263–269

I
Identity, 28

IND$FILE, 69, 79, 141, 151, 227

Input Field Validation, 196

Install
Print, 38, 39

Invalid Characters, 34, 35

J
Java, 42

JavaScript, 31

JDK 1.1 Print, 30

JRE, 42
Controller Applet, 42
placeholder, 133

K
Key, 258, 259

Key Command, 94, 95, 174, 260
configuration, 93, 95, 96, 97, 98, 99, 174, 175, 176, 177, 
178, 260, 261, 266, 267, 268
Wait Statements, 97, 176, 266

Key Map
Associate with session, 85
Associate with session, HTML5 client, 250
Associate with session, swing client, 164
Edit, 45

Key Map/Macro Editor, 91, 171, 257

Keyboard
Bluetooth, 220, 221

Mapping, 50, 123, 209
Maps, 206
On-screen Touch, 219, 220
Unlock, 100, 179, 269

Keyboard Maps, 119

Keystrokes
3270 Input, 197
5250 Input, 197
Alpha, 197
Alphanumeric, 197
Numeric, 197

L
Language, 29

Light Pen, 88
HTML5 client, 255
swing client, 170

line rule, 89
HTML5 client, 254
swing client, 168

Log
session to file, 45
Session to Printer, 64, 136
session to printer, 45

Look and Feel, 167

M
Macro, 106, 186

Compare Variables, 97, 176, 262
Copy_Paste, 96, 175
Delete statement, 176, 262
Execute, 96, 175
Goto statement, 97, 176, 262
Label execution, 97, 176, 261
Move, 96, 176, 261
Name, 57, 129, 215
Pause, 96, 175, 261
Play Macro, 97, 176, 261
Play Macro Menu, 57
pre-WC 6.3, 99, 178, 268
Record Play, 55, 128, 214
Record/Play Settings, 45
Record/Stop, 60, 131, 216
Remove statement, 97
Replace statement, 97, 176, 262
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Stop a Macro During Play, 60, 131, 216
toolbar, 44, 45, 46, 47, 118, 206
Type, 96, 175, 261
variables, 97, 175
Wait statement, 96, 176, 261

Menu
Configuration Settings, 88
Menu Bar, 45, 53, 118, 127, 206, 213, 214
right-click, 126, 212, 214
Setting, 46

N
notational conventions, 3

note, defined, 3

O
OIA, 196

On-screen Touch Keyboard, 219, 220, 221

Open URL, 269–272

P
passwords, 34, 35

Paste, 52, 119, 125, 206, 211
Block, 166
block, 50, 123, 208
by Fields, 166
Continue, 119
Hybrid, 166
right-click menu, 126, 212
Stream, 166
stream, 50, 123, 208
Suppress Trailing CR, 46

Platform, 167

Playing a Macro, 59, 130, 216

Pop-up Window Blockers, 42

Preferences
Attributes, 119, 206
Clickpad, 119, 206
Color Configuration, 85
Colors, 119, 206
Edit Attributes, 86
Hot Spots Configuration, 83
Hotspots, 119, 206
Keyboard Maps, 119, 206

Settings, 119, 206
Startup Macros, 119, 206
VB Scripts, 119, 206

Print
Associated Print, 224
Date-Time Stamp, 67, 138
Date-Time stamp, 67
HTML Sessions, 200
Log Session to Printer, 45, 64, 136
log session to printer, 45
Partial Screen, 135
right-click menu, 126
Screen, 63, 135, 223
session, 53
to File, 31
uninstall, 39

Prompt, 97, 176, 261

R
Record, 57, 129, 215

Recording a Macro, 57, 128, 214

Right-Click Menu, 126, 212, 214

rule
horizontal, 89

HTML5 client, 254
swing client, 168

vertical, 89
vertical, HTML5 client, 254
vertical, swing client, 168

S
Safari, 218

Saving a Macro File, 58, 129, 215

Screen
Print, 63, 135, 223
Print Partial, 135

Script Editor, 109, 188

ScrollBack, 167

Select All, 45, 48, 50, 119, 123
right-click menu, 126, 212

Server
Level Key Mapping, 93, 174, 260

Session, 119, 207
controller, 42
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Folders, 26
folders, 28
log to printer, 64, 136
logging, 64, 136
Switching, 212

session
switching, 126

Sessions Tab, 275–277

Sessions Windows Mode, 275–277

Setting
Menu, 46

Settings, 119

Single Sign-On, 32, 67, 139, 292

spool directory, 200

Start Sessions, 25

Startup Macro, 119

Stream, 208

stream, 50, 123

Swing
Attributes, 154, 243

Associate with session, 155
Color

Associate with session, 154
Cursor Options, 168, 254
Preferences

colors, 153, 242
Edit Attributes, 154
Hot Spots Configuration, 162, 249

Settings Menu, 164, 251

Switch to Session, 126

T
Tablet Devices, 218

Toolbar, 48, 120
macro, 44, 45, 46, 47, 118, 206

Trace Keys, 119, 207

Transfer Options, 71, 143, 231

TSO Files
Sending and Receiving, 72, 144, 232

Type ahead, 88
swing client, 168, 254

U
Uninstall

Print, 39

User
names, 34
Preferences, 38, 39
View, 30

user names, 35

V
VB Scripts, 119

creating, 106, 108, 186, 187
editing, 109, 188
import

VB Scripts
Editing, 108, 187

VM Files
Sending and Receiving, 76, 148, 237

VT
session logging, 64, 136

W
Wait Statements, 97, 176, 266

warning, defined, 4

wcemuapi.exe, 39

WebConnect, 264

WebConnect Macro
Associate with session, 93, 173, 260
configuration, 101, 180, 263
Create New, 103, 182, 265
Import, 104, 183
Key Command Configuration, 93, 173, 259
Key Maps, 93, 102, 173, 181, 264, 269
synchronized states, 97, 176, 266
text messages, 97, 176, 266

WebConnect Script Editor, 109, 188

WebPrint, 38
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